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Chapter 1. Getting Started 

Introduction to PCB Artist 
Welcome to the PCB Artist electronic design system. The system is built on an integrated 
design environment providing all the tools required to capture a schematic through to the 
design and layout of the printed circuit board (PCB).  

Introduction to the Tutorial 
You can quickly familiarize yourself with the PCB Artist features available and its design 
methodology by working your way through this tutorial and using the Online Help for more 
detail. 

This tutorial is broken down into logical sections following a typical Schematic and PCB design 
cycle.  

The Schematic design editor is used to capture your logical design and ‘drive’ the PCB design. 
However, the PCB design editor can be used with or without the schematic design as you 
wish.  

An important aspect of the PCB design is the production of professional manufacturing data, 
and hence the final PCB. PCB Artist has the facility to send the manufacturing data directly to 
your PCB supplier. From this data they can produce the final physical PCBs. 

Additional Help 
Help is available in a number of formats; on-line help available by pressing the F1 key on 
your keyboard at any time when using PCB Artist or by emailing/calling Advanced Circuits. 

System Requirements 
PCB Artist runs under the Windows operating systems but it is recommended that Windows 
XP is used. It cannot run under Windows 3.1x or Linux. A Pentium processor faster than 1Ghz 
and with at least 256Mb of RAM is recommended. It should be emphasized that PCB Artist 
does not require particularly ‘high-powered’ hardware to achieve good performance, a regular 
off-the-shelf PC should be sufficient. A complete product installation requires at least 100Mb 
of hard drive space. A mouse with a wheel is recommended and an internet connection for 
downloading the product from the PCB Artist web site. A CD-ROM drive is an option to load 
the product CD if it has been supplied this way. 

Installation 
It is assumed that you have successfully installed the PCB Artist product to your computer 
from the web download. The installation is straight forward using the wizard provided. Follow 
the instructions and use the default settings provided. The tutorial designs are also installed 
to allow you to pick up at key stages of the design process. 
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Removing the Software 
If for any reason you need to remove PCB Artist from your computer, you should do this by 
selecting the Add/Remove Programs icon from the Control Panel on the Start menu. 
Select PCB Artist from the list of installed programs and click the Change/Remove button. 

Starting PCB Artist 
During installation, a PCB Artist program icon is automatically added 
to your desktop and a Advanced Circuits program group added to the 
Start menu and Programs. 

To start PCB Artist, simply double-click on the PCB Artist icon on 
your desktop or select the PCB Artist menu item.  

The PCB Artist Desktop 
When you run PCB Artist, the main application window appears. You can open any number 
and combination of different designs and library items together in this. 

The picture below shows you the major framework facets by name so that as they are used 
in this tutorial you will understand what is being talked about. 
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Toolbars 
PCB Artist is installed with a set of commonly used tools on the toolbars for you to use. 

General Toolbar 

 

Schematic Design Toolbar 

 

 

 

 

If you hover the mouse over the toolbar 
buttons a small tooltip is displayed showing the 
button function and its keyboard shortcut if one 
has been defined. 

PCB Design Toolbar 
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Cancelling Commands 
All dialogs and commands can be cancelled at any time by clicking the ESC key on the 
keyboard. Sometimes this will need to be clicked a couple of times if you are ‘down’ in a sub-
menu or lower-level option. 

Shortcut Keys 
As well as the toolbars, PCB Artist has the ability for you to program your keyboard for 
commonly used options or commands. This means that once programmed, you can press a 
key or key combination to enter a function or option. For experienced users, this makes the 
program's operation far more efficient. 

When PCB Artist is installed, you will find a set of shortcuts defined for you. A full report of all 
the assigned keys can be obtained from the Help menu and Shortcut Keys… option. A 
dialog is displayed to allow you to choose how the shortcut keys are reported. 

 

Units 
The Units option on the Settings menu is used to define the units and the precision at which 
the co-ordinates and lengths displayed in the dialogs and edited by you are displayed. The 
basic working units can be changed using the Units: drop down list.  

 

For each type of units, you can specify a 
Precision:. This is the number of decimal 
places displayed; the value is simply 
rounded to the nearest last digit. 
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Grids 
Grids are used in PCB Artist for defining the points or steps that items will snap to when they 
are placed and for visible references in the design. For this, the Grids dialog on the Settings 
menu contains two sets of grid types: Working Grid and Screen Grid.  

 

The Working Grid page will allow you to 
define the grid used for placement of design 
items during manual interaction. The working 
grid is not visible but the Screen Grid (which 
is visible) can be the same value, hence 
making it appear to be visible.  

 

 

 

The Screen Grid page is used to define the 
display of 'dots' to guide you while designing. 
Size Steps: is used to define the ‘pitch’ of 
the grid and uses the Secondary Color to 
display them. The Primary Color is used to 
display another grid based on a 10 times 
larger size than the Secondary Grid. 

The Visible check box enables the grids to be 
displayed on or off, this can be set at any 
time in the design using the shortcut key 
<G>. 

Snapping to Grid 

The Snap Mode shortcut can be displayed during editing by selecting the direct keyboard 
command <Ctrl-G>. By selecting the snap mode setting you can use predefined multiples of 
the Working Grid to move items for example. 
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Shortcut Menus 
The right hand mouse button can be used extensively throughout PCB Artist to display 
shortcut menus, these are also known as context menus. These menus can be accessed 
during an operation and contain a set of relevant 'context' commands. 

Once familiar with the system, you can access the shortcut menus by right clicking directly on 
the item and picking the option from the menu. 

 

Undo/Redo 
PCB Artist contains unlimited multi-level Undo and Redo capabilities for use through the 
product. Undo can be used to reverse the last operations that have been completed. Undo 
can be used sequentially to undo more than one operation. It can also be a useful and 
flexible tool to interactively try different iterations of an operation, manual component 
placement for example.  

Undo and Redo are invoked using the standard Windows shortcut keys Ctrl-Z (and Alt-
Backspace) and Ctrl-Y respectively. These are also available on the Edit toolbar as buttons. 
Redo is only available once an Undo has been performed, until then, it remains on the menu 
but is grayed out as unavailable. The number of undo levels can be set in the Preferences 
dialog. 
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Properties of items 
Each item in the design contains a set of characteristics which can be viewed or edited using 
the Properties option. Some items within the design are made up of several entities, each of 
which is individually selectable and has its own properties that can be viewed. 

 

Item properties can be viewed by 
selecting the item and clicking on 
the Properties option from the 
shortcut menu. It is quicker though 
to select the item and click the 
shortcut key Alt-Enter. The 
example left shows the Component 
page properties of a PCB 
Component pad. You’ll notice that 
other properties of the component 
are available, such as Component 
and Component Values. 

 

Status Bar 
The status bar at the bottom of the design window displays useful information about the 
design item selected. More detailed information is also available by selecting the item and 
using the Properties dialog from the shortcut menu (key shortcut Alt-Enter). 
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Dockable Windows and Browsers 
As part of the design toolset, you have a number of browsers available through the 
Interaction Bar.  

Each individual browser can be opened by selecting one of the three tabs at the bottom edge 
of the browser. You can access Layers (in PCB only), Component Bin (in Schematics only), 
Goto and Add Component options. 

 

The Interaction Bar is available through the View menu and Interaction Bar <F9> or by 
right clicking the mouse over one of the toolbars or menu bar and selecting it from the 
shortcut menu.  
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Chapter 2. Creating The Schematic 

Schematic Design Tutorial 
During the tutorial we will create a Schematic design; this is how the engineer ‘conceived’ it:  

 

Obviously, once the sketch has been drawn properly as a PCB Artist Schematic it will look 
quite a bit different. 

Starting a New Schematic 

 To start a new Schematic design or a PCB design 

From the File menu, click New (shortcut key Ctrl-N) 

 

Check the New Schematic Design button and the Use Template button. The Default.stf 
template will help you get started quicker. More detail about Template files is available in the 
Online Help. 
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Click the OK button to start a new Schematic design. 

Note: If you intend creating a PCB without a Schematic design (which you can do), just click 
the New PCB Design button and OK. Then skip to the chapter headed, Starting a New 
PCB Design. 

Your PCB Artist window will look like this ready to start: 

 

For now, we will progress on to adding components to the design. 

Adding Components 

 To add a Component 

There are two methods for adding components; we will use the Interaction bar to start 
with, you can also use the Add Component option as well. 

The Interaction bar has automatically been started when creating a new Schematic design. If 
it hasn’t, click the <F9> shortcut key to display it.  

Select the Add Component browser tab at the bottom of the Interaction bar. 
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From the list of available libraries, select the Discrete library. Click on the small down arrow 
to reveal the drop down list and then make the selection. 
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The Component list will be populated with components. Selecting this library will 
automatically select the first component in the list as well. 

 

Scroll down the list of components using the vertical scroll bar. The first in the list is the 
generic ‘C’ component. You can also click in this list and type the first and subsequent letters 
and numbers of the item required. 

Scroll down and select the component R. This is a generic resistor that we will change the 
Value for later on. You can also work with specific named parts if you prefer, both methods 
are acceptable in PCB Artist. 
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A preview of both the Schematic and PCB symbols will be displayed (the PCB symbol is top 
most in the preview). 

Once you have the correct component, you can add it by selecting the symbol preview and 
dragging it into the design. You can also add the component by selecting and dragging its 
name. 

This is a one-shot process. If you wish to add more of the same type, drag another from the 
bin. 

The component is currently on the end of your cursor. To place it in the design, click the left 
mouse button once. 

You need 3 resistors in total for the final circuit. Once the first one has been placed, pick and 
drag 2 more from the Component Browser window. Position then in a stack like the picture 
below: 

 

 To pan & zoom in the design 

To view the resistors closer, roll the mouse wheel button forward to zoom in. If you zoom in 
too fast (and too far), roll the mouse wheel button backwards (slowly). If you zoom too far 
either way, press <A> on the keyboard to View All and then zoom in or out again. Shortcut 
keys are also available for Zoom in <Z> and Zoom out <U>. 

You can zoom while the component is active on the end of your cursor. 

 

Zoom out to give yourself space around the resistors in which to place more components. 
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 To add the capacitors 

We need 4 capacitors for this circuit. From the Add Component browser option again type 
C in the component list. The component name will jump back to the C component in the list. 

 

The preview windows confirm this is the correct component. As with the resistors, this is a 
generic component and we will change its value later on. 

As before, dragging a component from the browser will add another to the design. This time 
only drag out one capacitor to add C1 and then pause. The design will look like this: 

 

We will use a different technique to add more capacitors. 

Select the capacitor C1 in the design. Press the Ctrl-C keys on your keyboard at the same 
time to Copy the capacitor. Now press Ctrl-V to Paste a copy of the capacitor into the design. 
You will see that an identical copy of C1 has been made and is named C2. These are 
standard Windows commands. 



 Chapter 2 – Schematic Capture Editor   19 

 

Move C2 into position and just underneath C1 by moving the mouse. Single click to release. 
Now use Ctrl-V again, to add another capacitor C3 and then again to add C4.  

Your design now looks like this: 

 

Obviously in a design as simple as this, it would have been quicker to drag out 4 capacitors 
but the Copy/Paste principle is worth demonstrating. 

 To switch off the displayed grid 

At this stage we don’t really need to see the displayed grid dots so let’s switch them off. Click 
<G> to toggle the grid off. Press this key again will switch it back on at any time. 

 To add the Op-Amp 

Our design requires an Op-Amp. We will use another technique to add this component. 

Click the Add Component button on the toolbar, shortcut key <F8>. 
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The Add Component dialog will display [All Libraries] in the library path.  

 

We need to swap libraries to use a different one. Click the small ‘down’ arrow on the right 
side of Libraries: to reveal the fully libraries listing. 

 

From the list, select the AD.cml library. 

In the Component: list, type in AD844, this will select the name AD844AN on the list. 
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Click the Preview button to display previews of the Schematic symbol and PCB footprint. 

 

Click the Add button to add an opamp to the design. 

Depending on your current zoom level, you may need to roll the mouse wheel to zoom out a 
little. You will need to give yourself some space on the design in which to place this new 
component. 

Our Op-Amp (U1) is shown in the design on the end of your cursor as two gates (a & b).  
Gate a is defined as the logic gate and gate b is the power gate for this component.  

 

Click the mouse once to place the first gate. The second gate (power) will now be dynamic on 
the end of your cursor ready for placing. Place it near gate a, we will move it later on. 

Click the Esc key to cancel this option. 

Your design should look something like this: 
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Before we make the connections we should change the component values to be the ones 
required. This is easy to do because we’ve used ‘generic’ components. If you prefer to use 
specific Part named components, you can also work this way with PCB Artist. 

 To edit component Values 

Double-click on the Value field (1K), the Text tab of the Properties dialog is displayed.  

 

Click on the Component Values tab. 

The Value field shows the current 1K value and is already highlighted. Simply click the Edit 
button or double-click the blue highlighted field to edit the value required.  



 Chapter 2 – Schematic Capture Editor   23 

 

Type in 11K. 

When done, click the OK button to exit this dialog and OK again to exit Properties. When 
the value of R2 is changed to 11K the design is updated. 

Using the same process (double-clicking on the Value name), edit the Value fields for all R’s 
and C’s in the design as shown below: 

 R1 1K R2 11K R3 1.6K 

 C1 68nF C2 200nF C3 0.22uF C4 0.22uF 

Our design now looks like this: 

 

If you select the whole component by mistake, you can still edit the Value field by clicking 
Component Values tab on the Properties dialog. 

 To add a drawing border to the design 

At any time you can add a drawing border to the design. We will add one now. 
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Using the Add Component Browser again (<F9>), select the Schema library from the 
drop down list. For reference, this is a schematic only component library and will not have 
any PCB symbols associated with them. 

Scroll down the list and select the Letter drawing border. This has been previously created to 
fit a Letter page size. 

 

Like other components, pick Letter from the list or from the preview. Drag it into the design 
and position it on top of the existing components. You may need to zoom out a bit to see it. 
Use the <Z> key to zoom out or <A> to view all of the design. For speed you can also roll 
the mouse wheel. 

 

As with other components, this can be moved later if you need to. 
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 To save the design 

At this stage it might be a good idea to save your design. Go to the File menu and select 
Save As. Save it to the Examples folder and call it something sensible, like Tutorial.sch. 

Placing Components 
The position of the components currently is as they were placed after adding them to the 
design. We need to place them around the Op-Amp so they can be used in our circuit. On a 
real design, this would be how you would work in practice. To remind you, the original 
‘drawn’ circuit looks like this: 

 

As before, move the components into position by picking and dragging them in one move 
using the mouse. 

Components can be rotated during move by clicking the <R> key. A single click of the R key 
will rotate the component by 90 degrees. Click R more than once to rotate it by another 90 
degrees and so on. 

Note: You can also change the placement to fine tune it after adding the connections as well. 

The design will now look like this: 

 

You are now ready to add connections. 
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Adding Connections 
Connections are added to the Schematic design to make connectivity between electrical pins. 
When translated to the PCB design, these connections give you your net list. 

You can add connections in a number of ways: 

 Using the Add Connection option from the Add menu or from the Schematic 
Toolbar, click on the pin to start adding a connection, or; 

 Double-clicking on a component pin to start a new connection, or; 

 'Dragging' off an unconnected component pin to start a new connection. 

For this tutorial we will use the ‘dragging off pins’ method as this is the easiest to start with. 

 To add connections by dragging off pins 

To aid the addition of connections to a schematic, you can simply ‘drag’ off an electrical pin, 
each click of the mouse will then add a corner. Moving over another electrical pin will allow 
you to finish the connection. 

Using the design that you have created so far, zoom in on the area around R1 like the picture 
below. 

 

Click and drag (keeping the mouse button pressed down) off pin 2 of R1, this will start a new 
connection. Move the mouse over U1a pin 2 and single click to finish. 

 

You do not have to be exactly over a pin to finish a connection; as long as the cursor is within 
range then it will snap onto the terminal.  

Click the mouse button once to finish. You’ll notice that the component pin terminals X 
disappear when you connect to it; this indicates that it is connected. 

 To join connections together 

There are a couple of connections which must be connected together. Let’s assume that 
you’ve made a connection and now you need to connect another to it using a junction dot. 
When you attempt to finish a connection on an existing connection, when you release the 
mouse, the connection will automatically be added (as if it were an electrical terminal) and a 
junction dot displayed to indicate it is connected. 

Following our sketched design above, complete the design adding the connections required. 
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Adding Power & Ground Symbols 
Power and ground symbols are used in the Schematic to indicate a connection to a power 
source. These symbols are required for aesthetic purposes and are not translated to the PCB 
(because they do not have PCB footprints associated with them). The signals they represent 
are connected together at the translate stage by ‘implied’ connectivity. The power & ground 
symbols themselves can contain inherent net name properties that are automatically used 
when the symbol is attached to the net. 

 

 To add Power symbols 

Using the Add Component browser on the Interaction bar <F9>. 

The Schema library will still be selected after using it previously when adding the Letter 
component. If for some reason it isn’t, select it now from the library list. 

In the Component list select 0V. You will see the symbol selected in the preview box. 
Remember, all of these symbols have no PCB Symbol associated with them, they are 
Schematic only symbols. 

 

Drag the 0V symbol into the design from the browser. Move it near to C4 and click the 
mouse to release it. 
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Using our working design, add 2 more 0V symbols. From the Add Component browser, this 
time add one +15V symbol and place near C3. Now add one -15V symbol, place it near C4. 

Drag a connection off the end of the symbol terminal and connect as shown below. 

Your design will look something like this: 

 

Generally speaking you would now need to add some connector pins to connect the circuit to 
the outside world. 

Adding Connectors 
For this example, we will use a connector component from the library. 

 To add Connector pins  

Using the Add Component browser from the Interaction bar <F9>. Choose a new library, 
select the Conn_std component library. 
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Select the 5WP connector component from the list. The PCB Symbol and Schematic Symbol 
previews will be displayed. 

 

Drag it into the design and place it near the resistor R1 as shown below: 

 

Connect in the connector to the design using Add Connection or by dragging off a pin. You 
will also need to add another +15 component for completeness. Your design should look like 
this below: 
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Click the Save button on the File menu to save the design. 

Naming Connections 
One last task that is often required is that of naming connections in the design. We’ve added 
‘normal’ connections which have been named using the default naming convention and have 
been given ‘system’ names like N0005, N0100, N008 etc. We’ve also added connections 
between pins and components that have pre-defined net names (power and ground 
components, +5V, 0V etc.). 

We now need to name a few connections to make them more specific for use in the PCB 
design. 

 To edit net names  

Select the connection just off pin 7 of the Op-Amp’s power gate, the gate marked as U1b. 

Right click and from the shortcut menu, select Change Net… 
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From the dialog now displayed, select the Net Name: +15V from the list. 

From the Net Class: list, select Power. This will pre-assign you a set of connection 
properties for this net when it gets used in the PCB portion of the design. 

 

Click OK and return to the design. 

If you wish to see the Net Name in the design, right click again with the connection selected 
and choose Display Net Name from the menu. The net name will now be displayed in the 
design, you may reposition it if required by picking and dragging it. 

If this is difficult to select because you accidentally pick the wrong item, press the <N> key 
to select Next. The next item in the picking tolerance will be picked. 

Now select pin 4 on U1b. Using Change Net again, this time select the net name -15V. 
Select the Power Net Class again. Click OK to exit this dialog. The Net Name can be 
displayed using the method above if required. 
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Your Schematic is Finished 
The schematic design is complete. You may wish to print it to check it, use the Print option 
from the File menu. 

The next stage is to convert the design into the PCB design environment. To do this, move 
onto the next chapter Chapter 3. - Converting Your Schematic To PCB 
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Chapter 3. Converting Your Schematic To PCB 

Converting the Schematic to PCB 
If you created a Schematic in PCB Artist, the final process before starting on the PCB design 
itself is to translate the Schematic design into the PCB design editor.  

When you are in a position where you wish to go-ahead with this translation you should 
select Schematic <- - > PCB > and use the Translate To PCB option from the Tools 
menu. 

 

This will display the New Pcb wizard. 

Starting a New PCB Design 
If you intend starting a new PCB design without using a Schematic design first (which you are 
quite able to do), from the File menu select New and check the New PCB Design radio 
button. Click the OK button and this will start the New PCB Wizard. 
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The New PCB Wizard 
This wizard is a set of dialogs which you step through in sequence to define aspects of your 
design in the PCB design editor. The online help is available for each page by pressing the 
<F1> key at any time. 

Click Next > to move onto the next page. You can also click the page name you require in 
the list at the top left hand side of the page but is recommended to work through the wizard 
pages in sequence. 

 

The Board page allows you to define the Units used in the design and the board size. If your 
manufacturer has supplied some template designs with commonly used board outlines, they 
will be presented in the Use Board Template list for you to choose from. 

For the tutorial, select the Use Pre-Defined Board Size radio button and select 2.000 
inches x 2.000 inches from the list. Click Next > 

 

The Service page is used to select a named service. This is used to predefine ‘standard’ 
services that we provide or to customize the service required. 
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Using a Standard Service will enable you to place an order directly using the Submit Order 
option. If defining a Custom service, you will have to get a quote from the Submit Order 
dialog before proceeding with the order. 

 

The Layers page is used to define how many layers the design contains and how they look 
when manufactured. Remember that the number of layers used will also be a factor when the 
cost of the board is calculated. 

Leave the setting of 2 Layer Board for Electrical Layers and all other settings for now. 

 

If you had selected a greater number of layers than 2, 4 or 6 for example, you would need to 
also select how the inner layers would be used. If you wish to use the inner layers as power 
planes, check the Powerplane Layers check boxes and enter the net name associated with 
that layer. For the example below, we have selected both Layers 2 and 3 and have assigned 
them plane net names of GND and +15V respectively.  
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Click the Next > button to continue. 

The Board Parameters page is used to define the material used to manufacture the final 
PCB. 

Use this as it is for now. Click the Next > button. 

 

Additional Requirements is used to tell the manufacturer about any special requirements 
using the notes window into which you can type your message. 

You can specify Electrical Testing and Component Assembly as ‘cost’ options. 
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The Production page is used to specify how fast you require the board and the production 
quality and quantity. The cost of the PCBs, if available, is shown in the cost box. 

 

The Place And Route page is shown if you are transferring a schematic. It allows you to tell 
the PCB editor what to do with the parts and nets once in the PCB design. You can opt to 
place components and route them automatically, or just leave the placement and routing for 
you to do manually. 

For the tutorial we will change the settings to allow you to do the placement and routing 
manually once in the PCB design editor. Select the Arrange Around the Board button. 

 

Click the Next > button. 

The Finish page allows you to give your PCB design a name and to save it to a file in a 
chosen location. 

Click the Save the PCB Design To File check box and type in a suitable name. You should 
give it the same name as the schematic, but with the .pcb file extension Tutorial.pcb 

Click the Finish button. 
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At any time you can go back to one of the previous pages by selecting the page name form 
the list displayed. 

When you click the Finish button, the PCB design editor will run up and your PCB design will 
be ready for use.  

Schematic Design Completed 
You have now completed the first section of this introductory tutorial so let’s move on. Leave 
everything as it is and read on if you wish to continue with the PCB design tutorial. 
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Chapter 4. PCB Design Editor 

Getting Started with the Design 
PCB Artist PCB is flexible in that you can start your layout in two ways: 

 Use PCB Artist Schematic Capture as the 'front-end' to the PCB system. The nets and 
components are converted to PCB in the integrated environment. 

 Use the PCB Artist PCB design editor interactively creating the design on-the-fly 
without the need for an initial netlist. You just add components and connections as 
required to create the PCB design. 

Converting the Schematic to PCB 
If you are following the tutorial, you would have already processed your ‘logical’ Schematic 
design into the ‘physical’ PCB design layout editor using the Schematic To PCB wizard. If 
you didn’t do this, go back to the previous chapter (Chapter 3 - Converting your Schematic to 
PCB) and convert your schematic into a PCB design. 

At this point you are ready to start laying out the PCB design. You will see the board outline 
ready to place the components in. We previously chose to leave the components unplaced 
and the nets unrouted. These two features can both be selected during the final conversion 
process. 

 

The board outline is displayed with the components stacked neatly at the top edge ready for 
placing. 
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Changing the Number of Layers 
If you decide at any time to change the number of physical layers or the type of 
manufacturing, you can do this using the Settings menu and the PCB Configuration 
option. 

This opens a reduced page set of the New PCB wizard where you can edit the parameters of 
the finished PCB. Be aware that reducing the number of layers could lead to items on the 
inner electrical layers being lost. 

Creating a Board Outline Interactively 
If you require a custom board size and shape, and decide not you use one of our pre-defined 
templates, this can also be easily achieved. 

Deleting an existing board outline 

PCB Artist only requires one board outline so you would need to delete any previous one first. 
You can edit an existing board outline as well. If you do need to delete it, simply select the 
outline and click the Delete button on your keyboard. 

Adding a new board outline 

Board outlines can be created easily in PCB Artist; by adding board shapes (including circles). 
The Add Board option on the Add menu allows you to interactively create a board outline by 
drawing it into the design. Three shape styles are provided: Rectangle, Polygon, and 
Circle. There is also a shortcut on the PCB Design toolbar to add a Board Polygon. 

Board outlines are created as a Closed shape so during addition, you’ll see the ‘trailing’ board 
segment trail back to the start point. Click to add corners. After adding the last corner, use 
double-click to finish. If during the insert, you wish to cancel, click the Esc key on the 
keyboard. This will create you a board outline as a continuous shape starting and finishing at 
the start point.  

Once the board has been added, it can be modified afterwards, extra segments can be added 
and the corners can be mitred or made curved. 

For this tutorial, we would have specified the board outline from one of our templates 
available during the Schematic To PCB conversion process earlier. If you require cutouts in 
your board, add these using the Add Board Shape option. 

Placing Components 
We’ve started the design with the board outline and are now ready to manually place the 
components. This can be an automatic process either from the conversion phase or by using 
the Auto Place Components option from the Tools menu. For this exercise we will use the 
manual placement method. 

Placing components uses the Place option and because PCB Artist uses standard Microsoft 
Windows methodology throughout, Place is simple case of picking and dragging the selected 
component. 

Note: during place the drag may be cancelled by pressing the Esc key, or once released by 
using Undo (Ctrl-Z). 

Place all the components to look like the picture below (note, we have changed the 
background color of the design for this document for clarity). It is suggested you place PL1 
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and U1 first and place the other components around these. Placement on this design isn’t 
critical but improve it if you feel you can or want to. 

 

During Place or after placing components, use the shortcut key <R> to Rotate them and <F> 
to Flip (mirror) surface mount components to the other side of the board. These options (and 
more) are available on the shortcut menu during Place by clicking the right mouse button. 

 

For our design, no mirroring (Flip) will be required. The placement and overall connection 
lengths could be improved by rotating some of the components. If you feel you would like the 
practice placing components, select a component and click <R> to rotate it. Component 
names can be rotated back to be a readable direction separately using the same pick and 
rotate method. 

Once fully placed, the design should be routed. 

Routing the Design 
The design can be routed manually or automatically. This is the process of converting the 
electrical point-to-point connections into physical copper ‘tracks’. 
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Initially we will route the design automatically to see what the result looks like and to try this 
option. We will then Unroute is back to the ‘rats nest’ and use the manual routing tools to 
route. 

Automatic Routing 
The Autoroute option is used to convert your nets into electrical tracks as you can with 
manual routing. However, on dense designs it can save you many hours or days of work. The 
autorouter can take an unrouted design and route it within minutes quite often.  

You can use the autorouter in many modes; on All Nets in the design, on Browsed Nets, 
Browsed Net Classes, on selected nets and on components. 

 To use the autorouter 

From the Tools menu under Auto Route Nets>, select All Nets.  

Leave the default settings as they are: 

 

Simply click the Route button at the bottom of 
the dialog to start the router. This small design 
will easily route 100%.  

 

The results are quickly displayed: 

 

Click OK to close the report dialog and view the 
routes. 

The routed design might look something like this below. This will vary depending on how you 
placed the design. 
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 Save the design 

The PCB design has already been named when you translated from Schematic to PCB, we 
named it Tutorial.pcb. We named it this so it matches the name of the Schematic. This will 
become more important later on when you run the integrity checks before plotting. 

For now, click the Save icon on the toolbar or Save from the File menu. 

Unrouting the design 
You may sometimes have a requirement to unroute all or part of the design. Unrouting is the 
process of removing tracks leaving only the connections remaining. 

The Unroute Nets> option is available on the Tools menu, with three options available to 
control the amount of unrouting to perform. 

 Unroute the design 

Use the Unroute Nets> All Nets option to unroute the whole design removing all the tracks 
already done. Don’t forget, once unrouted, you can always restore the routes using Undo 
(Ctrl-Z). 

Manual Routing 
PCB Artist has a set of powerful manual routing tools to aid this process. These tools allow 
you to swap layers, automatically add vias on layer swaps and edit track thickness. 

The routed board might look something like this (the colors are still changed to that in your 
design for clarity in this tutorial): 

 

 To start routing tracks manually 

To start adding tracks, double-click on a connection, this is the quickest method to start 
routing, other methods are available. 
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If you followed our design placement loosely, 
double-click the connection between C3 pin 1 and 
C4 pin 1. 

 

Move the cursor to the down and right slightly. 
You’ll see the track starting to take shape and a 
connection between the end of the track and the 
‘target’ pad (C4.1). In this mode, the track is 
placed orthogonally at 90 degrees with two 
floating segments. 

 

 

Move the cursor down to draw the vertical track 
segment. The track is still being placed with 2 
segments and a 90 degree corner. 

 

Click the mouse once, this places the first track 
segment (the straight track segment coming out 
of C3.1). This is temporarily ‘locked’ in place for 
this routing session. It can be moved or edited 
later on. 

 

 

Now we will add a track layer change. 

Press the ‘L’ key on the keyboard and the Track 
Layer dialog is displayed. During normal routing 
where a layer change from one side to the other is 
required, a simple ‘L’ followed by <Enter> is all 
that is required. The Enter button is the same as 
clicking OK on the dialog. In time you will be able 
to change layers without looking at the dialog. 

 

 

A via has been added automatically and the track 
layer is now on the Bottom side. This will be 
displayed on the Status bar at the bottom of the 
PCB Artist window. 

 

 

 

Move the cursor right and click again. 
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This will either be the next corner or the next 
location for a via for a layer change. Notice the 
track has changed color. 

 

 

Press ‘L’ and <Enter> again to change layers 
back to the Top layer. Another via is added 
automatically. 

 

 

Continue moving the cursor right towards the 
target pad C4.1. Notice how it is on the Top layer 
shown in Red. 

 

Once over the target pad, click once to finish the 
track editing for this connection. 

After the track has been added, it can always be 
modified afterwards by picking and dragging the 
track or by double-clicking on the track to edit it. 

Move onto the next connection for editing. 

Summary of the basic modes of routing 

During track editing, the basic commands for use are:  

 Single-Click, once editing, this will insert a corner to change routing direction. 

 L followed by <Enter> will enable a layer change to the opposite side of the design. 
This can be used during editing, or afterwards on selection of a track. 

 To change manual routing modes 

You would have been using the standard routing mode of Orthogonal routing (two ‘floating’ 
segments at 90 degrees to each other).  
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This mode can be changed by accessing 
the routing mode during routing. Select 
the Segment Mode> from the shortcut 
menu and choose the mode from the 
choice of five available. 

 

 

On our example design, the routing may 
now look like this using the Mitre mode. 

Picking in tight areas 
When attempting to select items within a dense area of the design or where multiple 
connections cross each other for example, it is not always easy to pick the item required at 
the first attempt. Under these circumstances PCB Artist has a system of picking that 'cycles' 
through items adjacent to it until you select the item required. Once selected, an action may 
be made on that item, Properties for example. 

The shortcut key used for the command Select Next is defined as N for Next. 

 

To try this, click on a pad that has a track attached to it, the pad (or track) is selected. Now 
click <N> and the track (or pad) will be selected. Depending on how close it is to other 
design items, the component outline and the whole component may also be selected at each 
click of <N> is made. 

Pouring Copper into Areas 
Copper Pour is used to flood areas of a PCB layout with copper, usually connected to a 
nominated signal through ‘thermal’ connections, typically Ground (GND) or VCC. This facility 
will then create voids around tracks, component pads, vias and other electrical obstacles.  

For this we have the Add Copper Pour Area and Pour Copper options. 

If a copper area is to be inserted without the need for voids around unconnected tracks, 
components or pads, the Add Copper option can be used. 
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The principle of this facility is to insert a Copper Pour Area and ‘pour’ the copper into this 
area. 

 To create a Copper Pour Area 

From the Add menu, select Copper Pour Area> Rectangle Other Pour Area options are 
available for adding different shapes. We will add the pour area to the Top Copper layer. 
pour areas and poured copper can be added to any electrical layer. To change layers, select 
the pour area and click L followed by <Enter> as we did when editing tracks. 

The shape can be created on the design and the pour area can be drawn protruding outside 
the board outline. PCB Artist will pour the copper using the Spacing rules and rules defined 
for the Pour area. 

Following the picture below of our example, draw in a basic rectangle pour area shape, this is 
shown in black in the top left hand side of the design: 

 

For this example you will see how easy it is to add a poured copper area. 

Right click on the pour area. 

From the shortcut menu select Pour Copper. 
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A dialog is displayed from where you can select parameters for the poured area, such as the 
net name association and thermal connections etc. 

 

For this exercise, leave the Net Name blank and simply click OK. 

Notice that the poured copper has obeyed the Spacing rules of all defined items to copper 
including Board to Shape rules. 

 

 To remove poured copper from a copper pour area 

To remove a poured copper area (including any thermal spokes), simply select the area 
outline and select Clear Copper from the shortcut menu. This removes the copper but not 
the Copper Pour area. 
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When using poured copper remember you shouldn’t use Delete but should always use Clear 
Copper. Copper Pour Areas can be modified at any time and the area re-poured using the 
option from the shortcut menu. If you wish to completely remove the copper and area, you 
must use Clear Copper first and then delete the area afterwards using the Delete key.  

 To make the copper Pour Area intelligent 

There are more facets to the poured copper than we have discussed above. The poured 
copper can also have a net name associated with it so that when poured, pads are connected 
via thermal spokes to the copper itself. To do this, select the pour area and from the shortcut 
menu select Add To Net. Select the net name required from the list and then re-pour the 
copper. Try it again using 0V as the net name and click OK. 

   

Using the Thermal Pads check box and the Spokes settings, the style of how the copper is 
connected to pads can be defined. 

Copper Pour Areas will not appear on your manufactured boards, they provide the system 
with an intelligent area into which the copper can be poured. 
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Checking the Design Integrity 
Various checks are available in both the Schematic and PCB editors on the Tools menu. This 
is used to compare and verify designs and make changes in the PCB so that they are both in-
sync with each other at all times. 

 To check the designs  

You can use the Consistency Check option from the Schematic < -- > PCB > menu on the 
Tools menu at any time. By default, the file used for the comparison will be the same name 
as that used for the Schematic (or PCB design if running from the Schematic editor). 

When run, if there are no differences, the following dialog is displayed: 

 

If differences are found, Notepad will be run to view a detailed report. The report will give 
you a list of changes that would have to be made to the PCB in order to make it match the 
schematic (the schematic always being the ‘master’). You can then perform these changes 
automatically by selecting the Yes button on the dialog. 

 

Run this option on our tutorial design, there should be no differences. If there are, click the 
Yes button and make the changes. 

 To back annotate name changes to the Schematic  

Back annotation changes can be made in the PCB, and these can be passed back to the 
schematic also using the Back Annotation option from the Tools menu. When run, it will 
report and allow you to perform any back annotation changes to the Schematic that are 
‘pending’. 
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Design Rules Checking 
Before sending your design for manufacture, you must run the Design Rules Check option. 
This dialog contains check boxes that enable various checks to be made. The checks are 
made against the Spacing rules defined. This is also used to check various manufacturing 
rules have been obeyed.  

When errors are found Error Marker letters are added to the design on the appropriate layer 
to help you find and correct the actual error. 

 To run a Design Rules Check 

Select the Design Rule Check option from the toolbar. 

 

 

  

A dialog is displayed that allows you to control which items are 
included in the check. Click Check to run the DRC. 

 To locate DRC error markers 

After running a design rules check, you can find the error markers in the design using the 
Goto browser. This is available on the Interaction bar by pressing the F9 key. 

When the Goto browser is displayed, from the list of available Goto options, drop the list 
down and Select Error. 

 

This list is used to view all the design error makers as 
a sorted list. It is displayed in an 'active' browser, 
click to select an error, you can locate the error 
maker in the design. If the error marker is off the 
screen, it will be brought into the centre of the display 
so it can be seen. 
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Viewing Power Plane Layers 
If you have included powerplane layers in your design on the inner layers, before you send 
off the PCB design for manufacture, it is worth running a visual check of the thermal 
connections. This visual check will validate any potentially missing thermal spokes where a 
pad to copper connection has not been made. Where a pad to copper cannot be made 
because of design restrictions, the thermal spoke will not be added. Your check will identify 
these missing connections. 

To do this, select the Powerplane > option from the View menu. Select Show… 

 

From the list of powerplane layers, select the layer required.  

 

If we select the +15V layer for our example, the plane will look like this: 

 

Once finished, select the View menu and use Powerplane > Hide to switch it off. 
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Reports, Part Lists and Net Lists 
PCB Artist can generate reports where all vital aspects of the design can be output in detail. 
The reports also include a set of ‘standard’ reports like Component lists and net lists.  

These reports are all available on the Output menu. 

In Schematic editor: 

 

In PCB design editor: 

 

 

During your testing of the options, run the reports to see what they can produce for you. 
Each report will be displayed using Notepad, close the report once viewed. 

Manufacturing the PCB 
PCB Artist provides you with an output mechanism for sending your order and design to 
Advanced Circuits to be plotted and manufactured. 

Using the Submit Order from the Output option, the design is checked. If DRC errors exist 
in the design, a dialog is displayed: 

 

You should check the design and ensure that all known errors are corrected. 

The Submit Order dialog is displayed. Fill in the order information. The asterisk at the end of 
a field means the information must be provided. 

Use View PCB Configuration to get a report of the manufacture options you have selected. 
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Click Place Order to send your order direct to our web site. Click Get Quote if the price is 
shown as unknown. This will take you to our web site to get a quote for a custom 
manufacture. 

Click Email Order to send your order to our sales desk using email. 

For all options, a copy of the design will also be sent with the order. 
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