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ProLase XP Software Update for LMV1000(G)(E) Laser Markers 

 
The procedure written below assumes that the person performing the software 
upgrade has working knowledge of the Windows Operating System and knows all of 
the basic commands and operations necessary to perform this install. An incorrect 
install is the responsibility of the computer operator and is in no way the 
responsibility of the Miyachi Unitek Corporation. Perform this upgrade at your own 
risk. If you are unsure about any step in the installation procedure, please contact 
Miyachi Unitek or refer to a qualified computer technician to perform the upgrade. 
Please read the entire procedure first, before attempting to upgrade the software. 

 
Introduction 
We recommend all customers update their ProLase XP software to enable new features and 
eliminate all known software bugs. This procedure addresses how to update all versions of ProLase 
XP including; ProLase XP, ProLase XP Plus, ProLase XP Server and ProLase XP Plus Server. 
 
To date Miyachi Unitek has released 4 different versions of the ProLase XP software. The overall 
hierarchical structure of each software revision is slightly different; therefore it is important to 
follow the instructions written below explicitly for a trouble-free upgrade.  
 
A summary of all released ProLase XP software revisions is listed below. There are basically two 
ways to determine the version: (1) from the Help pull-down menu choose About ProLase…  or (2) 
note the “modified date” of the LasePS.exe file properties using Windows Explorer. 
(the LasePS.exe file is located in the C:/Program Files/American LaserWare/ProLaseXP subdirectory) 
 

MUC Revision ProLase XP Version ProLase XP build date LasePS.exe modified date 
A 4.23 3-27-04 3-26-04 
B 4.23 3-27-04 3-26-04 
C 4.710 12-15-05 12-15-05 
D 4.854 1-23-07 1-23-07 

E (update) 4.901 10-26-07 10-26-07 
 
In all cases, once the software update is complete, the revision will be version 4.901. 
 
As with all software upgrades it is best to record and back-up your current software system. This 
not only provides a path back to the factory original condition, but also maintains the integrity of 
your original files. Once the upgrade is complete, all associated ProLase system files will be 
modified and will no longer operate properly if your system is restored back to the factory original 
condition. (i.e. once the upgrade version of ProLase XP is started, these system files will not be 
backward compatible). 
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Update Procedure 

 
Note: Before starting this procedure, be sure to turn off power to the Laser Marker. 
 
If ProLase is not operating correctly… 
If ProLase XP is not operating correctly, delete the default.pre & lasexp.ini files, located in: 
 C:/Program Files/American LaserWare/ProLaseXP/default.pre 
 C:/Windows/LaseXP.ini 
Then change the PC date back one month, before proceeding. Try to get ProLase XP to operate 
correctly before continuing with this procedure. If you cannot get ProLase to run, skip to step 5. 
 
1. Save your current system configuration (.cfg) file 
The configuration file stores the lens field information, system delays, LD power table values, Q-
Switch values, I/O Driver information, and the basic system parameters. Save the current (default) 
system configuration using the Marking pull-down menu: 

(1) Marking > Config > Save As 
(2) Navigate to the ProLaseXP subdirectory (C:/Program Files/American LaserWare/ProLaseXP). 
(3) Save as default.cfg. If the file already exists, choose Yes to replace it. 

 
2. Record the LD Current Power Values 
The LD Current Power Values prevent the Laser Diode Module 
for being over-powered. An over-powered LD Module will have a 
significant decrease in useable lifetime. In older versions of the 
ProLase XP software, the LD Power values are stored in a separate 
calibration file. In the new version, the LD power values are 
integrated into the configuration file. 

Therefore as a precaution, the current LD Power Table Values 
should be recorded to ensure that these data values get updated 
properly in the new software version. 

a. Select the Marking > Config > Calibrate pull-down menu. 
b. When the Calibration window appears, choose the Power 

button. When a window appears warning that the “Laser 
may output”, choose OK. 

c. Record each of the PWR values and the associated DAC 
voltage for each data entry. 

d. Select OK, followed by OK once again when finished. 

 
A typical screen shot of the Laser Power Table is shown on the right. 
The table values in your system may be significantly different. 
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3. Record the Material File (.mat) Values 
The Material Files are responsible for specifying the marking parameters. The material properties 
can be viewed by; 

a. Selecting the Marking > Material pull-down menu, or 

b. place your mouse cursor over the Material parameter in the Layer / Object Layout Window, 
then select your right mouse button to view the material properties. 

In both cases the Material Properties window will display (as shown below). The majority of 
ProLase XP users have a single default material file for all of their marking files. This default 
material file is saved as default.mat and it resides in the ProLaseXP subdirectory. 
 
A smaller portion of ProLase XP users create 
custom material files. In order to ensure a smooth 
transition, all of these material files need to be 
opened up in the new version of ProLase in order 
to be re-formatted to the new software revision. 
 
Before performing the software upgrade, be sure to 
record each of the data values shown in this table 
as a precaution to recover from corrupt files. 
Repeat this same process for all other material files 
that have been created.  
 
4. Record the Fixture File (.fx2) Parameters 
The Fixture Files are responsible for specifying mechanical offsets in the mark field fixtures. The 
fixture properties can be viewed by; 

a. Selecting the Marking > Fixture pull-down menu, or 

b. place your mouse cursor over the Fixture parameter in the Layer / Object Layout Window, 
then select your right mouse button to view the fixture properties. 

In both cases the Fixture Properties window will display (as shown below). The majority of 
ProLase XP users have a single default fixture file for all of their marking files. This default fixture 
file is saved as default.fx2 and it resides in the ProLaseXP subdirectory. 
 
A smaller portion of ProLase XP users create 
custom fixture files. In order to ensure a smooth 
transition, all of these fixture files need to be 
opened up in the new version of ProLase in order 
to be re-formatted to the new software revision. 
 
Before performing the software upgrade, be sure to 
record each of the data values shown in this table 
as a precaution to recover from corrupt files. 
Repeat this same process for all other fixture files 
that have been created.  
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5. Record the System I/O Bit Properties  
For customers that use the External I/O to control their marking process, you should record the 
current I/O bit selection to verify that the upgrade is performed properly. If your system does not 
use I/O control, then proceed to the next step. 
 
Record the I/O Control bit values for each layer within each ProLase 
.laz file that was created. Place your mouse cursor over the Layer in 
the Layer / Object Layout window and choose Properties. 

Note: Some customers customize the name of each layer. Choose 
 the custom name of the layer in this case. 

 
When the Layer Control Sequence window appears, record each I/O 
bit value for the Start Mark Input I/O setting. There are three choices: 
  - Logic Low 
  - Logic High 
  - Don’t Care (dithered check mark) 

 

Repeat this same procedure for each Layer listed in the Layer Control Sequence window. Open any 
other .laz marking files that were created and record the values for each of these layers as well. 
 
6. Back-up the Original System Software 
Shutdown ProLase XP. 
In order to provide a Restore Point, all; system files, configuration files, executables, laser marking 
files, material files and fixture files should be backed-up. Copy all of the files located in the 
C:/Program Files/American LaserWare/ directory to a separate back-up directory. 
 
7. Delete the ProLase initialization files 
Whenever ProLase XP is started, two files are automatically created, default.pre and LaseXP.ini. In 
order to provide a smooth software upgrade, both of these files should be deleted (note: if these files 
do not exist, that is OK. Continue with the procedure). The files are located at: 
 C:/Program Files/American LaserWare/ProLaseXP/default.pre 
 C:/Windows/LaseXP.ini 
 
8. Remove the current ProLase 2k Drivers 
Navigate to the ProLase 2k Driver Utility; 
Start > (All) Programs > ProLaseXP > ProLase2kDriver 
 
Select the Remove ALI Drivers button. When all drivers are 
removed the Installation Status will report Not Configured. 
 
Choose Exit when finished. 
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9. Update the ProLase XP files. 
Download the update file to your local PC (note the location of the file). Unzip the contents of the 
update file, then copy all of the files to the C:/Program Files/American LaserWare/ProLaseXP 
subdirectory. When prompted to overwrite files, choose Yes to All. 
 
10. Install the new ProLase 2k Drivers. 
Navigate to the ProLase 2k Driver Utility; 
Start > (All) Programs > ProLaseXP > ProLase2kDriver 
 
Select the Install ALI Drivers button. When all drivers are 
installed the Installation Status will report CONFIGURED 
for Prolase DAC Control. 
 
Choose Exit when finished. 

 
 
11. ProLase XP Server & ProLase XP Plus Server.  
If your system operates with either ProLase XP Server or ProLase XP Plus Server, there are some 
additional steps required to complete your software upgrade as outlined below. If your system does 
not operate on either of these two software platforms, continue with the next step. 

a. Locate the folder on the PC where the pre-existing ProLase header (*.h) files and the 
prolase.lib are located. (Example: C:/yourcustomizedsoftware/prolasedll/) 

b. Extract the contents of the hfiles.zip file located in the C:/Program Files/American 
LaserWare/ProLaseXP directory into the folder identified in the previous step. Replace all 
.lib and .h files. In addition, if the prolase.dll file exists in your C:/Windows/System32 
folder, it will also need to be replaced by the new prolase.dll file. 

c. Check the customized software project properties and verify that the correct library 
directories link path is referenced. This will prevent linking to an incorrect version of the 
prolase.lib file. 

d. Recompile the customized software program to link with the latest *.h and prolase.lib files. 
Make sure that you link to the correct version of the prolase.lib file (dated 10-26-07). 

e. If you are running ProLase XP Plus Server, you must also rename the following files: 
Rename prolase.dll to proplus.dll and rename prolase.lib to proplus.lib. 
If you are not running ProLase XP Plus Server, skip this step. 

 
12. Start ProLase XP. 
Start the version of ProLase XP that your system operates with: 

Start > (All) Programs > ProLaseXP > ProLase______ 

If you select the incorrect ProLase XP version, you will receive a pop-up  
window that indicates that the Security Key not Found. This simply means that the hardware key 
(dongle) that you have does not match the version of software that you are trying to run. 
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When the updated version of ProLase XP runs for the first time, it 
will convert any of the older system files as necessary. A typical 
screen will appear as shown on the right. Select OK to continue. 

Note: The contents of the screen may appear differently (or not at 
all) depending on the version of software that was installed prior 
to the upgrade. 

When the Using Standard Preference Settings window appears, 
choose OK.  
 
13. Verify the software update.  
With ProLase XP running, verify that all of the configuration parameters were updated properly as 
noted below. 

a. Verify the Field Parameters match the lens that is installed:  Marking > Config > Field 

Model Lens Field Size Field 
Guide  Model Lens Field Size Field 

Guide 
75mm 1.54in / 3.9cm Circle  100mm 3.15in / 8.0cm Circle 
100mm 3.15in / 8.0cm Circle  160mm 3.94in / 10.0cm Square 
150mm 4.72in / 12.0cm Circle  254mm 5.91in / 15.0cm Square 
160mm 3.94in / 10.0cm Square  

LMV1000G 

300mm 6.89in / 17.5cm Square 
254mm 5.91in / 15.0cm Square      
270mm 8.50in / 21.6cm Circle      
300mm 8.27in / 21.0cm Square      

LMV1000 

420mm 11.57in / 29.4cm Square      
         

b. Select the Delays tab and verify that the Center Galvos After Mark option is checked ( ). 

c. Select the Driver tab and verify that the DDA – 16bit option is selected and that both the 
PCIM-DDA06/12 and PCI-CTR05 PCB’s both show a status of Found. 

d. Select the Field tab and verify the orientation options are the same as shown below. The 
other options and parameters are f-theta lens dependent. There is no need to modifying any 
of the other items on this screen. 
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e. Select the Calibration, Laser Control tab and verify each of the values as shown in the screen 
image below (especially the values in the Idle Power Control section). Change any data field 
that does not match the screen image below. 

 

f. Select the Power button and verify the 
table data values are the same as in Step 
2.  Select OK when finished. 

 

g. Select the Frequency button and verify 
the table data values are the same as 
shown below. Select OK when finished. 
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h. In the I/O Control window, 
verify that the  Digital Input 
Mask is selected. 
 
View the I/O Control window by 
selecting: 
Marking > Config > I/O Control 

 

 For customers that use the 
 External I/O to control their 
 marking process, you need to 
 verify that the I/O bit selection 
 was performed properly. If your 
 system does not use I/O control, 
 then proceed to the next step  

i. Place your mouse cursor over the Layer 
in the Layer / Object Layout window and 
choose Properties. Verify that the  Use 
Configuration Settings option is selected 
for each Layer property within each .laz 
marking file that was created. 
 
Verify the Start Mark Input I/O settings to 
the values recorded in step 5. Change 
any I/O setting that does not match. 

 
j. If all configuration parameters look correct, select OK to close the Configuration Parameters 

window. Save the current (default) system configuration using the Marking pull-down menu: 
a. Marking > Config > Save As 
b. Navigate to the ProLaseXP subdirectory 

(C:/Program Files/American LaserWare/ProLaseXP). 
c. Save as default.cfg. If the file already exists, choose Yes to replace it. 

k. Verify that the Material data values are the same as the values recorded in Step 3. Change 
any data field that does not match. Save the Material data by selecting the File > Save As 
from the pull-down menu from within the Material File window. Save as default.mat and 
save it in the ProLaseXP subdirectory (C:/Program Files/American LaserWare/ProLaseXP). 

l. Verify that the Fixture data values are the same as the values recorded in Step 4. Change any 
data field that does not match. Save the Fixture data by selecting the File > Save As from the 
pull-down menu from within the Fixture File window. Save as default.fix and save it in the 
ProLaseXP subdirectory (C:/Program Files/American LaserWare/ProLaseXP). 

Once all configuration parameters are verified, close ProLase XP and open it back up. Verify no 
errors exist. 
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14. Power on the Marker and verify operation.  
Once all software upgrades are complete and verified, turn on the Laser Marker power and verify 
operation. If all software updates were completed properly, the transition should be seamless. 
 
 

 
 

Software Revision differences: 
If you are using the ProLase XP command line interface, please contact Miyachi Unitek for 
additional instructions. The following table defines the differences in software revisions. This 
information is only provided as a reference. 

Rev A /B Rev C Rev D Rev E 
(upgrade)  

 4.23 
(3-27-04) 

4.710 
(12-15-05) 

4.854 
(1-23-07) 

4.901 
(10-26-07) 

LD Power 
Values 

Separate 
.cal file 

Separate 
.cal file 

Integrated into 
.cfg file 

Integrated into 
.cfg file 

Q-Switch 
Values 

Separate 
.cal file 

Separate 
.cal file 

Integrated into 
.cfg file 

Integrated into 
.cfg file 

Default 
Material file 

Saved as 
default.mat 

Saved as 
default.mat 

Saved as 
default.mat 

Saved as 
default.mat 

Setup Material 
file does not exist does not exist Saved as 

setup.mat 
Saved as 
setup.mat 

Fixture file .fx2 extension .fx2 extension .fx2 extension .fix extension 

Auto Idle 
After: 
timeout 

After: 
- immediately 
- timeout 

After: 
- immediately 
- timeout 

After: 
- immediately 
- timeout 
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