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Hardware and Software Instructions
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Attention

This section serves as a notice of the immediate or potential dangers involved when working with the equipment described 
throughout this manual. Any person involved in installation, maintenance, or service of the equipment should first carefully 
examine the equipment and read the instructions contained in this manual to ensure that personal and/or equipment injury 
is avoided. 

The following safety messages appear throughout this manual to alert of immediate or potential danger to life as well as 
property.

Disclaimer

This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to part 15 of the 
FCC Rules. These limits are designated to provide reasonable protection against harmful interference when the equipment 
is operated in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if 
not installed and used in accordance with the instruction manual, may cause harmful interference to radio communications. 
Operation of this equipment in a residential area is likely to cause harmful interference, in which case the user will be 
required to correct the interference at his own expense.

Instructions contained in this user’s guide should be performed only by qualified persons in accordance with local and 
national codes. Blue Ridge Technologies International, LLC and its affiliates assume no responsibility for any consequences 
related to the improper use of this manual.
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USB-TK Components Overview

The USB Tech Kit (USB-TK) includes the following items :

1 - USB Cable for RS-485 / Access Port 18” Length (Figure 1)

 
1 - USB Thumb Drive with Software & Files (Figure 2)

LPPK Files
LPPK Install 
LPPK User Guide
LPPK Product Codes
LPPK Unlock
LPX Files
AppLoader
Clipping Files
BACnet Integration Guide
Utilities
USB Drivers
RealTerm

(Figure 1)(Figure 2)
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Document Overview

This document provides instructions for configuration of the following Blue Ridge Technologies Lx5 Controller products :

BR Series Relay Panel
BR Series Retrofit-Kit
BR Series Retrofit Interiors

Also applies to legacy products :

L2500, L2600, and L3500
LP3500
Qwik-Kit Pro

The LX5 controller has many features encompassed by software and hardware elements. 

This User Guide details the relationship of inputs and outputs through Groups in the LPPK software.  Each software feature 
is discussed as it appears on the LPPK screens.

The LX5 Hardware User Guide focuses on the hardware features of the controller. In the guide components and related 
explanations are arranged by function. The configuration of related elements is also discussed.  

For physical installation of Relay Panels, Retrofit Kits, and Retrofit Interiors refer to the appropriate Mounting Instructions. 

For network point descriptions and integration to a Building Automation System (BAS), refer to the Lx5 BACnet Integration 
Guide.
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Installation : Software Installation LPPK

Before starting use Windows un-install utility to remove any previous 
versions of LPPK software. After the un-install process has been 
performed, check for remaining files in C:\Program Files\LUMISYS 
and delete manually if needed.

1. After un-installing any previous versions of LPPK, insert the USB-
TK Thumb Drive into an open slot on your PC

2. The USB-TK Thumb Drive is configured to auto-run and display 
the Main Menu screen (Figure 3)

3. From the Main Menu screen, click on the LPPK button to view the 
LPPK Menu choices

4. From the LPPK Menu, click on LPPK Install to launch the 
installation process 

5. At the end of the installation process, launch LPPK from your 
computer Desktop or Start Menu

6. After you launch LPPK, the splash screen appears (Figure 4)
7. Click OK on the splash screen
8. After clicking OK, the Software Registration dialog box will appear 

(Figure 5)

Installation : Register and Unlock LPPK

1. Go to http://www.BRTint.com/Tech_LPPK.html
2. Enter the requested information click Submit Now
3. After clicking Submit Now, you will need to select the version of 

LPPK (5.0 or 5.1)
4. After selecting the appropriate version the Lumisys LPPK Key 

Generator screen will open (Figure 6)
5. Copy the “Software Code” from the LPPK Software Registration 

screen
6. Paste that value in the Key Generator field entitled “Customer 

Software Code”
7. Then, click on the Generate Key button
8. A numeric value will appear in the “Liberation Key” field
9. Copy the “Liberation Key” value
10. Paste the “Liberation Key” value into the LPPK Software 

Registration field entitled ”Activation Code”
11. Then, click on the Activate button
12. The Product Activation screen will appear (Figure 7)
13. Click the OK button to complete the process

(Figure 4)

(Figure 5)

(Figure 6)

(Figure 7)

(Figure 3)
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Installation : Connecting the USB Technicians Cable 

PC Connection 

1. Insert the USB end of the Technicians Cable into an available  
USB port on your PC.  

2. Insert the USB-TK Thumb Drive into another available USB port 
on your PC.

3. The USB-TK Thumb Drive is configured to auto-run and display 
the Main Menu screen (Figure 3)

4. From the Main Menu screen, click on the Utilities button to view 
the Utilities Menu (Figure 8)

5. From the Utilities Menu, click on USB Drivers to open Windows 
Explorer

6. From Windows Explorer, double-click on the file CDM20600
7. After double-clicking on CDM20600, the USB driver install process 

will begin.
8. At the end of the installation process, the USB Technicians Cable 

is ready to be connected to a controller.

Lx5 Controller Connection

1. To ensure proper communication with LPPK ensure that only dip 
switch 4 is in the “On” position (switch 7 or 8 may also be ON for 
addressing). To activate changes to switch settings the controller 
must be power cycled.*

2. Remove the EIA-485 terminal block to reveal EIA-485 port.
3. Connect the LPPK cable to the EIA-485 port on the controller. 

(Figure 9)
4. On the Connect screen, select the Comm Port of the PC connected 

to the controller. (Figure 10)
5. Enter address of controller and select “Read This Address”. 

LPPK will try to establish communication with this controller. If 
communication is established the controller address and its 
software version will be displayed. Or select “Scan Address” if you 
don’t know the Controller address.*

6. Click on OK to connect to the controller and select OK when 
prompted to read controller database.

7. If communication is not established, verify you have the correct 
address and communication port selected.

(Figure 8)

(Figure 9)

(Figure 10)

* Refer to Lx5 Hardware Users Guide for additional dip switch setting and controller addressing instructions.
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Installation : Connecting LPPK to Multiple Controllers Over Network

1. On the Connect screen, select the Comm Port of the PC connected 
to the controller.

2. Enter the address of the controller and select “Read This 
Address” or select “Scan Addresses”. LPPK will try to establish 
communication with this lighting control panel or scan addresses 
1-255 and list all controllers on this network. 

3. Make sure the address of the controller is in the “Program for 
address” box and then click OK to connect to the controller. Click 
OK when prompted to read the controller database.

4. If communication is not established, verify you have selected the 
correct communication port.

Installation : Configuring a Database Online or Offline

A database can be configured while connected to the controller or 
offline. To configure a database while connected to a controller follow 
the instructions to connect to a controller listed above.

1. To configure a database offline select “Offline” as the 
Communication Port during start-up. (Figure 11)

2. Select the desired controller address in the box labeled “Program 
for Address”. Then select the type and software version to be 
programmed in the box labeled “Program for product”.

3. Select OK.
4. The LPPK main screen will be displayed.

(Figure 11)
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Getting Started : Creating a Controller Configuration Database

Overall Concept

The essential function of the LPPK software is to assign inputs to outputs utilizing a grouping method. Inputs (switches, 
occupancy sensors, light level sensors, etc) are configured with various settings. The input and settings are assigned control 
of a group. Each group contains outputs (relays and related lighting circuits). Therefore input commands and configurations 
are applied to outputs through groups.

Concept in Practice
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Getting Started : LPPK Main Screen

Developing a Controller Configuration Database with LPPK (assigning inputs to outputs through groups) begins on the 
Main Screen. All functions and features are accessible from this window. (Figure 12)

Helpful navigation labels appear at the bottom of the Main Screen as 
your cusor passes over features.

(Figure 12)
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Getting Started : Opening a File

1. Select Tool Bar File > Open or Open Names. (Figure 13)
2. File > Open provides the capability to open a saved .lpx file.  The 

suffix .lpx is used for all Blue Ridge Controller files. (Figure 14)
3. File > Open Names reads only .lpx name data and displays it on 

the screen. 
4. Select the File you want to open.
5. Press “Open” to open the file.
 

Getting Started : Saving a File

1. Select Tool Bar File > Save.
2. File > Save provides the capability to save the current information 

as an .lpx file. The name can be up to eight characters in length. 
(Figure 15)

3. “File Description” provides the capability to describe the file’s 
content such as “North Wing Electrical Closet” or “Fifth Floor 
Lighting”, etc.

4. Press “Save” to save the file.

(Figure 13)

(Figure 14)

(Figure 15)
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Inputs : Number of Inputs

The number of inputs represents the number of switches, occupancy sensors, etc. connected to the lighting controller. 

1. Select the number of inputs that will be utilized by typing in a number between 1 and 120 in the box labeled “Inputs”.  
(Figure 16)

2. Select Tool Bar File > Save to save data to .lpx file
3. Select Tool Bar Device > Write, to save data to the controller memory.

Inputs : Naming Inputs for .lpx File

Each input can have a name in addition to a number. Input names are only saved to a disk as .lpx file. All other panel 
configuration data is saved to both the disk and the panel’s processor.

1. To automatically name the inputs as Input 1, Input 2, etc. select Tool Bar Input > Create Default Names for All > As Input 
N. 

2. To automatically name the inputs with the name of the group it controls select Tool Bar Input > Create Default Name for 
All > Copy Name From Assigned Group. 

3. To individually assign a name to an input type in the desired name of each input in the box labeled “Name”. (Figure 16)
4. Repeat for each input.
5. Select Tool Bar File > Save to save data to .lpx file. Input names are never saved to the controller memory.

(Figure 16)
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Inputs : Types

Maintained inputs require the input be maintained to activate the output.

Momentary On inputs require a momentary closure to activate the output.  It also requires a separate input be assigned as 
a Momentary Off input to deactivate the output.

Momentary Off inputs require a momentary closure to deactivate an output.  It also requires a separate input be assigned 
as a Momentary On input to activate the output.

Momentary On/Off inputs require a momentary closure to toggle the state of the output.  This type of input requires only one 
input to perform both ON and OFF control of an output.  It also requires the input device to be in a location where the lights 
are within visual contact.

Linked On inputs are designed for multi-level lighting control applications that require timers for automatic shutoff of lighting.  
A typical application is 1/3, 2/3 and 3/3 lighting levels in a conference room.  One input is assigned to the 1/3 level output 
and a second input is assigned to the 2/3 level output.  Typically, two additional inputs are assigned as Momentary Off inputs 
for the 1/3 and 2/3 outputs.  Activating the 1/3 light level switch will turn on the respective output and begin its timer.  Once 
the timer has expired the 1/3 light level output will flash to warn the occupants that the lights are about to turn off.  Once the 
lights flash the two switches, 1/3 and 2/3, are linked as one so either switch can be activated to reinitialize the timer for the 
1/3 lighting level.  Immediately after either switch is activated the switches are automatically un-linked and return to their 
independent state until another flash warning occurs.  Without this feature a user may accidentally activate the wrong level 
switch causing frustration for the user.

State Change inputs are designed for use with maintained 3-way switches in retrofit applications.  A change of state will 
toggle the state of the associated output.
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Inputs : Assigning Input Types

1. To automatically assign all inputs to the same type select Tool Bar Input > Set All As Type > Select the desired type. All 
inputs will be assigned this type. 

2. To individually assign input types select the input type in the box directly next to the input number in the column labeled 
“Type”. (Figure 17)

3. Repeat for each input.
4. Select Tool Bar File > Save to save data to .lpx file
5. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 17)
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Inputs : Polarity

Each input can be assigned a normally open or normally closed polarity. This allows LPPK to properly read input commands 
with varied switch and controller polarity.*

1. To automatically assign all inputs to the same polarity select Tool Bar Input > Set Polarity For All To > Select the Desired 
Type. 

2. To individually set polarity utilize the column entitled “Normally”. (Figure 18)
3. Select Tool Bar File > Save to save data to .lpx file
4. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 18)

* Refer to the USBTK Tech Note and Lx5 Hardware User Guide for additional information.
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Inputs : Timers Durations 

An input’s timer represents the amount of time the assigned group will remain ON after the input is activated. (1 minute to 
18 hours)

1. Type in the duration of the timer in the boxes labeled “Timer Durations 1, 2 and 3”. The first two places are for hours and 
the second two places for minutes. (Figure 19)

2. Select Tool Bar File > Save to save data to .lpx file
3. Select Tool Bar Device > Write, to save data to the controller memory.

Inputs : Assign a Timer to an Input

1. To automatically assign all inputs to the same timer select Tool Bar Input > Set All For Timer > Select the Desired Timer. 
2. To individually set timers, enter timer duration between 1 and 3 in the box labeled “Timer” or scroll down to the desired 

timer. Entering “0” will deactivate the timer feature. (Figure 19)
3. Repeat for each input.
4. Select Tool Bar File > Save to save data to .lpx file
5. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 19)
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Inputs : Flash Warning (Flash Before Off)

Applying this setting to an input will schedule a momentary flash of the assigned output to warn of the timer’s imminent 
expiration and lighting shutoff.

1. To automatically assign all inputs the ability to “Flash” or “No Flash”, select  Tool Bar Input > Set All For > Flash or No 
Flash. All inputs will be assigned this selection.

2. To individually set Flash, click on the box labeled “Flash” to enable the flash warning feature. The input number is 
located to the right of the box. (Figure 20)

3. To deactivate the flash warning uncheck the box.
4. Repeat for all inputs.
5. Select Tool Bar File > Save to save data to .lpx file
6. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 20)
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Inputs : On-time After Flash 

This is the length of time the input’s assigned group remains ON after the flash warning occurs. (10 seconds to 60 minutes)

1. In the area labeled “Flash Durations” there is a box labeled “On-Time After Flash”. (Figure 21)
2. Set the length of time (minutes and seconds). 
3. Select Tool Bar File > Save to save data to .lpx file
4. Select Tool Bar Device > Write, to save data to the controller memory.

Inputs : Flash Off-time

This is the length of time the input’s assigned group switches OFF creating the flash warning. (factory set for .5 seconds)

1. In the area labeled “Flash Durations” there is a drop down box labeled “Flash Off Time”.
2. Select Tool Bar File > Save to save data to .lpx file
3. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 21)
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Outputs : Number of Outputs

This is the number of relays incorporated.

1. Select the number of outputs that will be utilized by typing in a number between 1 and 60 in the field labeled “Relays”.  
(Figure 22)

2. Select Tool Bar File > Save to save data to .lpx file
3. Select Tool Bar Device > Write to save data to the controller memory.  

(Figure 22)
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Outputs : Refresh Period

Refresh is a pulsing function intended to extend operation of worn-out relays.1

1. In the area labeled “Relays” there is a drop down box entitled “Refresh Period.” (Figure 23)
2. To set an output refresh rate select a time between 3-30 minutes from the drop down box.
3. To deactivate this feature select OFF from the drop down box.
4. Select Tool Bar File > Save to save data to .lpx file
5. Select Tool Bar Device > Write, to save data to the controller memory.

Outputs : Energize Duration

This setting regulates the length of time between the ON/OFF Refresh pulse.

1. In the area labeled “Relays” there is a drop down box labeled “Energize Duration”.
2. The output energize duration is factory set for 0.072 seconds. (There should be no need to change this value.) 
3. Select Tool Bar File > Save to save data to .lpx file
4. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 23)

1 To prevent damage to equipment, limit Refresh usage to Qwik / Retrofit Kits 3 or 5 .
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Group Assignments : Naming Groups

Naming groups is the first step to establishing the relationship between inputs and outputs in the LPPK Controller Configuration 
Database. Naming may be used to organize the groups according to application such as “1st Floor Conference Room”.

1. Under the column heading labeled “Assigned Group” select “Setup”. This can also be accomplished by selecting Tool 
Bar Group > Setup.

2. The Group Setup screen should appear. (Figure 24)
3. Select the desired Group between 1-60, to be named.
4. In the box next to the Group number type up to 15 characters to name the output. 
5. Repeat for each group.
6. Select Tool Bar File > Save to save data to .lpx file
7. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 24)
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Group Assignments : Inputs

The input and its configurations are then assigned to a group. For example, inputs (switches) in the conference room are 
assigned to the group entitled “1st Floor Conference Room”.

1. Under the column labeled “Assigned Group” select the name of the group the input will be controlling. If you do not know 
the Group Name then type in or select the group number between 1 and 60 under the column labeled “0..60”. (Figure 
25)

2. Repeat for all inputs.
3. Select Tool Bar File > Save to save data to .lpx file
4. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 25)
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Group Assignments : Outputs

The outputs are then included in the appropriate group. For example, outputs (relays and lighting circuits) in the 
conference room are included in the group entitled “1st Floor Conference Room”. This completes configuration of the 
relationship allowing the input control of all the outputs contained in the group.

1. Under the column heading labeled “Assigned Group” select “Setup”. This can also be accomplished by selecting Tool 
Bar Group > Setup from the toolbar.

2. The Group Setup screen should appear. (Figure 26)
3. Select the desired Group between 1-60, to be created or modified.
4. Once the Group number is selected, click on the box associated to the output / relay number to be added to the group. 

Select each respective box until all the desired outputs/relays are assigned to this group. There are buttons to the left 
labeled “Add All” to add all relays to the group, “Remove All” to delete all from the group and “Invert” to select the outputs 
that are not checked.

5. Repeat for each group.
6. Select Tool Bar File > Save to save data to .lpx file
7. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 26)
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Additional Features : Serial On Priority

This setting allows BAS ON commands priority over input OFF commands. 

1. Under the column heading labeled “Assigned Group” select “Setup”. This can also be accomplished by selecting Tool 
Bar Group > Setup.

2. The “Group Setup” screen should appear. (Figure 27)
3. To activate this feature click on the box in the lower left hand corner of the screen labeled “Serial On Priority”. An “X” will 

appear in this box to indicate the feature is selected.
4. Select Tool Bar File > Save to save data to .lpx file
5. Select Tool Bar Device > Write, to save data to the controller memory.

Additional Features : Serial On Priority Flash Warning (Flash Before Off)

This setting incorporates a flash warning for BAS OFF commands. 

1. To activate this feature click on the box in the lower left hand corner of the screen labeled “Flash before off”. An “X” will 
appear in this box to indicate the feature is selected.

2. Select File > Save to save data to .lpx file
3. Select Device > Write, to save data to the controller memory.

Additional Features :  Maintained Input Priority

This setting is typically utilized for fire alarm, security, or emergency transfer switch (ETS) override operations.*

1. In the box titled “Maintained Input Priority” select either None, On, Off, or On/Off.
2. Select Tool Bar File > Save to save data to .lpx file
3. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 27)

* Refer to USBTK Tech Note for additional information.
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Additional Features : Assigning Groups to Super Groups 

Super Groups allow application of an input’s group settings to multiple groups.

1. Under the column heading labeled “Assigned Group” select “Setup”. This can also be accomplished by selecting Tool 
Bar Group > Setup from the toolbar.

2. Select the desired Group number between 1-60, to be created or modified.
3. Once the Group number is selected, click on the circle in the “Group Type” area labeled “Super”. The numbers next to 

the boxes represent the groups included in the Super group. The group that matches the Super group number will be 
grayed out because it cannot be assigned to the Super group. (Figure 28)

4. Select the desired groups to be included in the Super Group by clicking the respective box.
5. Repeat until desired Super Groups are defined.
6. Select Tool Bar File > Save to save data to .lpx file
7. Select Tool Bar Device > Write, to save data to the controller memory.

(Figure 28)
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Additional Features : Special Options

Option 1 : N/A

Option 2 : N/A

Option 3 : When checked, this option changes all inputs types that were “Momentary On/Off” to operate as  “Momentary On/
Off/On” - when flash warning is enabled.

Option 4 : Future Use

Option 5 : Future Use

Group 1 > Timer 1, Group 2 > Timer 2, Group 3 > Timer 3 : This option provides the capability to overide all timer dependant 
switches in a panel. Examples are classrooms or offices that need a switch without a timer during the day and utilize the 
timer after hours.1 *

1. Select Tool Bar Other > Special Options
2. Special Options Screen will appear (Figure 29)
3. Choose desired options
4. Select Tool Bar File > Save to save data to .lpx file
5. Select Tool Bar Device > Write, to save data to the controller memory.

1 Be sure groups 1, 2, and 3 do not have relays assigned if these options are selected.

(Figure 29)

BAS Command On Switch is Activated

Lights will stay on until 
command off
Lights will stay on for duration 
of Timer 1 then turn off
Lights will stay on until 
command off
Lights will stay on for duration 
of Timer 2 then turn off 
Lights will stay on until 
command off
Lights will stay on for duration 
of Timer 3 then turn off

All switches in Panel X with Timer 1 will respond as if there 
is  no timer
All switches in Panel X with Timer 1 will now respond to 
Timer 1
All  switches in Panel X with Timer 2 will respond as if there 
is no timer
All switches in Panel X with Timer 2 will now respond to 
Timer 2
All switches in Panel X with Timer 3 will respond as if there 
is no timer
All switches in Panel X with Timer 3 will now respond to 
Timer 3

Panel X, Group 1 On

Panel X, Group 1 Off

Panel X, Group 2 On

Panel X, Group 2 Off

Panel X, Group 3 On

Panel X, Group 3 Off

Switch Timer State

* Refer to USBTK Tech Note for additional information.
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Additional Features : Setting LMB Controller Address

This feature allows you to remotely alter the controller’s address. (Legacy Feature - Only available on LMB)

1. Connect to LMB Controller.
2. Double click on the address box. The “Address Change” screen will appear. (Figure 30)
3. Enter the new address and click ‘Change’.

(Figure 30)
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Additional Features : Write Database to Controller

This allows writing a database (in part or whole) from your PC to the 
controller.

1. Select Tool Bar Device > Write 
2. Select Header if header information is to be written to a selected 

controller. Header information includes all the global controller 
data such as “inputs”, “relays”, “on-time after flash”, “flash off time”, 
“switch timer durations”, “relay refresh rate” and “relay energize 
duration”. (Figure 31)

3. Select Input Configuration if input configurations are to be written to 
a selected controller. Input Configurations includes “input names/
numbers”, “types”, “timers”, “flash”, and “input polarity”.

4. Select Group Information if group information is to be written 
to a selected controller. Group information includes all group 
information listed in the “Group Setup” screen.

5. Select the number of groups to be written to a selected controller. 
(This information takes the longest time to write.)

6. Select “Write” to begin writing to controller. 

Additional Features : Read Controller Database

This allows reading an existing database from the controller.

1. Select Device > Read

Additional Features : Print Controller Database

We recommend you print a copy of the controller data for your files.

1. Select Tool Bar File > Print 
2. Select the desired number of groups between 1 and 60. (Figure 

33)
3. Select “Print” to print desired groups.
4. Select “Cancel” to cancel print selection and return to the “Main 

Screen”. 

As information is being written or read a screen appears to display the process. (Figure 32)

The box to the left of entitled “Command” and to the left entitled “Response”, displays the information being 
communicated. The box to the right displays the actual protocol commands.
The “Response Time” with “Relative Speed” indicator will reflect system communication speed.

(Figure 31)

(Figure 32)

(Figure 33)
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Diagnostics : Communication and Device Status

Status 
The Status box displays either online or offline programming. If online is displayed then your computer is currently connected 
to a controller. (Figure 34)

Port
The computer USB port will be displayed in this box if you have selected online programming. Port is not applicable with 
offline programming.

Address
The address is the address of the controller you selected in online or offline setup.

EPROM
This displays the status (OK or Error) of the controllers EPROM which contains the controller’s software. This is not applicable 
for offline programming and newer controllers.

EEPROM
This displays the status (OK or Error) of the controller’s non-volatile EEPROM which contains the controller database. This 
is not applicable for offline programming.

(Figure 34)
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Diagnostics : View Current Input States

1. Select Tool Bar Group > View > Modify Current States.
2. An Input Status screen will appear and continuously display input status for each input configured in the database. 

(Figure 35)

The boxes and numbers represent the input numbers. An “X” in the box indicates the input is activated. Momentary inputs 
will only display the “X” for the duration of the momentary closure.

The area labeled “Analog Input” allows you to select a value range from 0-255 with which LPPK will display a value in 
proportion to 0-5VDC analog input signal. Controllers use six inputs. (LMB controllers have five inputs) 

(Figure 35)
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Diagnostics : View/Modify Current Output States

1. Select Tool Bar Group > View/Modify Current States.
2. A Group Status screen will appear and continuously display the output status for each output configured in the database. 

(Figure 36)  
3. To check the status of a Group, right-click once with the cursor on the desired Group status display. Text boxes at the 

bottom of the screen will display status information and the current status of the group including what caused the group 
to be in its current state.

4. To manually change the state of a Group, right-click twice on the Group status display. The State of the group will 
change.

(Figure 36)
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Diagnostics : Check Bad Relays/Circuits

This feature provides the capability to display the relays which are not 
in the correct state. Relays must be physically capable of providing 
feedback via auxiliary contact.

1. Select Tool Bar Other > Check For Bad Relays.
2. LPPK will determine which relays are not in the correct state and 

will list them in a dialog screen. (Figure 37) 

These relays may be malfunctioning and need replacing. Resetting 
the relays will be required to clear this screen. If you do not reset the 
bad relays then the same relay numbers will be displayed the next 
time you check bad relays. Be sure to reset the bad relays by selecting 
“YES”. If you want to keep the Bad Relay listing the next time you 
select this screen then select “NO”.

(Figure 37)
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Troubleshooting the Controller

Be sure to check the Blue Ridge website <www.BRTint.com> for latest troubleshooting support.

Outputs Will Not Turn On

Verify power is connected to the controller. There should be LEDs illuminated.

Verify there is at least 24 VAC present to the secondary of the transformer supplying power to the controller. 
Use a voltmeter to check the power.

Check to see if Maintained input priority for the group that is not responding to control commands is not set to Maintained 
Off Priority or Maintained On/Off Priority.

Verify that the output ribbon cable connector is properly seated.

Press the OVER push button to see if all the relays will turn on. If so, then the output portion of the controller is operating 
properly.*

Verify that the connector to output (relay or Circuit breaker) is properly seated. 
 
Use LPPK to verify that the controller sees the inputs change state. Use an alligator clip or shorting 
wire to test.  

Controller not communicating or Communication LED TX / RX Not Blinking

Verify the LPPK cable or network cable is connected correctly.

If you are using LPPK verify that the correct communication port is selected.

Verify the controller is addressed properly.

Ensure that only dip switch 4 is in the “On” position (switch 7 or 8 may also be ON for addressing). To activate changes to 
switch settings the controller must be power cycled.

* Refer to Lx5 Hardware User Guide for explanation of controller hardware.
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Worksheets : Group Programming
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Worksheets : Group Programming
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AppLoader : Overview and Installation

AppLoader software allows field service personnel to restore or update 
Lx5 firmware utilizing the USB Tech Kit cable. 

AppLoader performs two functions. First the software downloads 
firmware to the controller in the form of Clipping (extension .clipping) 
files. Second AppLoader displays Modstat consisting of diagnostic 
firmware and operational data.

1. The USB-TK Thumb Drive is configured to auto-run and display 
the Main Menu screen. (previously shown in Figure 1)

2. From the Main Menu screen, click on the AppLoader button to 
view the AppLoader Menu choices. (Figure 38)

3. From the AppLoader Menu, click on AppLoader Install to launch 
the installation process. (Figure 39)

4. At the end of the installation process select Done to complete the 
installation.

(Figure 38)

(Figure 39)
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(Figure 40)

(Figure 41)

(Figure 42)

AppLoader : Connection

1. Insert the USB end of the Technicians Cable into an available 
USB port on your PC.1

2. Connect the cable to the Lx5 controller with the red 5 pin socket. 
(Figure 40)

3. Launch AppLoader from your computer Desktop or Start Menu. 
The AppLoader main screen will appear. (Figure 41)

4. Select Tool Bar Access Port > Choose the Com Port to which the 
Technicians Cable is connected. (Figure 42)

1 Drivers must be installed to operate the 
Technicians Cable. Refer to Page 7 for driver 
installation instructions.
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(Figure 43)

(Figure 44)

(Figure 45)

AppLoader : Downloading

1. Select Tool Bar File > Open
2. Navigate to Removable Disk (X) (USB-TK Thumb Drive) > App_

Loader > Clippings > Select the Clipping file you wish to download. 
(Figure 43) (Contact Blue Ridge Technical Support for the latest 
Clipping files)

3. Once the Clipping file opens, select Build (Figure 44)1

4. AppLoader will then construct the file and display the message 
“Build complete. Choose next action.” (Figure 45)

5. Select Modstat to confirm communication is established.2

6. Modstat will display the controller’s current firmware and related 
data. 

1 If the Build button does not become selectable, resize the AppLoader Window.

2 If Modstat is not selectable confirm the proper Com Port is selected.
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AppLoader : Downloading

1. Select Tool Bar File > Open
2. Navigate to Removable Disk (X) (USB-TK Thumb Drive) > App_

Loader > Clippings > Select the Clipping file you wish to download. 
(Figure 43) (Contact Blue Ridge Technical Support for the latest 
Clipping files)

3. Once the Clipping file opens, select Build (Figure 44)*
4. AppLoader will then construct the file and display the message 

“Build complete. Choose next action.” (Figure 45)
5. Select Modstat to confirm communication is established.**
6. Modstat will display the controller’s current firmware and related 

data. 
AppLoader : Downloading (Continued)

7. Then select Download Memory.
8. The Set Device ID window will appear. “Use auto-assign device 

ID” creates an ID based on the controller’s configuration. “Use 
assigned device ID” employs the controllers current ID. “Set 
device ID to (X)” allows maunal assignment of the ID. Select 
desired device ID setting and select OK. (Figure 46)

9. AppLoader will begin loading new Clipping file to controller. 
(Download may take 10-20 minutes)

10. When the download is accomplished “Download Complete and 
Successful” will display. (Figure 47) (If the download fails first 
repeat steps 5-8. If failures continue refer to Page 41 and contact 
Blue Ridge Technical Support)

11. Close AppLoader.

(Figure 46)

(Figure 47)
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AppLoader : Formatting

Formatting the controller may be necessary to successfully download 
new firmware. Contact Blue Ridge Technical Support before formatting 
any controller. 

1. Disconnect the controller’s power.
2. Disconnect the USB Technicians Cable.
3. Set both the controller’s rotary switches to (0).*
4. Install a jumper on the Format (FMT) pins.
5. Apply power to the controller. Confirm the red Error LED is blinking 

(this indicates the controller is formatted).
6. Disconnect the controller’s power.
7. Reset both the controller’s rotary switches to original position.
8. Uninstall the jumper from the Format (FMT) pins.
9. Apply power to the controller.
10. Connect the USB Technicians Cable.
11. Perform a Modstat to confirm formatting. The Device Instance will 

display “Unconfigured”. (Figure 48)

(Figure 48)

* Refer to Lx5 Hardware User Guide for location of controller hardware.


