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1. Windows™ Software Installation

1.1. General

The UHBX-3S graphical user interface (GUI) is Windows™ software used to configure
advanced settings of the UHBX-3S. Use of the software requires USB connection of the
PC to the device. For convenience, a USB cable is provided with each device.

The GUI can be used to monitor and configure several devices simultaneously. So for
PC's that have multiple USB ports or with the use of external USB hubs, it is possible to
use the same GUI and address each device individually.

1.2. Installation Prerequisites
e A PC with Windows XP™ OS or later

e USB port

e  Microsoft™ .NET Framework 2.0 or later (most recent OS including Windows 7 and
8 typically include this and no action is required). If .NET Framework 2.0 or later is
not installed on your PC, the Microsoft™ website has free downloads available.

1.3. Software Installation

o Ifan earlier version of this particular software was previously installed, UNINSTALL
the program first from either the Add/Remove Programs section of the control panel
or by running the previous installation SETUP.EXE and selecting “remove
application”.

o Install the software by executing the SETUP.EXE program from the installation
source directory

e  Accept the default settings, but if you want to specify a particular installation
directory other than the default, you may do so.

e  Once the UHBX-3S software installation has completed, either Eﬁ
click the desktop icon or navigate the Start Menu to UHBX]|

Start = Programs = Hall Research = UHBX-3S Manager
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2. Using the Software

2.1. General

The UHBX-3S Manager is a Windows GUI that can be installed to remotely control and
monitor the UHBX-3S device via a USB connection. It also provides you an ability to
manage the EDID by learning it from a desired LCD monitor connected to any output,
importing any custom EDID into the device, exporting the device’s EDID to a file,
updating any future firmware into the device, and many more.

2.2. USB Device Detection

The UHBX-3S Manager automatically configures the USB port after connection to the
device (using standard Windows™ USB drivers) and does not require any special USB
drivers to be installed.

Once connected to a USB port, the Windows™ system will detect and use the
appropriate USB driver. The first time you connect the device to the PC, you may
experience a short delay and a windows notification pop-up message may be shown.

This detection and driver installation only occurs when the UHBX-3S is
connected to the PC for the first time. Afterwards, reconnected devices
automatically configure themselves with no delay or message.

= |f no UHBX-3S device is attached to the PC, the on-screen fields are disabled
(grayed out)

© Copyright 2014. Hall Research, Inc.
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Once, the UHBX-3S Manager detects a valid connected UHBX-3S device, its control
and status menu will be enabled as shown in below.
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2.3. Controls

The UHBX-3S Manager provides you more control and flexibility of the device than the
front panel.

Video EDID

The UHBX-3S creates an EDID table that the source connected to the input can read.
EDID mode can be set to either emulate or pass-thru.

= Emulate - The internally stored EDID is

passed to the source. This EDID can be a EDIZmulme

factory default or a learned EDID from one e Pins

of the sink LCD monitors or other device '

connected to an output. [ ] Leam |Local -

= Pass-thru - The EDID passed to the source
comes from a sink LCD monitor connected to an output.

EDID Table usBe
Presented to Port

Source |
HDMI i Internal ""‘L_"
Input ) =~ Emulate . Memory ¢ \
Video > 4 e
|3

P 3
— 1 Audio i \
EDID 7 Pass-Thru
Data \

HDMI

—_— Output Sink Device
EDID Routing Modes
Learn EDID (]
Learn Local x
An EDID can be learned from a sink LCD monitor
;
connected to any outputs. Once, an output is Output 1
selected, just click the Learn button to learn the Output 2

EDID from the connected monitor or device. o

Set RS232 Start Channel

The UHBX-3S’s output can be referenced e

by a number from 1 to 99, which makes Output 1 1

communicating to a desired remote serial

receiver easier when there are more than D -

one UHBX-3S devices connected in daisy Output 3 3

chain. Baud: 19200
Parity:  Mone

© Copyright 2014. Hall Research, Inc.
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By default, Output 1 of each device starts with number 1, and this number will be
incremented by one for the next output. If Output 1 is changed to 12, the Output 2 and
Output 3 will be 13 and 14 respectively.

This output channel numbering is used to transmit/receive data to or from the specified
serial receiver.

Set RS3232 Start Channel

Current Connection — Allow you to view
you to view the current output connection
that the controller is connected to in
addition to the baud rate, and the parity

Cutput 1 1

Current Connection

that the controller is communicating at with Output. 1

the remote serial receiver. Baud: 19200
Parity:  Mone

Miscellaneous

= Cycle HPD - This button is used to send
500ms Hot Plug Detect pulse signal to the i
video source. It has the same effect of __| cyeenPD
unplugging the HDMI input cable and 7| Power Management
plugging it back in. This forces the source
to re-initialize its HDMI video output connection (read EDID, and implement HDCP if
required).

Miscellaneous

= Power Management — When it is selected, the UHBX-3S device will check for the
presence of source +5V and sink HPD. If neither +5V nor HPD is detected, the
HDBaseT extender module at the output will be in low power mode. When it is not
selected, the HDBaseT extender module at the output will always be either in Auto
or Long Reach mode.

Video Blanked

The output video can be blanked or un-blanked Video Blanked

by selecting the corresponding check box. Outputs 0 - 3:

Set HDBaseT Mode

The HDBaseT output can be individually set to SetHDBaseT

either Auto or Long Reach mode. Mode RS
Auto @)

= Auto - When set to Auto, the HDBaseT
Long Reach @l

output will follow the current mode on the

© Copyright 2014. Hall Research, Inc.
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receiver. By default, it is the HDBaseT mode.

= Long Reach - When set to Long Reach, the HDBaseT output will have the
strongest signal from the sender to the receiver. However, this mode does not
support deep color or 4K video.

2.4. Status

The UHBX-3S Manager provides you an instant status update on input video, the
HDBaseT connection, and the current EDID passed to the video source.

Input Video
The input video status is indicated by an LED on/off. When the

LED is on, it means the indicated video type is detected. If the Input Video
LED is off, no video input is received. HOMI @
The HDCP LED is on/off when input video has HDCP Encryption HDCP @
enabled/disabled. oVl O
HDBaseT

The HDBaseT status is also indicated by

an LED on/off. When the LED is on, it HDBaseT 2 3
means the indicateq HDBaseT ‘connection Link "W W
is detected; otherwise, its LED is off. e e o
The cable length is measured in meters, Long Reach © @ C
and it is not applicable when the connection PoH @ & &
is in Long Reach mode. The calculation ApproxLength (m) 108 nfa 80

may vary according to cable quality.

When the Link LED is flashing, it is indicating the HDBaseT extender
module at the specified output is in Low Power mode due to either +5V
video source or HPD sink LCD being not detected.

EDID Table

The data shown in the EDID table is periodically scanned to ensure the checksums for
each block is valid. When an invalid checksum is detected, the last byte (location 256)
will be highlighted. This invalid checksum can cause connectivity problems.

n © Copyright 2014. Hall Research, Inc.
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EDID Table

00 01 02 03 04 05 06 07 08 09 0A 0B OC 0D OE OF
00|00 |FF |FF |FF |FF |FF |FF |00 |22 |49 |00 |02 | 00D | OO | OO | OO
01/0B |16 |01 |03 |80 |00 |00 |8C |EA|EE|[91 A3 |54 4C |99 | 26
02 |0OF |50 |54 |3F |CF |00 |81 |CO |81 |99 |90 |40 |95 |00 |A9 |40
03 (B3 |00 (D1 |CO (D100 (2 |10 (00 |80 (51 | D0 [1C | 20 | 40 | 80
04 35|00 |00 00 |00 |00 |00 |1E|BS |20 |00 |90 |51 |20 |1F |30
05|48 |80 |36 |00 |00 |00 |00 00|00 |1A |07 |3F |40 |30 |62 |BO
06 (2D | 40 |70 | AB (35 |00 (00 |00 (00 | OO |00 | 1A (2B | 3% | 90 | 30
07|62 | 1A |27 |40 |68 |BO |36 |00 |00 |00 |00 |00 |00 1A |01 | F7
08 |02 |03 |20 |F2 |46 |86 |82 |04 |05|10|1F |29 |09 |7F |07 | 15
09|07 |50 |3E |06 |CO |83 |1F |00 |00 |66 (03 (0C |00 |00 |00 |30
OA |02 |34 |30 (18 |71 (38 |2D (40 |08 (2C | 45 |00 |00 | 00 [ 00 | 0D
OB (00 [1E (02 (34 (B0 (DO |72 (38 (2D (40 | 10 |[2C |45 [ 30 | 00 | 00
OC (0O (0O (0O [1E (01 (1D (00 (72 |51 (DO |1E |20 |6E |28 | 55 | 00
0D | 00 |00 | 00 (00 |00 [1E |01 (1D |00 (BC |52 | DO |1E | 20 (B3 | 28
OE |55 (40 (00 (00 (0O (00 (OO [1E (OO (0O | OO | OO | OO | OO | OO | 00
OF |00 |00 |00 |00 |00|00/00 /00|00 |00 (00|00 |00 |00 |00|9C

2.5. Device Name

Assigns a descriptive name to the UHBX-3S device that is a maximum 8 characters long.
This information is stored in the device. Assigning unique Device Names to each device
can be useful to positively identify each device. This can prove handy if you are going to
upload different configurations for each device, or if you
intend to connect multiple devices simultaneously to a PC
and use the software to control several at once.

The FACTORY DEFAULT name is USBDEVHR.

File Tools Help
USBDEVHR

2.6. Status Bar
The bottom bar of the screen shows the USB connection status as follows:

This indicates the software has not detected any : ‘
UHBX-3S devices and is searching the USB ports | Scanning for Hardware .
for devices.

All controls and status are disabled until a valid UHBX-3S device is attached and properly
identified by the software.

The number of UHBX-3S devices will be shown; once, they
are connected to the PC. | Connected -1 ¢

© Copyright 2014. Hall Research, Inc.
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2.7. Tool Bar Menu

The UHBX-3S Manager consists of three main menus, which allow you to easily perform
more specific desired tasks.

File

The File menu consists of the Exit selection as & UHBX-3 Manager
shown. ‘

= Exit - Exit the UHBX-3S Manager.

File | Tools Help
Exit

Tools

The Tools menu consists of the following menu items as shown.

=  Factory Defaults — Restore the device to

factory default settings. .
File | Tools | Help
* Import EDID — Import an EDID (256-byte usg  Factory Default
binary into the unit). ]i Import EDID
= Export EDID - Save the current EDID as a B [
256-byte binary file. This file can be edited RN
as reloaded using Import EDID tool @ i 1
selection.

= HDBaseT Programmer — Can be used to update any HDBaseT extender module.
»  Firmware Update — Allow you to update any future device firmware.

Help
The Help menu has the About selection as shown.

= About... - Display the current version of s UHBX-35 Manager

UHBX-3S Manager, device firmware, and USB file Tools | Help
About...

serial number.

2.8. HDBaseT Programmer

The HDBaseT Programmer is only supported by the UHBX-3S firmware version 1.2 or
later. This HDBaseT programmer can be used to program the local HDBaseT extender
modules inside the UHBX-3S device. There are a total of 3 modules, and one module is
used at each HDBaseT ouput.

The HDBaseT Programmer can be found under the Tools menu. When the HDBaseT
Programmer is selected, the UHBX-3S Manager will open an HDBaseT Programmer
window as shown below.

n © Copyright 2014. Hall Research, Inc.
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Next, select a firmware to program it into a desired HDBaseT output module. A desired
output module is selected by having its box checked. If all three modules are needed to
be programmed, all three boxes next to Outputs 1-3 must be checked.

Once, it is ready for program, just click the Program button.

NOTE: A remote programming will be in the future firmware update.

The HDBaseT Programmer will verify the

firmware in the module after it has been

programmed. A completed or failed status

will be shown.

UHBX-35 Mansger (Connected)

Targel Device

@ Local

Local Device Info

EF

Programming Comgleted

Deice Type - FW Revision

3
P File Info
P Reision. 130383
Device Image:
Y FirmwaneF irmmwane UHEX-S-POFSE RS Bvowse.
1 2 3
COuiputs ol Cd v
Complated o o o

apsed Time (s) 74

Piogram

Ext
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2.9. Firmware Update

The firmware update can be found under the Tools menu. When the Firmware Update
is selected, the UHBX-3S Manager will open a Firmware Update window as shown.

r 5

UHBEX-35 Manager (Uploading Firmware Image...)

After the firmware update
is completed

Device Info
successfully, the UHBX-
. . Firmware: 1
3S will be running as
normal. FW File Info
Firmware: 14
Device Image:
X Browse...
| |
Uploading... L
———
(]
Device Mode: Programming
[ |
DONT CYCLE POWER UNIT I
s 4
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