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1 Tutorial: Fractal Image Generation using APU on the
Virtex-4 FX Platform (EDK 10.1)

Overview

This tutorial will demonstrate how to create, simulate and build an application targeting the Xilinx
Virtex-4 FX platform, including the use of data streams and the Auxiliary Peripheral Unit (APU)
interface. It includes all steps necessary to create a new platform using the Xilinx EDK 10.1 tools.

This example is described in Chapter 13 of Practical FPGA Programming in C.

This tutorial will require approximately one hour to complete, including software run times. To complete
the application, you will need access to a Xilinx ML403 development board (or equivalent board
equipped with a Xilinx Virtex-4 FX device), and a VGA monitor as shown above.

You should also download and read the following Xilinx Application Note APP901:
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Accelerating Software Applications Using the APU Controller and C-to-HDL Tools.

General Steps

This tutorial will take you through the entire process of creating a hardware-accelerated system in the
Virtex-4 FX FPGA using the Impulse and Xilinx tools. This is an advanced tutorial with many detailed
steps, but can be summarized as the following general steps:

1. Describe and simulate the application using C language and the Impulse CoDeveloper tools.
2. Automatically generate hardware, in the form of VHDL source files, for the hardware accelerator

portion of the application.
3. Export the generated files to an EDK project directory.
4. Build a new EDK project describing the PowerPC and all required peripherals, including the TFT

display peripheral.
5. Attach the hardware accelerator generated in step 2 to the PowerPC via the APU interface.
6. Add all needed software files representing the application to be run on the PowerPC.
7. Run synthesis and place-and-route to generate a downloable bitmap.
8. Download the application to the ML403 board using a JTAG programming cable.

Detailed Steps

Loading the Sample Application
Understanding the Mandelbrot Application
Compiling the Application for Simulation
Building the Application for Hardware
Exporting the Hardware and Software Files
Creating the ML403 Test Platform
Adding the Mandelbrot Hardware
Adding the Software Application Files
Building and Downloading the Application

1.1 Loading the Sample Application

Mandelbrot Extended Tutorial for Virtex-4 FX, Step 1

To begin, start the CoDeveloper Application Manager by selecting Application Manager from the
Start -> Programs -> Impulse Accelerated Technologies -> CoDeveloper program group.

Open the Xilinx Virtex-4 FX Mandelbrot sample project by selecting Open Project from the File
menu, or by clicking the Open Project toolbar button. Navigate to the
.\Examples\Embedded\Mandelbrot_Virtex4FX\ directory within your CoDeveloper installation. (You may
wish to copy this example to an alternate directory before beginning.) Opening the project will result in
the display of a window similar to the following:

http://direct.xilinx.com/bvdocs/appnotes/xapp901.pdf
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Files included in the Mandelbrot project include:

Source file mand_accel_hw.c - This source files includes the Mandelbrot fractal image generator
process, and also includes the application's configuration function.

Source file mand_accel_sw.c - This source file includes the test application that runs on the target
PowerPC processor. The test application includes a main() function, and a consumer/producer
function. As written, this test application can be compiled either on the PowerPC processor or as a
desktop simulation executable.

Source file mand.h - This source files includes global definitions, including the image size and
precision. This file also includes macros used for fixed-point math operations.

Other .C and .H source files - The remainder of the application source files are used for displaying
the results of the application (the generated fractal image) on an LCD display, and for creating a timer
used to compare performance.

See Also

Understanding the Mandelbrot Application

1.2 Understanding the Mandelbrot Application

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 2

Fractal texturing is a technique used in image rendering to create imagery with an organic appearance.
The Mandelbrot image generation algorithm is one example of fractal texturing. This sample
application is a fractal image generator that calculates and displays an image such as the one shown
below:
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To generate this image, the algorithm examines all points in a subregion of a complex plane that has
both real and imaginary parts between -2 and +2. The maximum number of iterations to determine if a
given point converges is defined by MAX_ITERATIONS, which is defined in source file mand.h. You
can increase this value for more precision in the generated output.

The generator is implemented as a single Impulse C process. The process accepts configuration data
defining the image subregion on a single input stream, and generates the resulting image as a stream
of pixels on the output stream. The provided software test bench is compatible with the PPC405
processor in the Virtex-4 FX, and communicates with the hardware process via the APU (Auxiliary
Peripheral Unit) interface.

The Virtex-4 APU Controller

The APU controller provides a flexible and high-bandwidth data transfer mechanism between the
FPGA fabric (via the Fabric Control Modules, or FCMs) and the embedded PowerPC processor on
Virtex-4 FX FPGAs. The APU interface is connected directly to the instruction pipeline and to one or
more FCMs. The advantage of this approach is that the typical latency associated with arbitration on a
peripheral bus (such as PLB or OPB) is absent.

The Virtex-4 APU controller performs two main functions:

· The APU provides a synchronization mechanism between the PowerPC processor and the FCM,
which may be running at a lower clock rate.

· The APU decodes instructions or allows the FCM to decode instructions. Execution, however, is
always carried out by the FCM.

When the instruction is due for decoding, it is presented to both the PowerPC processor and APU
controller. If the instruction is not recognized as a CPU instruction, the PowerPC processor looks for a
response from the APU controller to signal a valid instruction. If valid, the required operands are
fetched and passed to the APU for processing. Instructions directed towards the FCM can be either
predefined in the Instruction Set Architecture (ISA), such as floating-point instructions, or can be
user-defined instructions. The CoDeveloper toolset creates hardware cores designed to interface with
the PLB interface for easy integration into FPGA systems using XPS. In this example, CoDeveloper
uses the load/store instructions (predefined by the ISA) to transfer data between the PowerPC data
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memory system and the FCM.

See Also

Compiling the Application for Simulation

1.3 Compiling the Application for Simulation

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 3

The software test bench provided with this example (in mand_sw.c) has been written in such a way
that it can be compiled either to an FPGA as hardware (using fixed point math operations) or be
compiled for desktop simulation, using either fixed or floating point math operations. This makes it
possible to compile and simulate the application for the purpose of functional verification.

Select Project -> Build Simulation Executable (or click the Build Simulation Executable button) to
build the Mand.exe executable. The CoDeveloper transcript window will display the compile and link
messages as shown below:

You now have a Windows executable representing the application implemented as a desktop (console)
software application. You can run this executable by selecting Project -> Launch Simulation
Executable. A command window will open and the simulation executable will run as shown below:
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When complete, two BMP format files will be created in the project directory that represent the
generated hardware and software images, which have been sized for eventual display on the output
LCD (640 x 480):

See Also

Building the Application for Hardware

1.4 Building the Application for Hardware

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 4

Specifying the Platform Support Package

To specify a platform target, open the Generate Options dialog as shown below:
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Specify Xilinx Virtex-4 APU as shown. Also specify hw and sw for the hardware and software
directories as shown, and specify EDK for the hardware and software export directories. (EDK is the
directory in which you will be creating a Xilinx Platform Studio project.)

Also ensure that the Generate dual clocks option is selected as shown. (The Generate dual clocks
option is important because you will be clocking the PowerPC processor at a different rate than the
generated FPGA logic.)

Click OK to save the options and exit the dialog.

Generate HDL for the Hardware Process

To generate hardware in the form of HDL files, and to generate the associated software interfaces and
library files, select Generate HDL from the Project menu, or click the Generate HDL button as shown:
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A series of processing steps will run in a command window as shown below:

Note: the processing of this example may require a minute or more to complete, depending on the
performance of your system.

When processing has completed you will have a number of resulting files created in the hw and sw
subdirectories of your project directory. These files are ready to be exported into a Xilinx Platform
Studio project directory.

See Also

Exporting the Hardware and Software Files

1.5 Exporting the Hardware and Software Files

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 5

Recall that in the previous step you specified the directory EDK as the export target for hardware and
software. These export directories specify where the generated hardware and software processes are
to be copied when the Export Software and Export Hardware features of CoDeveloper are invoked.
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Within these target directories (in this case EDK), the specific destination for each file previously
generated is determined from the Platform Support Package architecture library files. It is therefore
important that the correct Platform Support Package (in this case Xilinx Virtex-4 APU) is selected
prior to starting the export process.

To export the files from the build directories (in this case hw and sw) to the export directories (in this
case the EDK directory), select Project -> Export Generated Hardware (HDL) and Project -> Export
Generated Software, or select the Export Generated Hardware and Export Generated Software
buttons from the toolbar.

Export the Hardware Files

Export the Software Files

Note: you must select BOTH Export Software and Export Hardware before going onto the next step.

You have now exported all necessary files from CoDeveloper for use in the Xilinx tools environment.
By opening a Windows Explorer window, you can see how the hardware and software files have been
copied into subdirectories of your EDK directory. In particular, notice that CoDeveloper has created a
pcores\apu_mand_v1_00_a directory containing the generated HDL and other related files. This
generated directory structure will allow you to import the generated core directly into the Platform
Studio tools.

See Also

Creating the ML403 Test Platform
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1.6 Creating the ML403 Test Platform

Mandelbrot Extended Tutorial for Virtex-4 FX, Step 7

At this point you have:

· Created hardware for the Mandelbrot accelerator.
· Exported the generated hardware to the EDK subdirectory as a pcore.
· Exported the PowerPC software application files to the EDK subirectory.

In this tutorial section, you will be making use of the Platform Studio tools, including the Base System
Builder Wizard, to define and build a new PowerPC-based platform targeting the Xilinx ML403
development board. You will first create a test platform allowing you to download and verify your
PowerPC and its standard peripherals. After successfully creating and testing the basic platform, you
will add the necessary hardware and software files to build, download and test the Mandelbrot sample
application.

Note: If you are using a different Virtex-4 FPGA development board, you will need to obtain an
associated XBD file from your board vendor, as described in the introduction to this tutorial.

Using Base System Builder to Create the Platform

To begin, start the Xilinx Platform Studio tools and select the Base System Builder wizard as
shown below:

Click the OK button to proceed. When asked for a project name and location, specify the EDK
subdirectory of your project, and accept the default project name (system.xmp) as shown below:
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Press the OK button to continue.

You will now be presented with the Base System Builder wizard. Select the I would like to create a
new design option, then click Next to continue:

Next, select your target board using the Board vendor and Board name drop-down lists. To use the
Xilinx ML403 board with attached LCD display, choose the Virtex 4 ML403 with TFT as shown:
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Click the Next button to proceed to the next wizard page.

On the Select Processor page, make sure PowerPC is selected as the target processor, then click
Next:
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On the Configure PowerPC Processor page, specify the following options:

Processor clock frequency: 200 MHz
Debug I/O: JTAG
Cache setup: Enable
On-chip memory: 16 KB each for data and instruction
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Click Next to continue. You will now be presented with a series of pages for configuring various I/O
interfaces. Select the RS232_Uart and LEDs_4Bit peripherals as shown, but do not select the
LEDs_Positions and the Push_Button_Position peripheral:

Click Next.
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On the next wizard page, select only the DDR_SDRAM peripheral:

Click Next.

On the page that follows, do not select any of the peripherals:
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Click Next.

On the Add Internal Peripherals page, remove the plb_bram_if_cntlr_1 as shown:
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Click Add Peripherals... to add an XPS TIMER to the design.

Set up the xps_timer_1 as shown below:

Click Next.

On the Cache Setup page, enable both cache selections as shown:



Tutorial Mandelbrot PowerPC ML403 EDK10.118

© 2003-2009 Impulse Accelerated Technologies, Inc.

Click Next.

The wizard will now ask if you want to create memory and peripheral test applications. Select the
Peripheral selftest application, but do not select the Memory test application:

Click Next.

You will now be prompted for memory locations for Instruction, Data and Stack/Heap for the
PeripheralTest application. Select ppc405_0_iocm_cntlr for the Instruction field, and
ppc405_0_docm_cntlr for the Data and Stack/Heap fields as shown below:
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Click Next.

The wizard will now display a summary of your platform selections:
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Click the Generate button to generate the platform with the specified configurations. After the platform
has been generated, the wizard will display a final page, and will give you the option of saving the
platform settings to a .BSB file. This file can be used when creating new platforms with similar settings.
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Click Finish to exit the wizard.

The Platform Studio interface will now appear similar to the following:
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Building and Running the Peripheral Test

Before creating and building the Mandelbrot sample application, it is a good idea to do a quick test of
the platform, using the Peripheral Selftest application created by Base System Builder. To build the
test application, you must first generate the PowerPC libraries, peripheral drivers, and other files
needed for the software portion of the application. To do this, select the Generate Libraries and BSPs
command from the Software menu as shown below:

When the libraries have been built, Platform Studio will display a message similar to the following:
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Next, select the Generate Bitstream command from the Hardware menu. This command starts the
synthesis and place-and-route process, resulting in a downloadable .BIT file.

After the bitstream generation has completed, make sure your JTAG cable is plugged in properly and
the ML403 board is powered up. Select Download Bitstream from the Device Configuration menu
as shown below:

When the FPGA has been successfully programmed, you will see a Programming Complete
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message in the Platform Studio transcript, and you will see a small row of LEDs located at the lower
right corner of the board light up in sequence on the lower right corner of board.

You have now verified the complete design flow and all needed hardware connections, from Platform
Studio and Base System Builder to the ML403 board. In the next tutorial section, you will replace this
test application with a new application representing the Mandelbrot fractal image generator.

See Also

Adding the Mandelbrot Hardware

1.7 Adding the Mandelbrot Hardware

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 8

In the previous step you used Xilinx Platform Studio and the Base System Builder to create a test
application, ready to download and run on the ML403 board. This test was important because it
established that all required peripherals, memories, etc. had been properly assembled, forming a base
platform on which the Mandelbrot example can be implemented.

In the steps that remain, we will modify the base platform to:

· Configure clock generator component
· Configure the TFT display
· Add the Mandelbrot APU accelerator
· Add the Mandelbrot software application files
· Build the platform, including synthesizing the new cores
· Download and run the Mandelbrot application on the target board

Configuring the Clock Generator

Our fractal image generator application requires three distinct clock sources, one for the PowerPC
processor, one for the Fabric Co-processor Bus (FCB), and one for the hardware accelerator, which
in this example runs at 40 MHz. The TFT Controller needs a 25 MHz clock.

To configure the Clock Generator, right-click the clock_generator_0 to open the Configure IP option
as shown below:
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Add a new clock output in CLKOUT3, type in the name pcore_co_clk, and frequency as 40,000,000
Hz as shown:
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Add another clock output in CLKOUT4, type in the name tft_25mhz_clk, and frequency as 25,000,000
Hz as shown:

Adding the Mandelbrot Accelerator Core

To add the Mandelbrot fractal image generator core as a peripheral, select the IP Catalog tab and look
for the category titled Project Local pcores. Under USER directory you will find the two cores that
were created (copied to) the EDK/pcores directory of your project. Add the apu_mand core by right-
clicking and selecting Add IP as shown below:
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This will add the core to the project as a peripheral.

Adding Fabric Co-processor Bus

To connect the peripheral to the PowerPC via the APU interface, you will also need to add a Fabric
Co-processor Bus (FCB) to the system. To add this core, select the Bus and Bridge category and
find the Fabric Co-processor Bus item. Add the FCB to your system by by right-clicking and selecting
Add IP as shown below:
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After you have added the FCB, it will appear in the Platform Studio connections window as shown
below. Use the mouse pointer to select and connect the MFCB port of the ppc405_0 to the FCB, by
clicking on the square connection point, and then connect the apu_mand_0 peripheral (SFCB
connection) to the FCB as shown below (and indicated by the the red circle):
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The apu_mand_0 peripheral is now connected to the PowerPC APU via the FCB.

Adding the XPS_TFT IP Core

The XPS_TFT IP Core controls the Thin Film Transistor (TFT) LCD Display, which gives us the
graphical output of the computation results.

The XPS_TFT IP Core is located under the IO Modules category of the IP Catalog. Add it by by right-
clicking and selecting Add IP as shown below:



Tutorial Mandelbrot PowerPC ML403 EDK10.130

© 2003-2009 Impulse Accelerated Technologies, Inc.

Next, edit the settings of the newly added xps_tft_0 module by right-clicking and selecting Configure
IP ...
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In order to expose the VGA interface, unselect the Select TFT Interface option.
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Modifying the TFT Base Address Parameter

The Base Address of PLB Attached Video Memory parameter sets the starting address of the TFT
image memory. This address is the key point to have the TFT LCD display properly, and you will need
to set the corresponding value in the software code. (See xtft_main.c, line 174.)

Change the Base Address of PLB Attached Video Memory to 0x08000000 as shown below:
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Clink OK to save the change.

The XPS_TFT  has a Master PLB and a Slave PLB bus interface. We need to add an additional PLB
bus to connect the XPS_TFT to the DDR_SDRAM. Add a Processor Local Bus (PLB) as shown
below:
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The MPLB of xps_tft_0 needs to be connected to the DDR_SDRAM through a separate SPLB port.
To do this, open the Configure IP dialog of the DDR_SDRAM:
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Change the Port Type Configuration of Port 2 from INACTIVE to PLBV46 as shown below. This will
add another PLBV46 port to the DDR_SDRAM.

Then, connect the MPLB of the xps_tft_0 to the newly added PLB, also conect the SPLB2 of the
DDR_SDRAM to the same PLB. Connect the SPLB of the xps_tft_0 to the shared PLB as shown
below (as indicated in red circles):
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Connecting the Peripheral Clock and Reset Signals

To do this, switch to the Ports tab in the System Assembly View window.

First, connect the following 6 ports of the xps_tft_0 to outside of the FPGA by select the Make
External for each port as shown below:

TFT_VGA_B
TFT_VGA_G
TFT_VGA_R
TFT_VGA_CLK
TFT_VSYNC
TFT_HSYNC
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Connect the SYS_TFT_Clk port to the tft_25mhz_clk from the Clock Generator as shown below:

The next step is to connect the two apu_mand_0 clock signals. To do this, change the apu_clk entry
to sys_clk_s as shown below:
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Now change the co_clk entry to pcore_co_clk as shown below:

Connect the FCB_CLK signal of the fcb_v10_0 peripheral to sys_clk_s:

And connect the SYS_RST signal of fcb_v10_0 to sys_bus_reset:
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Connect the PLB_Clk signal of the plb_v46_0 peripheral to sys_clk_s:

And connect the SYS_Rst signal of plb_v46_0 to sys_bus_reset:
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The Ports view of your project should now appear similar to the following:
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Modifying the C_APU_CONTROL Parameter

The C_APU_CONTROL parameter is used to enable the APU interface, which in this example is used
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to transmit data between the PowerPC processor and the hardware accelerator. This parameter can
be viewed and edited in the Configure IP dialogue as shown below.

Switch to the APU tab and change the APU Controller Configuration Register Initial Value to
0b0000000000000001 as shown below:

Adding XPS_TFT Constraints

Since the XPS_TFT module is not added in the BSB, its constaints, such as port locations and types,
need to be added manually to the UCF file associated with the project (system.ucf). To edit this file, in
the Project tab, find the UCF file listed under Project Files as shown below. Double-click on the UCF
File: data/system.ucf entry to open the file.
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Using the editing window that appears, add the following lines shown below to the end of the UCF file:

#### Module xps_tft constraints

NET xps_tft_0_TFT_VGA_B_pin<1> LOC = C5;  # VGA_B3
NET xps_tft_0_TFT_VGA_B_pin<2> LOC = C7;  # VGA_B4
NET xps_tft_0_TFT_VGA_B_pin<3> LOC = B7;  # VGA_B5
NET xps_tft_0_TFT_VGA_B_pin<4> LOC = G8;  # VGA_B6
NET xps_tft_0_TFT_VGA_B_pin<5> LOC = F8;  # VGA_B7
NET xps_tft_0_TFT_VGA_B_pin<*> SLEW = FAST | DRIVE = 8;

NET xps_tft_0_TFT_VGA_G_pin<1> LOC = E4;  # VGA_G3
NET xps_tft_0_TFT_VGA_G_pin<2> LOC = D3;  # VGA_G4
NET xps_tft_0_TFT_VGA_G_pin<3> LOC = H7;  # VGA_G5
NET xps_tft_0_TFT_VGA_G_pin<4> LOC = H8;  # VGA_G6
NET xps_tft_0_TFT_VGA_G_pin<5> LOC = C1;  # VGA_G7
NET xps_tft_0_TFT_VGA_G_pin<*> SLEW = FAST | DRIVE = 8;

NET xps_tft_0_TFT_VGA_R_pin<1> LOC = C2; #VGA_R3
NET xps_tft_0_TFT_VGA_R_pin<2> LOC = G7; #VGA_R4
NET xps_tft_0_TFT_VGA_R_pin<3> LOC = F7; #VGA_R5
NET xps_tft_0_TFT_VGA_R_pin<4> LOC = E5; #VGA_R6
NET xps_tft_0_TFT_VGA_R_pin<5> LOC = E6; #VGA_R7
NET xps_tft_0_TFT_VGA_R_pin<*> SLEW = FAST | DRIVE = 8;

NET xps_tft_0_TFT_VGA_CLK_pin LOC = AF8;
NET xps_tft_0_TFT_VGA_CLK_pin IOSTANDARD = LVDCI_33 | SLEW = FAST | DRIVE = 8;

NET xps_tft_0_TFT_VSYNC_pin LOC = A8;
NET xps_tft_0_TFT_VSYNC_pin SLEW = FAST | DRIVE = 8;

NET xps_tft_0_TFT_HSYNC_pin LOC = C10;
NET xps_tft_0_TFT_HSYNC_pin SLEW = FAST | DRIVE = 8;

The modified UCF file should look as shown below:
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Save the UCF file using the menu File -> Save command, then close the editing window.

Generate Addresses

Next step is to generate addresses for the memory related modules in EDK. Switch to the Addresses
tab of the System Assembly View Window.

First, change the size of the DDR_SDRAM from 64MB to 256MB. The actual size of the DDR_SDRAM
is 64MB. The purpose of mapping it to upper address space is to use the uncached memory space for
the TFT image memory.

Next, click the Generate Addresses button on the upper right corner to let EDK assign addresses for
the modules as shown below:
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An error message might show up when generating the addresses:

ERROR:MDT - C_IDCR_BASEADDRof ppc405_0 has no high address in MHS

If this happens, add the following line to the ppc405_virtex4 paremeters, in the system.mhs file:

 PARAMETER C_IDCR_HIGHADDR = 0b0111111111

Before buiding the hardware, check the system.mhs file to make sure that ppc405_virtex4 comes
before all other instances. If not, move it to the top. The instance order might affect the hardware
synthesis for some reason.

Now, build the hardware by choosing the Hardware -> Generate Bitstream menu. The synthesis,
place-and-route and bitstream generation process will take a few minutes to complete depending on
your PC.

During the building process, an error message might pop up due to a known issue with the EDK
software:

 FATAL_ERROR: GuiUtilities:Gq_Application.c:590:1.20

If this happens, just close the EDK window, and then re-open it and restart the building process.
Clearing the output window frequently may help. Please refer to  Xilinx Answers Database for a
possible solution.

After the process is done, a file called system.bit is created.

http://www.xilinx.com/support/answers/30859.htm
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The hardware side of the application, including the APU interface and Mandelbrot fractal image
generator core, is now ready for use. In the next tutorial section you will set up the software side of the
application.

See Also

Adding the Software Application Files

1.8 Adding the Software Application Files

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 9

The hardware configuration, including all required peripheral settings and connections, is now
complete. The next step is to add the Mandelbrot sample application.

Create Mandelbrot Software Application

Select the Applications tab of the project, double-click the Add Software Application Project to
show a dialogue. Type in mand as the Project Name as shown below:
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Click OK to continue.

Adding the Mandelbrot Application Source Files

To add source C files to the project, open the Add Existing Files dialogue from the Sources category
by right-clicking as shown below:

Select all files from the code subdirectory of your project as shown below:
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Next, add header files to your project similar to above as shown below:
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Setting Compiler Options

Now you will need to set a few compiler options for the project. To set the compiler options, double-
click on the Compiler Options under the Project: mand:
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In the Environment tab, select Use Default Linker Script, set the Program Start Address as
0x02000000 to avoid overlap with the TFT image memory location. Then enter Stack Size and Heap
Size values of 0x4000 and 0x8000, respectively:

Click OK to close the Compiler Options dialog.

The software application is now ready to compile for the PowerPC processor.

See Also

Building and Downloading the Application

1.9 Building and Downloading the Application

Mandelbrot  Extended Tutorial for Virtex-4 FX, Step 10

The Mandelbrot application is now ready to build, download and execute on the target ML403 board.

First, compile the software application to create a PowerPC executable. Do this by selecting Build
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Project from the Project: mand entry as shown below:

The size of the generated executable is shown below. It will be included in the FPGA bitstream.

Next, mark the ppc405_bootloop to initialize BRAMs by using the right mouse button. This will put a
loop in the starting address of the on-chip memory.
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Now, it is time to download the bitstream to the ML403 board. Make sure the JTAG cable is properly
connected and that the ML403 board is powered on. Also make sure the VGA display is connected
and powered on.

Select Download Bitstream as shown below:

Next, launch Xilinx Microprocessor Debugger (XMD) from the menu as shown below:

If this is the first time you have launched XMD for this EDK project, the XMD Debug Options dialogue
will pop up. Just click OK to accept the default settings, then the XMD terminal will appear.
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Download the Mandelbrot ELF file to the DDR_SDRAM, and then start running the program as
follows:

After downloading has completed, the application will start running, resulting in a display similar to the
following:
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Congratulations! You have completed this advanced tutorial.
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