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Getting Started

Welcome  to  the  Peer  Administrator  v4.0  software.   This  software  allows  for  the  ability  to
monitor PeerSync  and PeerLock  activity across the LAN for the centralized viewing of all
PeerSync  and  PeerLock  activity  on the  network.  The  Peer Administrator  is  a  receptor
application  that  receives  specific  information  from  running  PeerSync  and  PeerLock
 applications  on the  network.  As  a  receptor, it  displays  changes  from  the  PeerSync  and
PeerLock  applications based solely on their ability to connect and transmit that information
successfully to the Peer Administrator.  

Ne w Enha nce me nts

http://www.peersoftware.com/about_us/our-privacy-policy.aspx
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The Peer Administrator introduces new capabilities  that simplify  deploying, configuring, and
managing  multiple  PeerSync  instances  throughout  the  network.   With  just  a  few  clicks,
administrators  can  configure,  update,  distribute  and  monitor  all  running  instances  of
PeerSync. Email Alerts may be enabled for immediate status notifications. 

Pre re q uis ite s

1. Peer Administrator v4.0 should be installed on any Windows computer on the  network  with
access  to  all  other  computers  running  PeerSync  and/or  PeerLock .   From  the
computer  running  Peer  Administrator  you  need  to  be  able  to  navigate  and  access  the
machines running  PeerSync  and/or PeerLock  through  Network  Neighborhood  or  an
Explorer window. A trust must exist between different domains  within the  same  network  for
the  Peer  Administrator  to  be  able  to  receive  status  across  domains.  Your  firewall  also
needs  to  allow for  broadcast  traffic  between  the  Peer  Administrator  and  PeerSync  and
PeerLock.  

2. If Peer Administrator resides on a separate subnet than PeerSync,  then you will need  to
add  the  /GO:MachineName    or the  /GO:DomainName     command  line  argument  where
MachineName  and DomainName  represent the name and the domain of the  machine  on
which the Peer Administrator is running. 

3. Alternatively, if the Peer Administrator is having problems receiving status  information from
PeerSyncs  and  PeerLocks  running  on  the  domain  or  across  the  VPN,  open  the
Domain List dialog, right-click  and  select "Add  New Item". Enter the  name  of the  machine
where PeerSync  and PeerLock  reside.

4. In order to be able to utilize  all functions  of the  Peer Administrator product we  recommend
using  PeerSync  versions  7.3.2  or  higher  and  PeerLock  versions  2.0  or  higher.  
However, you may still  be  able  to  receive  limited  status  display  information  from  earlier
versions of PeerSync . 

Limita tio ns/Co mme nts

1. PeerSync  and  the  Peer  Administrator  utilize  Microsoft  mail  slots  for  communication
purposes.  This  method  ensures  that  all  communications  will  be  secured  by  the  built  in
security  of  your  Microsoft  Windows  network  environment  and  no  additional  security
methods  need  to  be  implemented.   In  other  words,  if  the  running  applications  have  the
privileges  to  access  each  others  information,  then  the  mail  slots  will  allow  interactive
communication.   Otherwise communication will be denied.

2. The Peer Administrator and PeerSync  both use the  same  mail slot to  send  and  receive
status  information.   Therefore  running  both  products  on  the  same  computer  will  limit  the
status  display  within  PeerSync  and  activity  reporting  in  the  Peer  Administrator.   A
solution to  this  would  be  to  disable  status  display  in the  PeerSync  Profiler  by  going  to
the  Op tio ns/Co mma nd s  window, click  on  Disp la y  Op tio ns ,  and  un-check  Disp la y
sta tus  in  Pro file r  (or  un-check  Ena b le  Ba s ic  D isp la y  and  Ena b le  Ad va nce d
Disp la y  in version 9.0 or newer).  Make  sure  you  save  and  restart  PeerSync  and  the
Peer Administrator.

3. If the computer on which the Peer Administrator is running cannot navigate to or access the

http://www.peersoftware.com/products/management-monitoring/peer-administrator.html
http://www.peersoftware.com/products/management-monitoring/peer-administrator.html
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machines  on  which  PeerSync  and/or  PeerLock  are  running  through  Network
Neighborhood or an Explorer window, then communication cannot take place  between the
applications. 

4. If a connection is lost, the  implication is  that PeerSync  and  PeerLock  are  not running,
however, that may not be the case.  PeerSync  and  PeerLock  may be  running  fine  but
the network path between the applications has been compromised.

5. Only a single copy of the Peer Administrator can run on a computer.

6. For PeerSync  versions older then 7.3.2, please enable the Se nd  s ta tus  info rma tio n to
Pe e r Ad minis tra to r option from the Op tio ns/Co mma nd s  > Disp la y  Op tio ns  window. 

Pe e r Ad minis tra to r Ins ta lla tio ns  a nd  Re g is tra tio n

Peer  Administrator  is  shipped  (downloaded)  in  a  full  installation  program.  To  run,  simply
double  click  on  the  executable  file  from  the  explorer  (or  select  the  application  from  the
Windows Start menu). 

Evaluation  copies  do  not  require  user  information  and  passwords.  Registration  copies
require you to enter a Registration Key into  the  Register Software  Screen. When purchased,
Peer  Software  will  send  the  Authorization  Key  required  to  unlock  the  Peer  Administrator
evaluation.  This key is to be entered during the installation of the software.

If this is an unregistered or evaluation copy of Peer Administrator, you can register it with Peer
Software,  Inc.  as  a  fully  licensed  copy  by  providing  credit  card  information  via  phone  or
secure Internet registration, or by sending a check or money order to the address below (see
included "readme.txt" file for pricing information).

Register online via secure internet credit card registration at http://www.peersoftware.com

Register by phone via credit card by calling: 
703.763.7700 between the hours of 9:00 AM and 5:00 PM EST

Register by mail, send check or money order to:  
Peer Software, Inc.
5900 Fort Drive, Suite 415
Centreville, NY 20121

Up g ra d e  Info rma tio n

As  new  updates/changes  become  available,  updated  versions  of  the  software  will  be
posted  on  our  web  page  http://www.peersoftware.com.  Check  this  page  periodically  to
download  the  latest executables.  Your Authorization Key will continue  to  work  with  updated
versions  unless  a  major  release  is  issued,  or  Peer  Administrator  is  installed  in  a  different
folder than the previously installed/authorized  version. Please  refer to  the  WhatsNew and/or
ReadMe  files  shipped  with  the  Peer  Administrator  installation  for  the  latest  upgrade
information. 

To upgrade, double-click on the installation file (peeradmin40.exe) in the  Explorer window, or
choose  "Run" from the  Start Menu and  then select the  application. If  you  are  upgrading  the

http://www.peersoftware.com
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current  version  of  Peer  Administrator  (3.6  to  4.0)  simply  install  the  application  over  your
existing Peer Administrator and the previous version will be backed up  in a  sub-folder called
'BACKUP' (if the option to keep a backup is selected during the installation).

If  you  are  evaluating  a  new version  of  Peer  Administrator   4.0  and  you  already  have  an
existing  copy  of  Peer  Administrator  3.6  or  older,  please  select  a  new directory  during  the
installation.

Pro d uct Sup p o rt

All  support  of  Peer  Administrator  will  be  handled  on  our  website  (http://
www.peersoftware.com) support page for this product. 

T e rms And  Co nd itio ns

Read License agreement before using this program.

Suggestions, Comments, or Requests for Support:

Peer Software, Inc.
5900 Fort Drive, Suite 415
Centreville, NY 20121
Phone: 703.763.7700
FAX: 703.763.7705
Email: support@peersoftware.com

The manufacturer of Peer Administrator makes no warranties, implied or otherwise, for use of this product. User assumes
all responsibility for any data loss or damage.

Copyright © 1993-2013 Peer Software Inc. All Rights Reserved Privacy Policy

Peer Administrator, PeerSync, and PeerLock are registered trademarks of Peer Software, Inc.
Reproduction in whole or in part without permission is strictly prohibited.

The Peer Administrator Help Manual was built on Wednesday, February 20, 2013

Menu

File Menu

File  Me nu

Sa ve  De fa ults This  option gets  displayed  in  the  File  menu.  When  selected,
the  Peer  Administrator  will  store  out  all  interface  settings,
including  positions  of  windows,  into  the  PSOBSDEF.CFG  file.

mailto:support@peersoftware.com
http://www.peersoftware.com/about_us/our-privacy-policy.aspx
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By  default  interface  changes  will  only  be  saved  when  the
application closes.

Exit Terminates  the  Peer  Administrator.   If  the  "Save  Content  on
Close"  option is  enabled  for Reporting  the  Peer  Administrator
will prompt you for a  report path upon closing  the  application. 
This setting is enabled by default. 

*  If  the  Terminate  Remote  Link  on  Close  Option  is  enabled,
each connected  PeerSync  and  PeerLock  will  be  notified
to stop reporting information across  the  network  when the  Peer
Administrator  is  terminated  reducing  unnecessary  network
traffic.   This  change  does  not  affect  communication  to  other
Peer Administrators running on the network.

* Note: Option available for PeerSync  versions 7.3.2 or higher.

Edit Menu

Ed it Me nu

Se tting s Opens  the  Settings  dialog  box/window  for  additional  Peer
Administrator configuration such as color key  settings, listing  of
available  domains,  reporting,  activity  monitor  options,  and
other miscellaneous settings. 

Pro file  Op e ra tio ns... Selecting  this  option  will  open  the  Profile  Operations  dialog
which  supports  functionality  such  as  Stopping,  Starting,
Pausing  PeerSync  services  and  editing/submitting  Profile
changes.
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View Menu

Vie w Me nu

Pe e rSync D isp la y
Op tio ns  

Re fre sh Pe e rSync D isp la y  F5
Clears  and  repopulates  all  active  connections  from  the
PeerSync Activity Table.

Cle a r/Re fre sh Entrie s ...
Clears  or  refreshes  the  following  PeerSync  Activity  Table
entries: 

Active Refreshes all connections that  are  active (receiving
or paused).

Passive Refreshes  all  passive  connections.  Completed,
terminated, or failed Profiles will  be cleared from the
list. 

All Refreshes  the  PeerSync  Activity  Table  to  display
new running Profiles and clearing completed,  failed,
or terminated sessions. 

Note:  These are global  settings which apply  to  all  tabs/ groups  within  the
PeerSync Activity Table.

Re -Se nd  Co nne ctio n Re q ue sts
Broadcasts message  to  all PeerSync  Profiles  running  within
the designated  domain to  begin transmitting  status  information
to the Peer Administrator.

Use  T a b  Gro up
Disabled by default, this option creates Tabs for all the items in
the PeerSync Activity  Table  based  on their Profile  names.  All
Profiles running with the  same  name  will be  grouped  under the
same  Tab. The  name  of each Tab  becomes the  name  of  the
Profiles running  in that group  followed  by  two  values (x/y). The
first  (x)  represents  the  number  of  Failed  or  Not  Responding
Profiles  in  the  group  and  the  second  (y)  represents  the  total
number  of  Profiles  in  the  group.  By  default  the  Tabs  will  be
displayed  on  top  of  the  PeerSyncActivity  Table  in  multiple
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rows/lines. 

Pe e rLo ck D isp la y
Op tio ns

Re fre sh Pe e rLo ck D isp la y  F5
Clears and repopulates all lock entries from the Locked List.

Re -Se nd  Co nne ctio n Re q ue sts
Broadcasts  message  to  all  PeerLocks  running  within  the
designated  domain  to  begin  transmitting  status  information  to
the Peer Administrator.

Auto  Re fre sh Lis ts  whe n Cha ng ing  T a b s
Enabled  by  default, this  option causes the  PeerLock  Lo cke d
File s  and  Re le a se d  File s  lists  to  be  refreshed  when
changing  tabs.  Otherwise,  these  lists  only  get  updated  when
clicking  on the  Re fre sh   Re le a se d  File s  link  above  the  list
at the right or by hitting F5 or F6.

Auto  Re fre sh Lis ts  a fte r Re le a s ing  Lo cks
Enabled by default, this option causes PeerLock to  refresh the
Lo cke d  File s  and  Re le a se d  File s  lists  after  manually
releasing one or more locks.

Use  Re le a se  Lis t D isp la y  Limit
Disabled  by  default,  this  option  will  only  display  the  last  100
entries  in the  PeerLock Lo cke d  File s  and  Re le a se d  File s
list. When disabled, the  Lo cke d  File s  and  Re le a se d  File s
panels  will  contain  as  many  entries  as  displayed  in  the
selected  PeerLock(s).  For  example,  if  PeerLock  is  limited  to
displaying up to 300 locked  entries, the  Locked  Files  list in the
Peer Administrator will display all 300 entries, plus  entries  from
any other PeerLocks, if selected.

Re p o rting Vie w
Opens the latest Peer Administrator.TXT file that exists.

Note:  By  default,  the  Peer  Administrator  report  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

De le te
Clears  the  content  of  the  latest  Peer  Administrator.TXT  file
created. 

Note:  By  default,  the  Peer  Administrator  report  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

Sa ve
Allows you to specify the name and location for your report file.
 The  report  file  can  also  be  saved  in  an  MS  Excel  format  by
changing the extension from .txt to .xls.

Note:  By  default,  the  Peer  Administrator  report  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
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menu.

Ap p e nd
Appends the  content of the  current PeerSync Activity  Table  to
the latest report file. 

Note:  By  default,  the  Peer  Administrator  report  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

Cre a te /Ove rwrite
Creates  a  new  report  file  with  the  latest  Network  Activity
information in the  directory  specified.  If the  file  already  exists,
the  application  will  give  you  the  option  to  either  overwrite  the
file or append the current Network Activity information to it. 

Note:  By  default,  the  Peer  Administrator  report  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

Sa ve  Co nte nt o n Clo se  
By default this option is enabled.  At the  time  you exit/close  the
application  the  Peer  Administrator  will  store  out  the  latest
Network  Activity  information  into  the  current  report  file.   If  no
report file exists, you will then be able to create one. 

Note:  By  default,  the  Peer  Administrator  report  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

Lo g g ing Vie w
The  log  file  maintains  a  running  summary  of  activities  picked
up by the Peer Administrator. This option opens the  latest Peer
Administrator.LOG file that exists.

Note:  By  default,  the  Peer  Administrator  log  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

De le te
Clears the content of the Peer Administrator.LOG file. 

Note:  By  default,  the  Peer  Administrator  log  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
menu.

Ena b le  Lo g g ing
By default this option is  enabled.  When this  setting  is  enabled
the  Peer  Administrator  will  store  Profile  activities  in  the  Peer
Administrator.LOG file. 

Note:  By  default,  the  Peer  Administrator  log  files  get  stored  in  the  same
directory where the Peer Administrator application file is located.  To modify the
default location, go to the Reporting dialog accessible from the Edit -> Settings
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menu.

Auto  So rt T a b le  b y
Sta tus  Le ve l 

Enabled  by  default,  this  setting  will  sort  all  PeerSync  and
PeerLock  table  entries  by  the  Status  Level  column.  This
setting  applies  to  both  PeerSync  and  PeerLock  Activity
Tables. 

Sho w Ad min Eve nts  When  selected  it  will  display  the  Admin  Events  Panel  at  the
bottom of the Peer Administrator interface. By  default this  table
will show all errors that result due to administrative actions  such
as  failing  to  copy  a  remote  Profile  locally  for  purposes  of
editing. Right-click on this  table  and  uncheck the   Show Failed
Events  Only  option  to  display  all  messaging  transactions
between PeerSync , PeerLock , and the Peer Administrator.

Sho w Activ ity  Pa ne ls Sho w Pe e rSync
Shows  or  Hides  the  PeerSync  Activity  Panel.  It  can  only  be
hidden when the  PeerLock Activity  Panel is  visible. One  of the
two panels must be shown.

Sho w Pe e rLo ck
Shows  or  Hides  the  PeerLock  Activity  Panel.  It  can  only  be
hidden when the  PeerSync Activity  Panel is  visible. One  of the
two panels must be shown.

Sho w Bo th (Default)
Shows  or  Hides  both  the  PeerSync  Activity  Panel  and  the
PeerLock Activity Panel .

Sho w Co lo r Le g e nd
Pa ne l

Displays  the  Color  Legend  Panel  below  the  PeerSync  or
PeerLock Activity Tables.  This setting is enabled by default.  

Help Menu

He lp  Me nu

Pe e r Ad minis tra to r
He lp  F1

Opens  the  default  Help  Content.  This  requires  that  the  Help
Manual  is  located  in  the  Peer  Administrator's  installation
directory.  

We b  Site Our Ho me  Pa g e
Link  to  the  Peer  Administrator  home  page  at
www.peersoftware.com which provides quick and easy access
to our product information, 

http://www.peersoftware.com
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Online  Sup p o rt
Provides  access  to  product  Knowledge  Base  pages,  Online
Forum, Support team contact, and product updates. 

La te st Ne ws
Link  to  the  News  page  for  a  listing  of  press  releases,  white
papers  ,and  success  stories  referencing  Peer  Software
products.

Co nta ct Us
Companies  address,  phone  number,  and  e-mail.  You  may
also complete and submit a request through the  form available
on this page. 

Re g is te r Pe e r
Ad minis tra to r

Opens the Registration window.  A product Key is  issued  at the
time  of  purchase  and  is  required  in  order  to  fully  register  the
product.  Otherwise  the  Peer  Administrator  will  run  for  a  trial
period before it becomes non-functional. 

Lice nse  Info rma tio n Opens the Product Editions and Licensing  dialog. This  window
shows  the  current  packages,  options,  and  functionalities  the
Peer Administrator is registered to use. 

Ab o ut Pe e r
Ad minis tra to r

The  About  window  displays  the  product  details  such  as  the
version  number,  build  date,  registration  information,  and
company contact details.  

PeerSync Activity Panel

PeerSync Activity Panel

Pe e rSync Activ ity  T a b le  Co lumns

The Activity Table displays PeerSync  Profile activities in tabular format.  This  is  the
primary visual feedback display  for all connected  and  running  PeerSyncs   on your
network.   Through  this  display  you  can  expand  detailed  information  about  one  or
more  connections  and  have  some  limited  control  over  the  connected  and  running
PeerSyncs   around  your  network.   Below  is  a  description  of  each  column
represented in the PeerSync Activity Table.

Pe e rSync Co mp ute r Lists  the  name  of  the  computer  on  which  a  specific  Profile  is
running.  When (SVC) is  displayed  at the  end  of  the  computer
name, it  signifies  that  the  Profile  is  running  as  a  Service.    
When  (NP)  is  displayed  at  the  end  of  the  computer  name,  it
signifies  that the  Profile  is  running  in  a  Non  Persistent  mode.  
This  means that  PeerSync  will  terminate  once  it  completes
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its  Job(s).  This  notation  tells  you  that  PeerSync  terminated
expectedly. 

Gro up  Displays  the  Name  or  Group  Name  of  the  Profile  (.snc)
currently  running  on  a  computer.   By  default,  the  Peer
Administrator  uses  the  name  of  the  running  Profile.   You  can
specify  a  Group  Name  for your Profile  by  adding  /GOC:group
  to the list of command line arguments in PeerSync  (see the /
GO option in the PeerSync  Help Manual). 

Curre nt Sta tus  Shows the status of each running Profile. 

Not Connected Displayed  when  PeerSync  is  running  but  not
transmitting  status  information  to  the  Peer
Administrator.   In  PeerSync  versions  older  then
7.3.2  this  has  to  be  enabled  manually  from  the
PeerSync  Profiler. 

Processing
Selected Jobs

Generally shown for Non Persistent (NP) Profiles.

Job/ Copy Threads Shown for persistent Jobs running multiple threads.

Daily Timer w/ RT Shown for persistent Jobs running in a schedule and
real-time mode.

Finished Specific  Profile  terminated  after  successfully
completing its Job(s). 

Activ ity Shows the activity of each Profile running. 

Monitoring
(Persistent)

Displayed  for  persistent  Profiles  such  as  Profiles
running in  real-time,  on  schedule,  interval,  or  as  a
Service.

Running Usually shown for Non Persistent (NP) Profiles.

Closed  by
Operator  or
System Shutdown

Displayed once all  Jobs in  a  Non Persistent  Profile
completed and the application was closed or when a
Service was manually stoped.

Closed Normally Displayed when all  Jobs in  a  Non Persistent  Profile
completed. 

Che cke d  This  indicator displays  the  total number of source  files/folders
that have been validated for all Profile Jobs.

Up d a te d Indicates  the  number of Target Files  that were  updated  during
synchronization of all Profile Jobs. 

Ad d e d  Indicates the  number of new files  added  to  the  Target Folders
during the synchronization of all Profile Jobs.

De le te d Indicates  the  number  of  files  deleted  (or  moved)  during
synchronization of all Profile Jobs.

Me ssa g e s Indicates  the  number  of  error  messages  generated  during
Profile processing.

T ime  Indicates the amount of time that has  elapsed  since  the  current
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Profile was launched.

T o ta l Byte s  Co p ie d Indicates  the  total number of bytes  successfully  transmitted  to
the  Target  Folder(s)  during  the  synchronization  of  all  Profile
Jobs. 

Use r Indicates  the  user name  under which  the  PeerSync  Service
or application is running.

Ve rs io n Represents  the  version  of  PeerSync  running  under  this
Profile.  PeerSync  versions older then 7.3.2 will be  displayed
as UNKNOWN.

Se nd  Fre q ue ncy Frequency  in  seconds  by  which  PeerSync  transmits  status
information  to  the  Peer  Administrator.   By  default  the  Send
Frequency is  set to  3 seconds in PeerSync .   To  modify  the
Send  Frequency  for  a  specific  PeerSync  Profile,  right-click
on  the  entry  from  the  PeerSync  Activity  Panel,  select  "Set
Transmit Frequency" from the PeerSync Activity  Pop-Up  menu
and  specify  the  desired  frequency.  Alternatively,  you  may
add  /GOF:  x   to  the  PeerSync  list  of  command  line
arguments, where x   represents the second frequency interval. 

Do ma in The  name  of  the  Domain  on  which  the  Profile  is  running.   If
PeerSync  and  the  Peer  Administrator  are  running  on  two
separate  domains  on  the  same  network  a  trust  must  exist
between the domains in order for the applications to  be  able  to
see and communicate with each other. 

Note: The Domain name will only be displayed for PeerSync  versions 7.3.2

or higher.

Cycle s By  default,  this  column  is  hidden  and  is  only  viewable  in  the
PeerSync  Activity  Panel.  To  enable,  right-click  on  the
PeerSync Activity Panel and choose "Selected Columns..."

The  Cycle  interval tells  the  Peer  Administrator  when  to  check
the  activity  and  status  of the  items  listed  in  the  PeerSync  and
PeerLock  Activity  Panels.   After  each  Cycle  the  Peer
Administrator  will  update  the  color  display  of  the  items
accordingly.  

The  Cycle  is  determined  internally  by  the  number  of  seconds
before  displaying  the  "Pending"  and  "Failed"  colors.  These
options  can be  set in  the  General  Settings  window. The  Peer
Administrator  determines  the  greatest  common  denominator
between  these  two  values  as  the  Cycle.  If  the   common
denominator  equals  the  "Pending"  value,  the  next  common
denominator of the "Pending" and "Failed" settings is used.

Note: The Cycle value is used by the Peer Administrator to  check  the status
of both PeerSync and PeerLock activities.

Sta tus  Le ve l Column  that  represents  the  status  level  of  each  PeerSync
entry (-1 to 5). 
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 0  = Finished,  1  =  Receiving,  2  =  Paused,  3  =  Pending,  4  =
Failed-Idle, 5 = Failed, -1 = Disabled/Unknown

Pro file  Da te  Mo d ifie d  Column  that  represents  the  date  and  time  when  the  current
Profile was updated.

Pe nd ing  Sca ns Column that represents the number of scans that have not been
able to run because of lack of Job Threads.

Pe nd ing  Eve nts  Column  that  represents  the  number  or  pending  events  that
have been queue but are still waiting to be processed.

Pe nd ing  Re trie s  Column that represents  the  number of files  waiting  in the  list  to
be retried.

Pe nd ing  Ma na g e d
File s  

Column that represents the number of files that are waiting to be
processed  using  the  Emb e d d e d  Op e n  File  Ma na g e r
(EOFM) or VSS  based on the Managed Files interval. 

Fa ile d  Sca ns Column  that  represents  the  number  of  scans  that  have
interrupted  or  were  not  able  to  run  because  of  lack  of  Job
Threads  or  connectivity  issues  and  the  Re try  fa ile d
co nne ctio n  e ve ry  x  minute s  option  is  disabled.  The  text
color will change to red for items in the PeerSync Activity  Panel
when  the  Failed  Scans  counter  is  greater  than  zero.  See  the
Reprocess Failed Scans option.

Fa ile d  File s  Column that represents  the  number  of  files  that  have  failed  to
be  replicated/synchronized  possibly  due  to  Retries  being
turned  off  or  exceeded.  The  text  color  will  change  to  red  for
items  in  the  PeerSync  Activity  Panel  when  the  Failed  Files
counter is  greater than  zero.  See  the  Reprocess  Failed  Files
option.

Jo b  Co unt Column  represents  the  total  number  of  Jobs  running  in  the
current Profile.

De te cte d  Eve nts  Column that  represents  the  number  of  events  that  have  been
detected  but have  not been analyzed  and  entered  in a  queue
yet. 

Notes: 

1. If the "Auto Sort Tables by Status Level"  option is selected from the View menu, non-responding Profiles will be
shown at the top of the Activity Table while inactive Profiles are pushed to the bottom.  All other activities will be
shown in the order they are received.  The color of each row represents the connection status and can be set in
the Settings window accessible from the Edit menu or by simply clicking on the Color Legend Panel at the bottom
of the Peer Administrator.

2. Turning off the "Auto Sort Tables by Status Level"  option from the View menu will allow you to sort the table by
any column  simply by clicking on the column header.

3. The columns displayed on this panel can be shown/ hidden by choosing "Select Columns..."  from the PeerSync
Activity Pop-Up Menu.

4. You can re-arrange the table columns by clicking and dragging the desired column to another location. The size
and positions of the columns will be retained in the PSOBSDEF.CFG configuration file.  



Peer Administrator Help14

Copyright © 1993-2013 Peer Software Inc. All Rights Reserved

5. By double clicking on a selected row you will open the Status Display of the running PeerSync  Profile.  See

Connect to Status Display bellow for more information.

6. To refresh all active PeerSync  entries hit F5 on the keyboard once the PeerSync Activity Panel is in focus. 

PeerSync Activity Pop-Up Menu

Activ ity  Po p -Up  Me nu Ite ms

By right clicking on the PeerSync Activity Table, you will display  the  PeerSync Activity
Pop-Up Menu.   

Co nne ct T o  Co mp ute r
Sta tus  D isp la y   

Opens  the  Status  Display  window  of  the  selected  running
PeerSync  Profile.   You  may  open  a  maximum  of  four  (4)
Status  Display  widows.   Each  one  will  retain  its  size  and
position, although subsequent launches  of  a  given  Profile  will
not  necessarily  utilize  the  same  window.   To  open  another
Profile, simply  close  one  of the  open Status  Displays  and  the
new window will open in its place.  Only a  single  instance  of the
Status  Display  window  can  be  opened  per  Profile.  
Furthermore, each window can be  specified  to  Stay  on Top  of
the  Peer  Administrator  application  from  the  Options  menu  in
each  individual  window.  This  menu  item  is  not  available  for
PeerSync Profiles that are running TCP Jobs. 

Se le ct Co lumns... Displays  a  dialog  from  which  you  can  choose  to  show/hide
specific  PeerSync Activity  Panel columns. You can hide/show
the  entire  PeerSync  Activity  Panel  by  disabling  /enabling  the
"Display PeerSync Activity" item within the  View menu. At least
one column must be shown in the PeerSync Activity Panel.
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Cle a r/Re fre sh Entrie s
In T a b le ... 

Se le c te d
Available only if an entry is selected from the PeerSync Activity
Table. This setting refreshes the selected row.  If all the  Jobs in
a  Non  Persistent  (NP)  Profile  are  completed  or  the  selected
Profile was terminated or 'Failed', the  table  entry  for that Profile
will be cleared.

Active
Refreshes all connections that are active (receiving or paused)
within  this  table  or  current  tab/group  (if  the  Use  Tab  Group
option is enabled). 

Pa ss ive
Refreshes all passive  connections. Completed, terminated, or
failed Profiles will  be cleared from the  Activity  Table  or current
tab/group (if the Use Tab Group option is enabled). 

All
Refreshes the PeerSync Activity  Table  to  display  new Profiles
running  and  clearing  completed,  failed,  or  terminated
sessions. 

Re -Se nd  Co nne ctio n
Re q ue st

Broadcasts  message  to  all  Profiles  running  within  the
designated  domain  to  begin  transmitting  status  information  to
the  Peer  Administrator.  This  menu  item  is  not  available  for
PeerSync Profiles that are running TCP Jobs. 

Ena b le  Activ ity
Re p o rting  Fo r: 
Co mp ute r

Selecting  this  option  tells  PeerSync  and  PeerLock
residing  on  the  computer  of  this  selection  to  begin  sending
status information to the  Peer Administrator. This  option is  only
available  on the  right-click  of an item on the  PeerSync Activity
Panel,  however,  it  also  affects/apply's  to  PeerLock  entries
residing  on  the  same  computer  as  the  PeerSync  item  that
received  the  "Enable"  command.  This  menu  item  is  not
available for PeerSync Profiles that are running TCP Jobs. 

Disa b le  Activ ity
Re p o rting  Fo r: 
Co mp ute r 

This option tells  PeerSync  and PeerLock  residing  on the
computer of this selection to  stop  sending  status  information to
the  Peer  Administrator.   This  option  is  only  available  on  the
right-click of an item on the PeerSync Activity  Panel, however it
also  affects/apply's  to  PeerLock  entries  residing  on  the
same  computer  as  the  PeerSync  item  that  received  the
"Disable"  command.  If  the  Always  Enable  Activity  Reporting
setting  is  enabled,  selecting  this  option  will  disable  it  so  that
the Enable Activity Reporting becomes available. 

When  activity  has  been  "Disabled"  for  PeerSync  and
PeerLock , the  PeerSync  and  PeerLock  entries  affected
would change their status  to  'Disabled'  followed  by  the  reason
why the Peer Administrator stopped  receiving  the  activity. Only
minimal information would be retained  in the  Activity  Panels  for
the 'Disabled' connections. This  menu item is  not available  for
PeerSync Profiles that are running TCP Jobs. 

Se rv ice  Op e ra tio ns  Sta rt Pe e rSync On
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This  option  is  available  only  when  using  the  PeerSync
Administrator  Enterprise  Package  and  for  items  for  which  the
service  has  been  installed  and  is  stoped.  Clicking  on  this
option  will  start  the  PeerSync  Service  for  the  selected  item
(assumes  the  service  has  been  installed  and  properly
configured on the target computer). 

Sto p  Pe e rSync On
This  option  is  available  only  when  using  the  PeerSync
Administrator  Enterprise  Package  and  if  the  selected  item  is
running  as  a  service.  By  selecting  this  option  the  Peer
Administrator will terminate the  PeerSync  Service  running  on
the selected device.  

Pa use  Pe e rSync On
This  option  is  available  only  when  using  the  PeerSync
Administrator  Enterprise  Package  and  if  the  selected  item  is
running  as  a  service.  By  selecting  this  option  the  Peer
Administrator  will  pause  the   PeerSync  Service  running  on
the selected device.  

Re sume  Pe e rSync On
This  option  is  available  only  when  using  the  PeerSync
Administrator  Enterprise  Package  and  for  items  for  which  the
service  is  paused.  By  selecting  this  option  the  Peer
Administrator  will  resume  the  paused  PeerSync  Service
running on the selected device.  

Se le ct Co mp ute r to  Sta rt Pe e rSync Se rv ice ... 
This  option  is  available  only  when  using  the  PeerSync
Administrator Enterprise  Package. When  selected,  a  Remote
Service  Start dialog  will be  displayed  where  you  may  select/
enter  the  name  of  the  computer  on  which  to  start  the
PeerSync  Service  (assumes the  service  has been installed
and properly configured on the target computer). 

Pro file  Op e ra tio ns... This  option  is  only  available  with  the  PeerSync  Administrator
Enterprise  Package. Selecting  this  option will open the  Profile
Operations  dialog  which  supports  functionalities  such  as
Stoping,  Starting,  Pausing  PeerSync  services  and  editing/
submitting Profile changes.

Re p ro ce ss Fa ile d
Eve nts  On: Co mp ute r 

This  option  is  only  available  with  the  PeerSync  Administrator
Enterprise  Package. Sends a  command  to  PeerSync  to  re-
process  any  events/files  that  failed  to  be  processed  without
restarting PeerSync .

Pro ce ss Fa ile d  Sca ns
On: Co mp ute r 

This  option  is  only  available  with  the  PeerSync  Administrator
Enterprise  Package. Sends a  command  to  PeerSync  to  re-
process any scans that failed to run/complete without restarting
PeerSync .

Se t T ra nsmit
Fre q ue ncy On: 
Co mp ute r

Enabled  only  if  an  item  is  selected  on  the  PeerSync  Activity
Panel. Frequency represents, in seconds, the  interval by  which
PeerSync  transmits  status  information  to  the  Peer
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Administrator. Selecting this option will open a  dialog  by  which
you  may  specify  a  desired  frequency  for  a  specific
PeerSync  Profile.  By  default,  PeerSync  sends  status
information  to  the  Peer  Administrator  every  3  seconds.  This
menu  item  is  not  available  for  PeerSync  Profiles  that  are
running TCP Jobs. 

Note:  For accurate status display set the Set Transmit Frequency interval  to
be  smaller  then  the  "Number  of  Cycles  Before  Displaying  Pending  Color"
interval used. 

* Notes: 

1. Option available for PeerSync versions 7.3.2 or higher.

2. Some menu items are not available for PeerSync Profiles that are running TCP Jobs. 

PeerLock Activity Panel

PeerLock Status

Pe e rLo ck Sta tus  Co lumns

This  panel contains  all  information  captured  about  the  PeerLock  instances  running  on
the network. 

Pe e rLo ck Co mp ute r Lists the name of the computer on which a  specific  PeerLock is
running.  When (SVC) is  displayed  at the  end  of  the  computer
name, it signifies that PeerLock is running as a Service.  

Gro up When  PeerLock  is  associated  with  a  PeerSync  Profile,  the
Group name will be  the  Group  name  of the  Profile. If PeerLock
is not associated with a PeerSync Profile, the  Group  will be  set
to None.

Curre nt Sta tus Displays  the  status  for  the  specific  PeerLock  instance.  Non
Normal statuses usually  indicate  a  possible  connection issue.
The font for such entries will turn red. Possible statuses:

Normal Running without connection issues 

Normal  (Stopped
@ DATE TIME)

%PRODUCT2%> shows a stopped status. 

Connecting  to Establishing connection to the source folder
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Source Folder:  .  .
.

Connecting  to
Target Folder:  . .

Establishing connection to the target folder

There  is  1  Failed
Connection: Path

Unable to connect to the specified path

There are 3 Failed
Connections.

Unable to connect to more than one path

Retrying
Connection - Ping

Retrying a connection failure

Activ ity The activity level of the specific PeerLock instance. 

Running Default running mode

Checking Locks Scanning the Windows Open Files list to determine if
any files need to be locked.  By default  this is done
every 1 second.

Checking
Releases

Scanning the Windows Open Files list to determine if
any files need to be released. By default this is done
every 3 seconds.

Caching Lists Writing locked files to the cache list for easy cleanup
during  restarts  and  is  also  used  by  the  PeerLock
Read-Only Display,  and  the  PeerSync  Profile.  The
cache list gets written after checking the releases.

Checking  Failed
Connections

Independent  thread  which  checks  the  connection
status of all systems.

Checking  Failed
Locks

On a lock cycle PeerLock checks an internal  list  of
failed locks and retries them.

Lo cks Shows  the  cumulative  number  of  locks  generated  by  the
specific  PeerLock  instance  followed  by  the  number  of  active
locks.

Re le a se s The  total  number  of  locks  that  were  released  by  the  specific
PeerLock instance.

Lo ck Ave ra g e The  average  number  of  locks  generated  per  minute  by  the
specific PeerLock instance. 

Re le a se  Ave ra g e The  average  number  of  locks  that  were  released  per  minute
by the specific PeerLock instance. 

Fa ile d  Lo cks Total  number  of  locks  that  failed  to  be  set  by  the  specific
PeerLock instance.

T ime The  duration  of  time  that  the  specific  PeerLock  instance  has
been running. 

Use r Indicates  the  user  name  under  which  the  specific  PeerLock
instance has been running. 

Ve rs io n The version number of the specific  PeerLock instance  that has
been running.

Se nd  Fre q Represents,  in  seconds,  the  interval  by  which  PeerLock
transmits status information to the Peer Administrator. 
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Do ma in The  name  of  the  Domain  on  which  the  specific  PeerLock
instance  has  been  running.   If  PeerLock  and  the  Peer
Administrator  are  running  on  two  separate  domains  on  the
same  network  a  trust must exist between the  domains  in order
for  the  applications  to  be  able  to  see  and  communicate  with
each other.

Sta tus  Le ve l Column  that  represents  the  status  level  of  each  PeerLock
entry. 
0  = Released,  1  =  Receiving/Locked,  3  =  Pending,  5  =  Not
Responding  (Status  Levels  -1,  2,  and  4  apply  to  PeerSync
entries only)

PeerLock  status entries  will change  if the  Peer Administrator
has not received  new updates  from PeerLock  for the  period
set by the Activity Monitoring Options.

Jo b  Co unt The  total  number  of  Jobs  that  are  configured  for  this  specific
PeerLock instance.

Me ssa g e s The  total  number  of  messages  that  occurred  for  this  specific
PeerLock instance. 

Cycle s By  default,  this  column  is  hidden  and  is  only  viewable  in  the
PeerLock Status panel. To  enable, right-click  on the  PeerLock
Status panel and choose "Selected Columns..."

The  Cycle  interval tells  the  Peer  Administrator  when  to  check
the  activity  and  status  of  the  items  listed  in  the  PeerLock  and
PeerSync panels.  After each Cycle  the  Peer Administrator will
update the color display of the items accordingly.  

The  Cycle  is  determined  internally  by  the  number  of  seconds
before  displaying  the  "Pending"  and  "Failed"  colors.  These
options  can be  set in  the  General  Settings  window. The  Peer
Administrator  determines  the  greatest  common  denominator
between  these  two  values  as  the  Cycle.  If  the   common
denominator  equals  the  "Pending"  value,  the  next  common
denominator of the "Pending" and "Failed" settings is used.

Note: The Cycle value is used by the Peer Administrator to  check  the status
of both PeerSync and PeerLock activities.

Lo g  File  Pa th By  default,  this  column  is  hidden  and  is  only  viewable  in  the
PeerLock Status panel. To  enable, right-click  on the  PeerLock
Status panel and choose "Selected Columns..."

The  Log  File  Path column shows the  location of the  log  file  for
this specific PeerLock instance.

Syste m Up time By  default,  this  column  is  hidden  and  is  only  viewable  in  the
PeerLock Status panel. To  enable, right-click  on the  PeerLock
Status panel and choose "Selected Columns..."

The  System Uptime  column shows the  total uptime  time  of the
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system on which PeerLock has been running. 

Locked List

Lo cke d  File s  Co lumns

This  panel  contains  all  information  captured  about  the  source  and  target  files  that  have
been locked by PeerLock  instances running on the network. 

Pe e rLo ck Co mp ute r The name of the computer on which PeerLock  is  running  and
locking corresponding target files. When (SVC) is  displayed  at
the  end  of  the  computer  name,  it  signifies  that  PeerLock  is
running as a Service.  

Curre nt Sta tus Displays  'Locked'  as  the  status  for  all  entries  in  the  Locked
Files panel. 

T a rg e t File  Pa th Shows the  file  name  complete  with folder  path  for  a  target  file
that is locked, if the file exists and can be locked.

Lo cke d Display the date/time when the target file was locked.

Dura tio n Displays  the  amount  of  time  that  the  source  file  has  been
opened.

Acce sse d  By The name of the user who has opened the file  or accessed  the
resource.

T a rg e t Acce ss
Allo we d

Displays  the  permissions  that  are  allowed  on  the  opened
target file which are applied by PeerLock .

So urce  File  Pa th Displays the file name complete  with folder path for the  source
file that has been detected as an open file.

Ve rs io n Represents the version of PeerLock .

Se nd  Fre q Frequency  represents,  in  seconds,  the  interval  by  which
PeerLock  transmits  status  information  to  the  Peer
Administrator. Selecting this option will open a  dialog  by  which
you  may  specify  a  desired  frequency  for  a  specific
PeerLock . 

Sta tus  Le ve l Column  that  represents  the  status  level  of  each  PeerLock
entry. 
0  = Released,  1  =  Receiving/Locked,  3  =  Pending,  5  =  Not
Responding  (Status  Levels  -1,  2,  and  4  apply  to  PeerSync
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entries only)

PeerLock  status entries  will change  if the  Peer Administrator
has not received  new updates  from PeerLock  for the  period
set by the Activity Monitoring Options.

La st Up d a te d Date  and  time  the  Locked  Files  list  was  last  updated  by
PeerLock. The  Locked  Files  list  only  gets  updated  when  you
click the Locked Files list tab from another tab  (changing  tabs),
or by clicking on the Refresh  Released Files link above the list
at the right. Hitting F5 or F6 will also force an update of this list.

Jo b  Numb e r Lists the Job number that the specific lock is associated with. 

#Lo cks Not  shown  by  default.  Displays  the  number  of  locks  on  the
source.

Ap p lica tio n Not shown by  default.  Displays  the  application  that  has  been
detected  as opening the source file.  

De te ctio n T yp e Not shown by  default. This  column represents  the  PeerLock
detection  mode  used  to  detect  what  source  files  are  locked/
opened.  This  will  either  be  File  Server  Mode  Detection  or
Local Detection. 

Id le  T ime Not shown by  default. Shows the  amount of time  the  target  file
will  remain  locked  once  the  source  file  has  been  released.
When the source file is closed, PeerLock  will wait the number
of Idle Time seconds specified  before  releasing  the  target file.
During  the  Idle  Time  period  the  file  entry  in the  Locked  list  will
be  highlighted  Yellow. The  Idle  Time  value  can  be  set  in  the
Release Options dialog. This feature  is  intended  to  protect the
releasing  of  files  during  file  opens  and  saves.  Certain
applications  may  temporary  release  files  during  these
procedures.  With this feature enabled, PeerLock  will wait the
set period of time  to  make  sure  the  file  is  fully  released  before
unlocking the corresponding target files.  

Lo ck File  Ha nd le Not shown by default. Displays the handle value created that is
being  used  to  lock  the  temporary  Lock  File  created  by
PeerLock   to Interact with other <%COMPANY% Products.  If
the Interact features are disabled, then this will display 'None'.

Re le a se  De te cte d Not  shown  by  default.  Shows  the  date  and  time  when
PeerLock  detected  the  source  file  was  closed.  This  value
will be cleared  if the  file  is  reopened  within the  Idle  period  and
the target file handle is not  released.  

So urce  Acce ss
Allo we d

Not  shown  by  default.  Displays  the  permissions  that  are
allowed on the opened source file. 

So urce  Attrib ute s Not shown by default. Shows the attributes of the source file. 

So urce  Ha nd le Not shown by default. Displays the  handle  value  created  when
the source file was opened. 

So urce  Mo d ifie d Not  shown  by  default.  Shows  the  modified  date/time  of  the
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source file when it was detected as being open.

So urce  Op e n Mo d e Not shown by default. Displays the permissions that were  used
to open the source file.

T a rg e t Ha nd le Not shown by  default. Display  the  handle  value  created  that is
being used to lock the target file by PeerLock . 

T a rg e t Op e n Mo d e Not  shown  by  default.  Displays  the  permissions  that  were
granted when the target file was locked by PeerLock .

T e mp o ra ry  Re le a se s Not shown by  default.  Shows  the  number  of  times  the  source
file  was  closed,  but  the  corresponding  target  file  was  not
released.  This  would  most  likely  occur  when  using  the  Idle
period setting in PeerLock . 

Notes: 

1. The PeerLock  Activity Panel can be shown/ hidden from the View -> Show PeerLock  Activity Panel menu

item. Either the PeerSync  or PeerLock  Activity Panels must be shown. Both Panels may not be disabled at

the same time.  

2. The columns displayed on this panel can be shown/ hidden by choosing "Select Columns..."  from the Locked List
Popup Menu.  

3. You may resize, sort, and reposition the columns simply  by  dragging  them to  a  desired  position.  The  size  and
positions of the columns will be retained in the PSOBSDEF.CFG configuration file.  

4. The default columns are Computer, Status,  Target  File  Path,  Locked,  Duration,  Accessed  By,  Target  Access
Allowed, Source File Path, Version, and Send Frequency.

5. To refresh all active PeerLock  entries hit F5 on the keyboard once the PeerLock Activity Panel is in focus. 

6. Unless you manually enables or disables the PeerLock Activity Panel from the View menu, the Peer Administrator

will try to determine if  PeerLock  has been installed on the local machine  or  if  is  running  on  the  network,  to

analyze whether it needs to automatically show the PeerLock Activity Panel. 

Released List

Re le a se d  Lis t Co lumns

This  panel displays  a  list of the  top  100 recently  released  files  by  PeerLock  instances
running on the  network  and  all information pertaining  to  the  locking  and  releasing  of those
files  including  why  the  file  was  released  (i.e.  Manually,  Locking  Stopped,  PeerLock
Stopped or the Source File was released). 



Peer Administrator Help 23

Copyright © 1993-2013 Peer Software Inc. All Rights Reserved

Pe e rLo ck  Co mp ute r The name of the computer on which PeerLock  is  running  and
locking corresponding target files. 

Curre nt Sta tus Displays  'Released'  as  the  status  for  all  entries  in  the
Released Files panel. 

T a rg e t File  Pa th Shows the  file  name  complete  with folder  path  for  a  target  file
that is locked, if the file exists and can be locked.

Re le a se d Displays the date and time when the locked file was released. 

Dura tio n Displays  the  amount  of  time  that  the  source  file  has  been
opened.

Acce sse d  By The name of the user who has opened the file  or accessed  the
resource.

T a rg e t Acce ss
Allo we d

Displays  the  permissions  that  are  allowed  on  the  opened
target file which are applied by PeerLock .

So urce  File  Pa th Displays the file name complete  with folder path for the  source
file that has been detected as an open file.

Ve rs io n Represents the version of PeerLock .

Se nd  Fre q Frequency  represents,  in  seconds,  the  interval  by  which
PeerLock  transmits  status  information  to  the  Peer
Administrator. Selecting this option will open a  dialog  by  which
you  may  specify  a  desired  frequency  for  a  specific
PeerLock . 

Sta tus  Le ve l Column  that  represents  the  status  level  of  each  PeerLock
entry. 
0 = Released, 1 = Receiving, 3 = Pending, 5 = Not Responding
(Status Levels -1, 2, and 4 apply to PeerSync  entries only).

PeerLock  status entries  will change  if the  Peer Administrator
has not received  new updates  from PeerLock  for the  period
set by the Activity Monitoring Options.

La st Up d a te d Date  and  time  the  Locked  Files  list  was  last  updated  by
PeerLock. The  Locked  Files  list  only  gets  updated  when  you
click the Locked Files list tab from another tab  (changing  tabs),
or by clicking on the Refresh  Released Files link above the list
at the right. Hitting F5 or F6 will also force an update of this list.

Jo b  Numb e r Lists  the  Job  number  that  the  specific  lock  release  was
associated with. 

#Lo cks Not  shown  by  default.  Displays  the  number  of  locks  on  the
source.

Ap p lica tio n Not shown by  default.  Displays  the  application  that  has  been
detected  as opening the source file.  

De te ctio n T yp e Not shown by  default. This  column represents  the  PeerLock
detection  mode  used  to  detect  what  source  files  are  locked/
opened.  This  will  either  be  File  Server  Mode  Detection  or
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Local Detection. 

Id le  T ime Not shown by  default. Shows the  amount of time  the  target  file
will  remain  locked  once  the  source  file  has  been  released.
When the source file is closed, PeerLock  will wait the number
of Idle Time seconds specified  before  releasing  the  target file.
During  the  Idle  Time  period  the  file  entry  in the  Locked  list  will
be  highlighted  Yellow. The  Idle  Time  value  can  be  set  in  the
Release Options dialog. This feature  is  intended  to  protect the
releasing  of  files  during  file  opens  and  saves.  Certain
applications  may  temporary  release  files  during  these
procedures.  With this feature enabled, PeerLock  will wait the
set period of time  to  make  sure  the  file  is  fully  released  before
unlocking the corresponding target files.  

Lo ck File  Ha nd le Not shown by default. Displays the handle value created that is
being  used  to  lock  the  temporary  Lock  File  created  by
PeerLock   to  Interact with other <%COMPANY%  Products.
 If the Interact features are disabled then this will display 'None'.

Re le a se  De te cte d Not  shown  by  default.  Shows  the  date  and  time  when
PeerLock  detected  the  source  file  was  closed.  This  value
will be cleared  if the  file  is  reopened  within the  Idle  period  and
the target file handle is not  released.  

So urce  Acce ss
Allo we d

Not  shown  by  default.  Displays  the  permissions  that  are
allowed on the opened source file. 

So urce  Attrib ute s Not shown by default. Shows the attributes of the source file. 

So urce  Ha nd le Not shown by default. Displays the  handle  value  created  when
the source file was opened. 

So urce  Mo d ifie d Not  shown  by  default.  Shows  the  modified  date/time  of  the
source file when it was detected as being open.

So urce  Op e n Mo d e Not shown by default. Displays the permissions that were  used
to open the source file.

T a rg e t Ha nd le Not shown by  default. Display  the  handle  value  created  that is
being used to lock the target file by PeerLock . 

T a rg e t Op e n Mo d e Not  shown  by  default.  Displays  the  permissions  that  were
granted when the target file was locked by PeerLock .

T e mp o ra ry  Re le a se s Not shown by  default.  Shows  the  number  of  times  the  source
file  was  closed,  but  the  corresponding  target  file  was  not
released.  This  would  most  likely  occur  when  using  the  Idle
period setting in PeerLock . 

Notes: 

1. The PeerLock Activity Panel can be shown/ hidden from the View -> "Show PeerLock Activity Panel"  menu item.

Either the PeerSync  or PeerLock Activity Panels must be shown. Both Panels may not be disabled at the same

time.  
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2. The columns displayed on this panel can be shown/ hidden by choosing "Select Columns..."  from the Released
List Popup Menu.  

3. You may resize, sort, and reposition the columns simply  by  dragging  them to  a  desired  position.  The  size  and
positions of the columns will be retained in the PSOBSDEF.CFG configuration file.  

4. The default columns are Computer, Status,  Target  File  Path,  Locked,  Duration,  Accessed  By,  Target  Access
Allowed, Source File Path, Version, and Send Frequency.

5. Unless you manually enable or disable the PeerLock  Activity Panel from the View menu, the Peer Administrator

will try to determine if  PeerLock  has been installed on the local machine  or  if  is  running  on  the  network,  to

analyze whether it needs to automatically show the PeerLock Activity Panel. 

Status Popup Menu

Lo ck/Re le a se d  Lis t Po p up  Me nu

Display  the  Lock/Release  List Popup  Menu by  right-clicking  on  the  Locked  or  Released
panels.

Ge t/D isp la y  Lo cke d
File s  Fo r: Co mp ute r

Changes focus to the PeerLocks Locked files list. 

Se le ct Co lumns... Displays  a  dialog  from  which  you  may  choose  to  show/hide
specific  Locked  or  Released  columns.  At  a  minimum,  one
column must be shown at all times. 

Cle a r Re fre sh Ite m(s)
in T a b le ... 

Se le c te d  F5
Available  only  if  an  entry  is  selected  from  the  Locked  or
Released  panels.  This  setting  refreshes  the  selected  row.   If
the selected lock  becomes released, the  entry  will be  cleared
from the Locked list and added to the Released list. 

Cle a r/Re fre sh All  F6
Refreshes  the  Locked  or  Released  tables  to  display  new
locks and clearing/adding released locks. 

Re -Se nd  Co nne ctio n
Re q ue st

Broadcasts  a  message  to  all  PeerLocks  running  within  the
designated  domain  to  begin  transmitting  status  information  to
the Peer Administrator.
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Se t T ra nsmit
Fre q ue ncy On:
Co mp ute r 

Enabled  only  if an item is  selected  from  the  table.  Frequency
represents,  in  seconds,  the  interval  by  which  PeerLock
transmits status information to the Peer Administrator. Selecting
this  option  will  open  a  dialog  by  which  you  may  specify  a
desired  frequency  for  the  specific  PeerLock  running  on  the
selected computer entry.  By  default, PeerLock  sends status
information to the Peer Administrator every 3 seconds.

Note: For accurate status display, set the Set Transmit Frequency interval to
be  smaller  then  the  "Number  of  Cycles  Before  Displaying  Pending  Color"
interval used. 

Vie w Lo g  File : Lo g Opens the log file of the remote PeerLocks instance.

Sa ve  As Saves the content of the current panel into a CSV file format. 

Locked/Released List Popup Menu

Lo ck/Re le a se d  Lis t Po p up  Me nu

Display  the  Lock/Release  List Popup  Menu by  right-clicking  on  the  Locked  or  Released
panels.

Se le ct Co lumns... Displays  a  dialog  from  which  you  may  choose  to  show/hide
specific  Locked  or  Released  columns.  At  a  minimum,  one
column must be shown at all times. 

Cle a r Re fre sh Ite m(s)
in T a b le ... 

Se le c te d  F5
Available  only  if  an  entry  is  selected  from  the  Locked  or
Released  panels.  This  setting  refreshes  the  selected  row.   If
the selected lock  becomes released, the  entry  will be  cleared
from the Locked list and added to the Released list. 

Cle a r/Re fre sh All  F6
Refreshes  the  Locked  or  Released  tables  to  display  new
locks and clearing/adding released locks. 
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Re -Se nd  Co nne ctio n
Re q ue st

Broadcasts  a  message  to  all  PeerLocks  running  within  the
designated  domain  to  begin  transmitting  status  information  to
the Peer Administrator.

Re le a se : File Visible  only  on the  Released  panel. When selected, the  Peer
Administrator will send  a  command  to  PeerLock  to  release
the  lock  handle  of  the  selected  target  file.  When  using  this
option the  target file  will not enter the  Idle  period  before  being
released.  The  the  target  file  may  be  temporarily  released.
During  the  next Lock  Cycle/Frequency/Interval  PeerLock  may
detect that the  source  file  is  opened, and  will re-lock  the  target
file. Once an item is  released  it will  be  added  to  the  Released
Files table. 

Re le a se  All Lo cks  * Visible only on the  Released  panel. PeerLock will release  the
lock  handles  of  all  the  files  currently  locked  on  the  target
folders. When using  this  option the  target files  will not enter the
Idle period before being  released. The  the  target files  may be
temporarily  released.  During  the  next  Lock  Cycle/Frequency/
Interval PeerLock may detect that the  source  files  are  opened,
and  will re-lock  the  target files. Once  an item is  released  it  will
be added to the Released Files table. 

Se t T ra nsmit
Fre q ue ncy On: 
Co mp ute r 

Enabled  only  if an item is  selected  from  the  table.  Frequency
represents,  in  seconds,  the  interval  by  which  PeerLock
transmits status information to the Peer Administrator. Selecting
this  option  will  open  a  dialog  by  which  you  may  specify  a
desired  frequency  for  the  specific  PeerLock  running  on  the
selected computer entry.  By  default, PeerLock  sends status
information to the Peer Administrator every 3 seconds.

Note: For accurate status display, set the Set Transmit Frequency interval to
be  smaller  then  the  "Number  of  Cycles  Before  Displaying  Pending  Color"
interval used. 

Vie w Lo g  File : File Opens the log file of the remote PeerLocks instance.

Sa ve  As Saves the content of the current panel into a CSV file format. 

Admin Events Panel

Admin Events Panel

Ad min Eve nts  T a b le
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When  enabled  via  the  View  menu  it  will  be  displayed  at  the  bottom  of  the  Peer
Administrator  interface.  By  default  this  table  will  show  all  errors  that  result  due  to
administrative  actions  such  as  failing  to  copy  a  remote  Profile  locally  for  purposes  of
editing.  Right-click  on  this  table  and  uncheck  the   Show  Failed  Events  Only  option  to
display  all  messaging  transactions  (successful  or  failed)  between  PeerSync ,
PeerLock , and the Peer Administrator.

Da te /T ime The following column shows the date and time of the  command
that was sent or received  by  the  Peer Administrator.  You  may
drag  and  drop  this  column  to  change  its  location  as  well  as
hide it via the Admin Events Pop-Up Menu.

Co mp ute r/Do ma in The  following  column shows the  computer and  domain  for  the
command that was sent or received  by  the  Peer Administrator.
You may drag  and  drop  this  column to  change  its  location  as
well as hide it via the Admin Events Pop-Up Menu.

Pro d uct The  following  column  shows  the  Product  name  (PeerSync  or
PeerLock) for the  command  that  was  sent  or  received  by  the
Peer  Administrator.  You  may  drag  and  drop  this  column  to
change its location as well as hide it via the Admin Events Pop-
Up Menu.

Use rNa me The  following  column shows the  UserName  for  the  command
that was sent or received  by  the  Peer Administrator.  You  may
drag  and  drop  this  column  to  change  its  location  as  well  as
hide it via the Admin Events Pop-Up Menu.

Se nd /Re ce ive The  following  column  shows  the  direction  (Send  or  Receive)
for  the  command  that  was  sent  or  received  by  the  Peer
Administrator. You may drag  and  drop  this  column  to  change
its  location  as  well  as  hide  it  via  the  Admin  Events  Pop-Up
Menu.

De scrip tio n The  following  column shows the  Description for  the  command
that was sent or received  by  the  Peer Administrator.  You  may
drag  and  drop  this  column  to  change  its  location  as  well  as
hide it via the Admin Events Pop-Up Menu.

Examples: 
Get Remote Profile: \\Server\Path\To\Profile.snc
Restart Profile: \\Server\Path\To\Profile.snc
Initializing Communication
Reprocess Failed Events
Release File: \\Path\To\File.xyz

Re sult The  following  column  shows  the  Result  for  the  command  that
was  sent  or  received  by  the  Peer  Administrator.  Failed
command  will  appear  in  red.  You  may  drag  and  drop  this
column to  change  its  location as  well as  hide  it  via  the  Admin
Events Pop-Up Menu.

Examples:
Completed Successfully
Sent Successfully
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Failed (Could not copy file ...)

Admin Events Pop-Up Menu

Ad min Eve nts  Po p -Up  Me nu

When enabled via the View menu the  Admin Events  Panel will  be  displayed  at the  bottom
of the Peer Administrator interface. Right-click on the  panel to  view the  Admin Events  Pop-
Up Menu.

Se le ct Co lumns... Displays  a  dialog  from  which  you  can  choose  to  show/hide
specific  Admin Events  Panel columns. You can hide/show the
entire  Admin  Events  Panel  by  disabling/enabling  the  Sho w
Ad min Eve nts  item within the View menu. At least one  column
must be shown in the Admin Events Panel.

Sho w Fa ile d  Eve nts
Only

This  option  is  enabled  by  default.  Uncheck  this  option  to
display  all  messaging  transactions  between  PeerSync ,
PeerLock , and the Peer Administrator.

Cle a r Lis t Removes/Deletes all entries from the Admin Events Panel.

Sa ve  As Saves the content of the current panel into a CSV file format. 
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Settings Window

General Tab

Activ ity  Mo nito r Op tio ns

Numb e r o f Se co nd s
Be fo re  D isp la y ing
Pe nd ing  Co lo r

Allows  you  to  determine  when  to  display  the  'Pending'  color
(default  Yellow)  on  a  PeerSync  or  PeerLock  activity.   A
Passive connection such as 'Pending' occurs  if PeerSync  or
PeerLock  fail  to  send  status  information  to  the  Peer
Administrator  within  the  specified  interval  (see  'Send  Freq'
column  and  the  /GO  command  line  argument  in  the
PeerSync  Help  Manual).   Such  connections  usually  occur
during  normal  sync  processes  and  are  not  critical  (i.e.  the
processing of large files).  This setting allows you to specify the
number of seconds before displaying the 'Pending' color.  This
ensures  that  a  persistent  failure  has  occurred  before
displaying  the  'Failed'  color.  The  minimum  value  allowed
before  displaying  the  'Pending'  color may be  set  as  low as  1
second and as high as 86400 seconds (24 hrs).  Default setting
is 30 seconds.

Notes: 

1. This setting applies to both PeerSync and PeerLock activities. 
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Numb e r o f Cyc le s
Be fo re  D isp la y ing
Fa ile d  Co lo r 

Allows  you  to  determine  when  to  display  the  'Failed'  color
(default  Red)  on  a  PeerSync  or  PeerLock  activity.   A
Passive  connection such as  'Failed'  occurs  if  PeerSync  or
PeerLock  fail  to  send  status  information  to  the  Peer
Administrator  within  the  desired  interval  (see  'Send  Freq'
column  and  the  /GO  command  line  argument  in  the  
PeerSync  Help  Manual).   Such  connections  usually  occur
during  normal  sync  processes  and  are  not  critical  (i.e.  the
processing of large files).  This setting allows you to specify the
number  of  cycles  before  displaying  the  'Failed'  color.   This
ensures  that  a  persistent  failure  has  occurred  before
displaying  the  'Failed'  color.  The  minimum  value  allowed
before  displaying  the  'Failed'  color  may  be  set  as  low  as  1
second and as high as 86400 seconds (24 hrs).  Default setting
is 60 seconds.

Notes: 

1. This setting applies to both PeerSync and PeerLock activities. 

2. This setting needs to be equal to or greater then the "Number of Seconds
Before Displaying Pending Color"  setting above. If  this interval is smaller, it
will be automatically set to equal the "Pending" color interval. 

Se t De fa ults A courtesy  option which  resets  the  Activity  Monitor  Options  to
the default settings. 

Misce lla ne o us Op tio ns

Ma ke  Ne w Links

Pe rs is te nt *
Enabling  this  option  forces  each  Profile  to  send  status
information to the Peer Administrator.  If PeerSync  should  fail
on the  remote  computer,  when  it  starts  up  it  will  automatically
start sending status information again.

T e rmina te  Re mo te

Link  On Clo se  *
This  setting  tells  each  PeerSync  to  stop  sending  status
information to  the  Peer  Administrator  if  the  Peer  Administrator
closes or terminates.  This  setting  is  recommended  to  prevent
unnecessary network traffic and does not affect communication
to other Peer Administrator running on the network.

Alwa ys Ena b le

Activ ity  Re p o rting  *
Checking  this  option  sends  a  message  to  all  available
PeerSync  hosted  computers  to  enable  them  to  send  status
information.   Selecting  Disable  Activity  Reporting  from  the
PeerSync Activity Pop-Up Menu will disable this setting. 

Se nd  Re p e titive
Bro a d ca sts  e ve ry  x
se co nd s

Specifies  the  interval  used  by  the  Peer  Administrator  will
broadcast  =  messages  to  all  available  PeerSyncs  and
PeerSyncs  within  the  designated  domain  to  begin
transmitting  status  information  to  the  Peer  Administrator.  The
default value used is 10 seconds.

Up d a te  Fa ile d /
Finishe d  Links

When  enabled  this  setting  will  update  Failed  or  Finished
entries in the PeerSync Activity panel. This option will eliminate
duplicate entries by always updating existing entries. 
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Notes: 

1. * This option is available for PeerSync  versions 7.3.2 or higher.

2. The General window can be accessed from the Edit -> "Settings" menu.

Reporting Tab

Re p o rting (These settings apply to items in the PeerSync Activity Panel only.)

Auto  Sa ve  Activ ity
Re p o rt  o n  Ap p lica tio n
Clo se

At  the  time  you  exit/close  the  application,  the  Peer
Administrator  will  store  out  the  latest  Network  Activity
information into the current report file.  If no report file  exists, you
will then be  prompted  to  create  one.   By  default  this  option  is
enabled.

Pa th Gives you the ability to save the report file in an alternate  path. 
By  default, the  report files  are  stored  in the  same  directory  as
the Peer Administrator application. 

Lo g g ing (These settings apply for items in both PeerSync and PeerLock Activity Panels)

Ena b le  Activ ity
Lo g g ing

By default this option is  enabled.  When this  setting  is  enabled
the  Peer Administrator will store  PeerSync  and  PeerLock
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activities in the Peer Administrator.LOG file.

Pa th Gives you the ability to save the log file in an alternate path.  By
default,  the  log  files  are  stored  in  the  same  directory  as  the
Peer Administrator application. 

Co mmo n File  Op tio ns

Ma x File  Size Specify, in bytes, the  maximum  size  of  both  the  reporting  and
log files.   When this  size  is  exceeded, the  file  will be  renamed
to a backup file and a new base file created. 

Ma x Ba ckup s Specify  the  total  number  of  report  and/or  log  files  to  be
retained. 

Note: The Reporting window can be accessed from the Edit -> "Settings" menu.

Email Alerts

E-Ma il Ale rts

Re ce ive  e ma il a le rts Check  this  option  to  begin  receiving  email  notifications  when
the  status  of  a  PeerSync  instance  changes.  Check  the  Alert
Types for  which  you  wish  to  be  notified  via  e-mail.  When  the
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status of a PeerSync instance  changes to  the  selected  type(s)
an e-mail notification will be sent.

Ale rt T yp e s Select the PeerSync statuses you wish you be notified of via  e-
mail.  When the  status  of a  PeerSync instance  changes to  the
selected  type(s)  an  e-mail  notification  will  be  sent.  View  the
Legend section for more  information about potential PeerSync
statuses (Failed, Finished,  Failed-Idle,  Pending,  Paused,  and
Receiving). 

Ema il Se tting s SMT P Ho st
The host name or IP address of the  SMTP mail server to  send
alert emails to.

Use r ID
The username to authenticate  with the  SMTP mail server. This
is normally not needed. (Optional)

Po rt
TCP/IP connection port. It is  recommended  that you leave  the
default setting unless your email server requires otherwise.

T o
The  email address  of the  person who  is  to  receive  the  email.
This  user sometimes  needs  to  be  a  valid  user  on  the  SMTP
mail  server.  You  may  add  multiple  email  addresses  in  this
field. Use a semicolon (;) as a delimiter. 

CC
The  email address  of the  person  who  is  to  receive  a  Carbon
Copy of the  email. You may  add  multiple  email  addresses  in
this field. Use a semicolon (;) as a delimiter. 

Fro m
The  email  address  that  will  appear  in  the  From  field  of  the
email.  This  e-mail  does  not  need  to  be  a  valid  e-mail.  For
example  it  can  be  used  to  identify  the  message  as   a
notification  coming  from  the  Peer  Administrator  by  using  an
address such as PeerAdministrator@company.com. 

Se nd  T e st Ema il...
Clicking  this  button  will  send  a  test  email  to  the  configured
address(es)  and  let  you  know  if  the  Peer  Administrator  was
able  to  successfully  connect  and  send  an  email  via  the
configured  SMTP  mail  server.  It  is  highly  recommended  that
you test the configuration before saving the options.

Notes: 

1. These settings apply to items in the PeerSync Activity Panel only.

2. The Email Alerts window can be accessed from the Edit -> "Settings" menu.

mailto:PeerAdministrator@company.com
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Color Key Tab

Co lo r Ke y Se le c tio n

This  section  allows  you  to  set  the  status  color  for  entries  in  both  PeerSync  and
PeerLock  Activity Panels.  Currently the 'Failed-Idle' and 'Paused' colors  do  not apply  to
PeerLock  entries.   

Se t De fa ults A  courtesy  option  which  resets  the  Color  Key  to  the  default
settings. 

Notes: 

1. The Color Key window can be accessed from the Edit -> "Settings"  menu or by  clicking  on  the  Color  Legend
Panel.   

2. The same color can be selected for multiple connections.  
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Domain List Tab

Do ma in Lis t

Sca n fo r Ava ila b le
Do ma ins

Searches  and  lists  all  available/trusted  domains  visible  from
this computer.  This option appends new findings to the existing
list and will not remove any domains  that are  no  longer visible.
By  default,  the  Peer  Administrator  it  will  now  only  scan  and
enable  the  current  domain  for  running  PeerSync  and
PeerLock  instances. Other  domains  found  will  be  listed  but
not enabled by default.  

Cle a r Lis t Removes all listed domains.

Ad d  Ne w Ite m (Po p -
Up  Me nu)

If  the  Peer  Administrator  is  having  problems  receiving  status
information from PeerSyncs  and PeerLocks  running  on the
domain or across  the  VPN, select this  option to  add  the  name
of the machine where PeerSync  and PeerLock  reside. 

De le te  Ne w Ite m
(Po p -Up  Me nu)

Removes only the domain or computer selected. 

Sca n Se le c te d
Do ma in fo r
Co mp ute rs

This  setting  is  only  available  when  right-clicking  on  a  domain
listed  in the  panel. Selecting  this  option  will  automatically  add
all the  machines  listed/available  under  the  selected  Domain.
This setting will make  it easier to  add  multiple  machines to  the
list. This  option only  works  if the  domain  selected  can  see  all
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the  desired  machines  where  PeerSync  and  PeerLock
reside. 

Notes: 

1. The Domain List window can be accessed from the Edit -> "Settings" menu.

2. By default the local domain is always included in the search even if it does not appear in this list.

Profile Operations

Pro file  Op e ra tio ns

Vie w o r Ed it Sto re d
Pro file

With  this  option  you  may  choose  to  Download  and  Edit  a
desired  running  Profile.  You  must  first  select  the  Profile  you
wish  to  edit  from  a  table  that  lists  all  the  running  instances  of
PeerSync. In this table the Sta tus  column will show Sto re d  if a
local  copy  of  the  Profile  exists  on  the  Peer  Administrator
system. Otherwise the status will be Unkno wn. 

Ge t Pro file
Click  the  Ge t Pro file  button to  download  the  selected  Profile
to  the  local  system  for  editing.  This  will  cause  the  remote
Profile to be   transferred  to  your Peer Administrator installation
directory, into  a  ProfilesStorage  sub  folder. The  Profile  will  be
stored in a folder named  after the  remote  system from where  it
was  copied  (i.e.  ..\Peer  Administrator\ProfilesStorage
\ComputerName\ProfileName.snc).



Peer Administrator Help38

Copyright © 1993-2013 Peer Software Inc. All Rights Reserved

Ed it Pro file
The  Ed it  Pro file  button will become  available  if the  selected
Profile  exists  in the  ProfilesStorage  folder on the  local  system
where  the  Peer  Administrator  is  running.  Click  this  button  to
launch  the  Profile  Editor.  This  interface  is  installed  by  default
unless  you  choose  to  opt  out.  You  must  register  the  Profile
Editor using your PeerSync license  key. The  Profile  Editor will
allow  you  to  make  Profile  modifications  using  the  options/
features that your PeerSync license  is  authorized  to  used. The
Profile  Editor is  a  light weight version of  the  PeerSync  Profiler
designed only for PeerSync Profile modifications - PeerLock
configuration  changes  are  currently  not  supported.  You  may
start  multiple  copies  of  the  Profile  Editor.  Monitor  the  Admin
Events panel for failure notifications.

Once you have made your Profile changes use the Dis trib ute
o r Re sta rt Sto re d  Pro file  operation to send your changes
to the remote server(s) and restart PeerSync for your changes
to take effect. 

Notes: 
1. By default all " .SNC"  Profiles get stored in  the  following  directory:  ...\ Peer

Administrator\ ProfilesStorage\ ComputerName\ ProfileName.snc
2. The  original  Profile  will  be  maintained  for  recovery  purposes  using  the

following naming convention: ProfileName.snc_ORIG

Cre a te  Custo m Pro file With  this  option  you  may  choose  to  Edit  or  Create  a  New
Profile.

Cre a te  Ne w
Click this button to launch the  Profile  Editor and  create  a  brand
new Profile. The Profile Editor is installed by default unless  you
choose  to  opt  out.  You  must  register  the  Profile  Editor  using
your PeerSync license  key. The  Profile  Editor will  allow you to
make Profile modifications  using  the  options/features  that your
PeerSync license is authorized  to  used. The  Profile  Editor is  a
light weight version of the  PeerSync Profiler designed  only  for
PeerSync  Profile  modifications  -  PeerLock  configuration
updates  are  currently  not  supported.  You  may  start  multiple
copies of the Profile Editor. 

Ed it Pro file
The  Ed it  Pro file  button will become  available  if you select  a
Profile  stored  on  the  local  system  or  anywhere  else  on  the
network.  Click  the  Ed it  Pro file  button  to  launch  the  Profile
Editor. This interface is  installed  by  default unless  you choose
to  opt  out.  You  must  register  the  Profile  Editor  using  your
PeerSync  license  key.  The  Profile  Editor  will  allow  you  to
make Profile modifications  using  the  options/features  that your
PeerSync license is authorized  to  used. The  Profile  Editor is  a
light weight version of the  PeerSync Profiler designed  only  for
PeerSync  Profile  modifications  -  PeerLock  configuration
updates  are  currently  not  supported.  You  may  start  multiple
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copies of the Profile Editor. Monitor the  Admin Events  panel for
failure notifications.

Once  you have  created  a  new Profile  or  updated  an  existing
one,  use  the  Dis trib ute  o r  Re sta rt  Custo m  Pro file
operation  to  send  your  changes  to  the  remote  server(s)  and
restart PeerSync for your changes to take effect. 

Notes: 
1. By default all " .SNC"  Profiles get stored in  the  following  directory:  ...\ Peer

Administrator\ ProfilesStorage\ ComputerName\ ProfileName.snc
2. The  original  Profile  will  be  maintained  for  recovery  purposes  using  the

following naming convention: ProfileName.snc_ORIG

Dis trib ute  o r Re sta rt
Sto re d  Pro file

With this option you may choose  to  Download, Edit, Distribute,
and  Restart a  desired  running  Profile. You must first select the
Profile  you  wish  to  edit  from  a  table  that  lists  all  the  running
instances  of  PeerSync.  In  this  table  the  Sta tus  column  will
show Sto re d  if a  local  copy  of  the  Profile  exists  on  the  Peer
Administrator system. Otherwise the status will be Unkno wn. 

Ge t Pro file
Click  the  Ge t Pro file  button to  download  the  selected  Profile
to  the  local  system  for  editing.  This  will  cause  the  remote
Profile to be   transferred  to  your Peer Administrator installation
directory, into  a  ProfilesStorage  sub  folder. The  Profile  will  be
stored in a folder named  after the  remote  system from where  it
was  copied  (i.e.  ..\Peer  Administrator\ProfilesStorage
\ComputerName\ProfileName.snc).

Ed it Pro file
The  Ed it  Pro file  button will become  available  if the  selected
Profile  exists  in the  ProfilesStorage  folder on the  local  system
where  the  Peer  Administrator  is  running.  Click  this  button  to
launch  the  Profile  Editor.  This  interface  is  installed  by  default
unless  you  choose  to  opt  out.  You  must  register  the   Profile
Editorusing  your PeerSync license  key. The  Profile  Editor  will
allow  you  to  make  Profile  modifications  using  the  options/
features that your PeerSync license  is  authorized  to  used. The
Profile  Editor is  a  light weight version of  the  PeerSync  Profiler
designed  only  for  PeerSync  Profile  modifications  -  PeerLock
configuration  updates  are  currently  not  supported.  You  may
start  multiple  copies  of  the  Profile  Editor.  Monitor  the  Admin
Events panel for failure notifications.

Ne xt
Once you have  made  your Profile  changes, select the  running
Profile  instance  you wish to  update/restart then  click  the  Ne xt
button. The dialog will now show all the  instances of PeerSync
that are currently running with Profiles matching  the  name  of the
local Profile you wish to distribute. 

Se le ct All
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Click  the  Se le ct  All  button  to  select/check  all  the  Profile
instances  that  have  the  same  name  as  the  local  Profile  you
wish  to  distribute.   Note:  Use  caution  when  using  this
option.The  Profiles  listed  have  the  same  name  as  the  local
Profile  you  wish  to  distribute,  but  may  have  different
configuration options. 

Dis trib ute
Once you've selected a target PeerSync(s) to update  you may
click the Dis trib ute  button. This option will transfer the  desired
Profile  to  the  selected  target  system(s).  Monitor  the  Admin
Events panel for failure notifications.

Dis trib ute /Re sta rt
Once you've selected a target PeerSync(s) to update  you may
click  the  D is trib ute /Re sta rt  button.  This  option  will  transfer
the desired Profile to the selected target system(s) followed  by
a  restart  of  PeerSync  in  order  for  the  changes  to  take  effect.
Monitor the Admin Events panel for failure notifications.

Notes: 
1. By default all " .SNC"  Profiles get stored in  the  following  directory:  ...\ Peer

Administrator ProfilesStorage\ ComputerName\ ProfileName.snc
2. The  original  Profile  will  be  maintained  for  recovery  purposes  using  the

following naming convention: ProfileName.snc_ORIG

Dis trib ute  o r Re sta rt
Custo m Pro file

With this  option you may choose  to  Distribute, Restart, Edit, or
Create a New Profile.

Cre a te  Ne w
Click this button to launch the  Profile  Editor and  create  a  brand
new Profile. The Profile Editor is installed by default unless  you
choose  to  opt  out.  You  must  register  the  Profile  Editor  using
your PeerSync license  key. The  Profile  Editor will  allow you to
make Profile modifications  using  the  options/features  that your
PeerSync license is authorized  to  used. The  Profile  Editor is  a
light weight version of the  PeerSync Profiler designed  only  for
PeerSync  Profile  modifications  -  PeerLock  configuration
updates  are  currently  not  supported.  You  may  start  multiple
copies of the Profile Editor. 

Ed it Pro file
The  Ed it  Pro file  button will become  available  if you select  a
Profile  stored  on  the  local  system  or  anywhere  else  on  the
network.  Click  the  Ed it  Pro file  button  to  launch  the  Profile
Editor. This interface  is  installed  by  default unless  you choose
to  opt  out.  You  must  register  the  Profile  Editor  using  your
PeerSync license key. The Profile Editor will allow you to make
Profile  modifications  using  the  options/features  that  your
PeerSync license is authorized  to  used. The  Profile  Editor is  a
light weight version of the  PeerSync Profiler designed  only  for
PeerSync  Profile  modifications  -  PeerLock  configuration
updates  are  currently  not  supported.  You  may  start  multiple
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copies of the Profile Editor. Monitor the  Admin Events  panel for
failure notifications.

Ne xt
Once  you have  created  a  new Profile  or  updated  an  existing
one,  click  the  Ne xt  button.  The  dialog  will  now  show  all  the
instances  of  PeerSync  that  are  currently  running  with  Profiles
matching the name of the local Profile you wish to distribute

Se le ct All
Click  the  Se le ct  All  button  to  select/check  all  the  Profile
instances  that  have  the  same  name  as  the  local  Profile  you
wish  to  distribute.   Note:  Use  caution  when  using  this
option.The  Profiles  listed  have  the  same  name  as  the  local
Profile  you  wish  to  distribute,  but  may  have  different
configuration options. 

Dis trib ute
Once you've selected a target PeerSync(s) to update  you may
click the Dis trib ute  button. This option will transfer the  desired
Profile  to  the  selected  target  system(s).  Monitor  the  Admin
Events panel for failure notifications.

Dis trib ute /Re sta rt
Once you've selected a target PeerSync(s) to update  you may
click  the  Dis trib ute /Re sta rt  button.  This  option  will  transfer
the desired Profile to the selected target system(s) followed  by
a  restart  of  PeerSync  in  order  for  the  changes  to  take  effect.
Monitor the Admin Events panel for failure notifications.

Notes: 
1. By default all " .SNC"  Profiles get stored in  the  following  directory:  ...\ Peer

Administrator\ ProfilesStorage\ ComputerName\ ProfileName.snc
2. The  original  Profile  will  be  maintained  for  recovery  purposes  using  the

following naming convention: ProfileName.snc_ORIG

Re sta rt Running
Pro file

Select the PeerSync instances to restart.

Se le ct All
Click  the  Se le ct  All  button  to  select  all  the  running  Profile
instances  to  restart  PeerSync.  This  feature  will  work  for  all
running  instances of PeerSync, even if they  are  not running  as
a service.

Re sta rt
Once  you  have  selected  the  running  PeerSync  instances  to
restart  click  the  Re sta rt  button  to  issue  a  restart  command.
Monitor the Admin Events panel for failure notifications.

Notes: These options are only available when using the PeerSync Administrator Enterprise Package.

http://www.peersoftware.com/products/peer_utilities/Administrator_Enterprise_Package/overview.aspx
http://www.peersoftware.com/products/peer_utilities/Administrator_Enterprise_Package/overview.aspx
http://www.peersoftware.com/products/peer_utilities/Administrator_Enterprise_Package/overview.aspx
http://www.peersoftware.com/products/peer_utilities/Administrator_Enterprise_Package/overview.aspx
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Color Legend Panel

Le g e nd

The  colors  shown  in  this  legend  are  used  by  the  PSPeer  Administrator  to  represent  the
connection status of each row in the PeerSync  and PeerLock  Activity  Panels. Currently
only  the  Active/Receiving  (White),  Pending  (Yellow),  Failed  (Red),  and  Finished  (Dark
Gray)  colors  apply  to   PeerLock  entries.   Paused  and  Failed-Idle  will  only  apply  to
PeerSync items. 

Re ce iv ing Actively receiving incoming status. The  value  of this  status  is  1
and can be shown in the Status column of the PeerSync Activity
Panel. 

Pa use d Connection  is  active  but  remote  application  is  currently
paused.  The  value  of this  status  is  2 and  can be  shown in the
Status column of the PeerSync Activity Panel. 

Fa ile d Lost connection while remote application was processing data.
 This  suggests  that  PeerSync  may  have  not  completed  its
tasks  before  terminating. The  value  of this  status  is  5  and  can
be shown in the Status column of the PeerSync Activity Panel. 

Pe nd ing Remote  application is  temporarily  not  responding.  The  value
of this status is 3 and  can be  shown in the  Status  column of the
PeerSync Activity Panel. 

Finishe d Remote  application was  terminated  in  a  normal  manner.  The
value of this status is 0 and  can be  shown in the  Status  column
of the PeerSync Activity Panel. 

Fa ile d / Id le Lost  connection  while  remote  application  was  idle.   This
suggests  that  PeerSync completed  its  tasks  before
terminating. The  value  of this  status  is  4  and  can  be  shown  in
the Status column of the PeerSync Activity Panel. 

Notes: 

1. By default this panel is shown and can be removed by unchecking the 'Show Color Legend Panel' option from
the View menu. 

2. Placing the mouse over a color in the Color Legend Panel displays a hint which describes the meaning of  that
color.

3. Clicking on one of the colors on the panel opens the Settings window where you may change or reset the colors.
Alternatively, you may access the Settings window from the Edit menu. 

4. Each status is represented as an integer (-1 to 5) and can be viewed  in  the  Status  column  of  the  PeerSync
Activity Panel ( 0 = Finished, 1 = Receiving, 2 = Paused, 3 = Pending, 4 = Failed-Idle, 5 = Failed, -1 = Unknown)
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Profile Editor

Pe e rSync Pro file  Ed ito r

The Pro file  Ed ito r is installed by default unless you choose to opt out.  It is used to  create
or edit Profiles  and  is  launched  when selecting  the  Cre a te  Ne w  or Ed it  Pro file  settings
from the Profile Operations  window. Before  starting  the  Pro file  Ed ito r  you must register it
using  your  PeerSync  license  key.  The  Pro file  Ed ito r  will  allow  you  to  make  Profile
modifications using  the  options/features  that your PeerSync license  is  authorized  to  used.
The Pro file  Ed ito r  is  a  light weight version of the  Pe e rSync  Pro file r  designed  only  for
PeerSync  Profile  creations/modifications  -  PeerLock  configuration  updates  are  currently
not supported. You may start multiple copies of the Pro file  Ed ito r. 

For  detailed  information  on  all  the  Pro file  Ed ito r  options  please  review  the  PeerSync
Help manual.

http://www.peersoftware.com/products/resources/pdf/kb/ps/hlp/HTML/pshelp.html
http://www.peersoftware.com/products/resources/pdf/kb/ps/hlp/HTML/pshelp.html
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Status Display

Sta tus  T a b  Fe a ture s

The Status Display window can be accessed by double clicking  on one  of the  items within
the PeerSync Activity  Table  or by  selecting  Connect to  Status  Display  from the  PeerSync
Activity  Pop-Up  Menu.  The  Status  Display  window is  the  same  display  window  used  in
PeerSync  to  view Current Profile Activity within the  PeerSync  application. This  window
is not accessible when PeerSync  is running as a Service. 

Pro file Displays  the  name  of  the  Profile  actively  being  processed.
This  label  may  not  match  the  name  of  the  Profile  currently
being configured through the Profiler.

Jo b This  indicator will dynamically  display  the  name  of  whichever
Job is presently being processed for the Active Profile.

Mo d e Displays  the  Operation  Mode  (Real-time  Mode,  Scheduled
Operation, etc.) applied to synchronization of the Active Profile. 

So urce Displays  a  file  path  for  the  Source  Folder  presently  being
synchronized.

T a rg e t Displays  a  file  path  for  the  Target  Folder  presently  being
synchronized from the Source indicated above. 

Fo ld e rs This  indicator  provides  a  count  of  all  unsynchronized  folders
contained  within the  Source, and  will decrease  as  each  folder
is synchronized. An additional "thermometer" indicator will also
track the progress of folder synchronization.
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File s This indicator displays the total number of files contained  within
the Source while also providing a count of synchronized files. In
addition,  a  "thermometer"  indicator  will  show  file
synchronization progress  by  increasing  according  to  the  size
of the current folder, with 100% representing the cumulative  size
of files contained within the Source Job set.

File Indicates the name of the file currently being synchronized.

La rg e  File  o r
Co mp re ss io n Sta tus

This caption will be displayed to the right of the file name  that is
currently  synchronized  for large  files  and  during  compression.
The  caption will show the  size  of the  file  that has  been  copied
to the Target and/or compression status.

Size Indicates  the  size  (in  bytes)  of  the  file  currently  being
synchronized.  A  related  "thermometer"  indicator  tracks  the
progress of synchronization for that file.

Che cke d This  indicator displays  the  total number of source  files/folders
that have been validated for all Profile Jobs.

Exclud e d Indicates  the  number  of  files  that  were  excluded  from
synchronization. 

Me ssa g e s Indicates  the  number  of  error  messages  generated  during
Profile processing. 

Up d a te d Indicates  the  number of Target Files  that were  updated  during
synchronization of all Profile Jobs. 

Ad d e d Indicates the  number of new files  added  to  the  Target Folders
during the synchronization of all Profile Jobs.

De le te d Indicates  the  number  of  files  deleted  (or  moved)  during
synchronization of all Profile Jobs.

Ela p se d  T ime Indicates the amount of time that has elapsed during the current
Profile activity.

Re fre sh Refreshes the Status Display features.

Clo se Will  close  the  Status  Display,  which  can  be  re-accessed  via
double-clicking on an item within the Activity Table.

Othe r T a b  Fe a ture s

Up d a te d Screen  containing  statistical  information  (File  Name,  Size,
Modified  Date/Time,  Path,  Duration,  etc.)  about  the  updates
that  occurred  during  the  current  PeerSync  session.  Right-
click  and  select  Sa ve  As  to  export  the  list  into  a  CSV  file
format (PSUpdated.csv).  

Ad d e d Screen  containing  statistical  information  (File  Name,  Size,
Modified  Date/Time,  Path,  Duration,  etc.)  about  the  file  adds
that occurred  during  the  current PeerSync  session.  Right-click
and  select  Sa ve  As  to  export  the  list  into  a  CSV  file  format
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(PSAdded.csv).

De le te d Screen  containing  statistical  information  (File  Name,  Size,
Modified  Date/Time,  Path,  Duration,  etc.)  about  the  deletions
that  occurred  during  the  current  PeerSync  session.  Right-
click  and  select  Sa ve  As  to  export  the  list  into  a  CSV  file
format (PSDeleted.csv).

Exclud e d Screen  containing  statistical  information  (File  Name,  Size,
Modified Date/Time, Path, Note, etc.) about the  exclusions  that
occurred  during  the  current  PeerSync  session.   Right-click
and  select  Sa ve  As  to  export  the  list  into  a  CSV  file  format
(PSExcluded.csv).

Me ssa g e s Screen  containing  a  list  of  error  messages  generated  during
the  current PeerSync  session.  Right-click  and  select  Sa ve
As  to export the list into a CSV file format (PSMessages.csv).

Jo b  Sta ts Screen  containing  a  list  of  all  the  Jobs  configured  under  the
current  Profile  with  their  respective  Source  and  Target  paths.
Right-clicking on this table  brings  up  a  pop-up  menu providing
the  ability  to  View   Log  File  and  Open  the  Source/Target
Folders for the selected Jobs from the remote PeerSync.

Jo b  Sca ns Lists  how many scans are  running  at a  Job  level either  for  the
selected  Job  or for all  the  Jobs.  Right-click  and  select  Sa ve
As  to export the list into a CSV file format (PSJobScans.csv).

Ma na g e d  File s  Lis t Lists the total number of files  that are  in the  Managed  Files  List
for  the  selected  Job  or  all  the  Jobs.  Right-click  and  select
Sa ve  As  to  export  the  list  into  a  CSV  file  format
(PSManagedFilesList.csv).

Fa ile d  Eve nts Lists all the failed files for the selected  Job  or all the  Jobs. You
can right-click  the  list  and  select  Reprocess  Failed  Events  to
notify  PeerSync  to  re-process  them  for  all  the  Jobs  (not  Job
specific).  To  reprocess  only  a  specific  file,  you  can  click  the
Reprocess Selected  button  from  the  Failed  Events  tab  within
the  PeerSync Status  Display  (when  running  as  an  application
only).  Right-click  and  select Sa ve  As  to  export the  list  into  a
CSV file format (PSFaileEvents.csv). 

File  Co p y Pro g re ss Visually  displays  the  file  copy  progress  for  each  file  for  the
selected  Job  or all the  Jobs. Right-click  and  select  Sa ve  As
to  export  the  list  into  a  CSV  file  format
(PSFileCopyProgress.csv).

His to rica l Da ta This panel displays a subset of the  Job  Stats  table  (Xfer Rate,
Bytes  and  Event  Averages)  in  an  hourly,  daily,  weekly,  and
total  format  for  all  the  Jobs  or  only  the  selected  Job.
Furthermore,  it  displays  a  Running  Event  Count,  a  Running
Event  Average  and  Peak  Count,  and  a  Running  Job  Count.
Right-click and select Sa ve  As  to export the list into  a  CSV file
format (PSHistoricalData.csv).
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License

YOU  SHOULD  READ  CAREFULLY  T HE  FOLLOWING  T ERMS  AND
CONDIT IONS  BEFORE  INST ALLING,  USING  OR  DIST RIBUT ING  T HIS
SOFT WARE.  INST ALLING,  USING  OR  DIST RIBUT ING  T HIS  SOFT WARE
INDICAT ES  ACCEPT ANCE  OF  T HESE  T ERMS  AND  CONDIT IONS.  IN  T HIS
AGREEMENT ,  ' 'YOU' '  MEANS  YOU  AS  AN  INDIVIDUAL  IF  YOU  ARE  USING
T HIS  SOFT WARE  FOR  PERSONAL  USE.  IF  YOU  ARE  USING  T HE
SOFT WARE  ON  EQUIPMENT  OWNED  OR  OPERAT ED  BY  A  COMPANY  OR
ORGANIZAT ION  (COLLECT IVELY  ' 'COMPANY' ' ),  BY  ACCEPT ING  T HIS
AGREEMENT ,  YOU  REPRESENT  T HAT  YOU  ARE  DULY  AUT HORIZED  T O
ACCEPT  T HIS AGREEMENT  ON BEHALF OF YOUR COMPANY.

COPYRIGHT

The  software  programs  (hereafter  the  "Software")  and  documentation  (hereafter  the
"Documentation") is copyrighted and remains the property of Peer Software, Inc. All rights are
reserved.

LICENSE

Peer  Software,  Inc.  hereby  grants  you  (hereafter  the  "User")  a  limited,  non-exclusive,  non-
transferable  license  to  install  and  use  the  Software  and  accompanying  Documentation
contained  in  the  trialware  distribution  package  (hereafter  called  the  "Trialware  Package")
you  received  (THE  "Original  Distribution")  for  your  internal  business  purposes  only.  The
Trialware  Package  consists  of copies  of the  Software  and  Documentation  received  via  an
electronic  transfer mechanism or an electronic  storage  medium including, but not  limited  to,
diskette, hard  disk,  removable  disk,  tape  or  optical  devices  such  as  CD-ROM  or  WORM.
This  license  to  install and  use  the  Software  and  Documentation is  conditioned  upon  User’s
compliance with the terms of this Agreement.

You may install and use the Trialware Package on one or more  computers  provided  there  is
no chance that it will be used simultaneously  on more  than one  computer. If you need  to  use
the  Software  on  more  than  one  computer  simultaneously  or  on  a  network,  please  contact
Peer Software, Inc. for information about network licenses.

The  Software  is  protected  by  trade  secret  and  copyright  laws  and  international  treaty
provisions. You are  not obtaining  title  to  the  Software  or Documentation or  any  copyright  or
other intellectual property rights. You further acknowledge that title and full ownership  rights  to
the  Software  and  Documentation will remain the  exclusive  property  of Peer Software, Inc. or
its  suppliers,  and  You  will  not  acquire  any  ownership  rights  to  the  Software.  You  may  not
sublicense, lease, rent, sell, convey,  translate,  modify,  decompile,  incorporate  into  another
product,  convert  to  another  programming  language,  reverse  engineer  or  disassemble  the
Software or Documentation for any purpose. You may not modify, or create  derivative  works
based in whole or in part upon, the Software. You agree to not remove, obscure, or alter Peer
Software, Inc.’s  or any  third  party's  copyright  notice,  trademarks,  or  other  proprietary  rights
notices affixed to or contained  within or accessed  in conjunction with or through the  Software
and  Documentation.  Peer  Software,  Inc.  reserves  the  right  to  periodically  conduct  audits
upon advance written notice to verify compliance with the terms of this Agreement.

Once  a  license  is  purchased  from   Peer  Software,  Inc.,  the  Trialware  Package  will  be
authorized  to  function as  the  full working  version of the  Software  with  access  to  all  licensed
features.
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NET WORK LICENSE

Multiple users on a network (e.g. a LAN) requiring access to the Software and  Documentation
must  purchase  a  Network  License.  Two  forms  of  Network  Licenses  are  offered,  a  Site
License  and  Enterprise  or  Concurrent  User  License.  With  a  Site  License,  any  user  who
accesses  the  Software  or  Documentation  requires  a  user  license,  regardless  of  the
frequency of use. Once  a  Site  License  is  purchased  Software  and  Documentation  may  be
copied  to  all  users  who  have  been  licensed.  Site  Licenses  are  customized  for  each
purchase. The license is based on a quantity of simultaneous users and or CPU installations.

The Concurrent User License allows the licensed number of users  to  simultaneously  access
the  Software  and  Documentation.  The  User  agrees  to  operate  metering  software,  which
restricts  the  simultaneous  number  of  users  to  the  quantity  purchased.  The  Software  and
Documentation must be installed on network servers under the control of metering software. 

Both Site and Concurrent User Licenses allow installation of the Software and  Documentation
to  any number of servers  on any number of geographic  sites, limited  only  by  the  quantity  of
licenses purchased.

T ERM AND T RIAL PERIOD

You  are  permitted  to  use  the  Trialware  Package  for  a  trial  period  (hereafter  the  "Trial
Period") of thirty  (30) days  or 30 uses (which ever comes  first)  after  receipt  of  the  Trialware
Package. After such time, if  you  continue  to  use  the  Trialware  Package,  you  must  register
your  copy  with  Peer  Software,  Inc.  Failure  to  register  after  the  Trial  Period  constitutes
termination of this  license. Upon registration, a  password  (hereafter  called  the  "Password")
will be provided to eliminate the registration reminder screen.

This  license  is  effective  until  terminated.  You  may  terminate  it  by  destroying  the  Software,
Documentation, and  all copies  thereof. This  license  will also  terminate  if  you  fail  to  comply
with any of the  terms or conditions  herein. You  agree,  upon  such  termination,  to  destroy  all
Software, Documentation, and  copies  thereof. Upon  request,  You  agree  to  certify  in  writing
that all copies of the Software and Documentation have been destroyed.

LIMIT ED WARRANT Y

THE SOFTWARE AND DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTY
OF  ANY  KIND. PEER  SOFTWARE, INC. DISCLAIMS  ALL  WARRANTIES  RELATING  TO
THIS  SOFTWARE,  WHETHER  EXPRESSED  OR  IMPLIED,  INCLUDING  BUT  NOT
LIMITED  TO  ANY  IMPLIED  WARRANTIES  OF  MERCHANTABILITY,  FITNESS  FOR  A
PARTICULAR  PURPOSE,  AND  INFRINGEMENT  AND  ALL  SUCH  WARRANTIES  ARE
EXPRESSLY AND SPECIFICALLY DISCLAIMED. 

EXCLUSIVE REMEDY

YOUR EXCLUSIVE REMEDY AND PEER  SOFTWARE, INC. ENTIRE  LIABILITY  ARISING
FROM  OR  IN  CONNECTIONS  WITH  THE  SOFTWARE,  DOCUMENTATION,  AND/OR
THIS LICENSE (INCLUDING  WITHOUT  LIMITATION  FOR  BREACH  OF  WARRANTY  OR
INFRINGEMENT)  SHALL  BE,  AT  PEER  SOFTWARE, INC.'S  OPTION, THE  REPAIR  OR
REPLACEMENT  OF  THE  SOFTWARE  OR  REFUND  OF  REGISTRATION  FEES  (IF
NOTIFICATION OF PROBLEM IS WITHIN 30 DAYS OF PURCHASE).
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LIMIT AT IONS OF LIABILIT Y

UNDER NO CIRCUMSTANCES OR LEGAL THEORY, WHETHER IN  TORT, CONTRACT,
OR OTHERWISE, SHALL PEER SOFTWARE, INC. OR ANYONE ELSE  WHO  HAS  BEEN
INVOLVED IN  THE CREATION, PRODUCTION, OR DELIVERY OF THIS  SOFTWARE  BE
LIABLE  TO  YOU  OR  TO  ANY  OTHER  PERSON  FOR  ANY  INDIRECT,  SPECIAL,
INCIDENTAL,  OR  CONSEQUENTIAL  DAMAGES  (EVEN  IF  PEER  SOFTWARE,  INC.
SHALL HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES), INCLUDING,
WITHOUT  LIMITATION,  DAMAGES  FOR  LOSS  OF  GOODWILL,  WORK  STOPPAGE,
COMPUTER  FAILURE  OR  MALFUNCTION,  OR,  FOR  ANY  OTHER  DAMAGES  OR
LOSSES OF ANY NATURE. IN NO EVENT WILL PEER SOFTWARE, INC. BE LIABLE FOR
ANY  DAMAGES  IN  EXCESS  OF  THE  LIST  PRICE  PEER  SOFTWARE,  INC.  CHARGES
FOR A LICENSE TO THE SOFTWARE. 

Some  states  do  not allow the  exclusion of the  limit of liability  for consequential  or  incidental
damages, so the above limitation may not apply to you.

BACK-UP

You may make one copy of the Trialware Package for backup purposes only.

DIST RIBUT ION

You may distribute the Trialware  Package  to  others  via  an electronic  transfer mechanism or
electronic  storage  media  provided  that  no  files  are  deleted  from  the  Original  Distribution
Trialware  Package  or  are  modified  in  any  way.  Files  may  be  added  to  the  Trialware
Package  expressly  for  the  purpose  of  identifying  the  party  distributing  the  Trialware
Package.  You  may  also  place  the  Trialware  Package  into  any  archive  or  compressed
format for ease of distribution.

You may not distribute the product Registration Key to others under any circumstances.

GENERAL

Export  of  the  Software  may  be  subject  to  compliance  with  the  rules  and  regulations
promulgated  from  time  to  time  by  the  Bureau  of  Export  Administration,  United  States
Department  of  Commerce,  which  restrict  the  export  and  re-export  of  certain  products  and
technical data. If  the  export  of  the  Software  is  controlled  under  such  rules  and  regulations,
then  the  Software  shall  not  be  exported  or  re-exported,  directly  or  indirectly,  (a)  without  all
export or re-export licenses and United  States  or other governmental approvals  required  by
any applicable laws, or (b) in violation of any  applicable  prohibition against the  export or re-
export of any part of the  Software. Some  countries  have  restrictions  on the  use  of encryption
within their borders, or the  import or export of encryption even if for only  temporary  personal
or business use. You acknowledge that the implementation and enforcement of these  laws is
not  always  consistent  as  to  specific  countries.  Although  the  following  countries  are  not  an
exhaustive list there  may exist restrictions  on the  exportation to, or importation of, encryption
by:  Belgium, China  (including  Hong  Kong),  France,  India,  Indonesia,  Israel,  Russia,  Saudi
Arabia, Singapore, and  South  Korea.  You  acknowledge  it  is  your  ultimate  responsibility  to
comply  with  any  and  all  government  export  and  other  applicable  laws  and  that  Peer
Software,  Inc.  has  no  further  responsibility  after  the  initial  license  to  you  within  the  original
country of sale.

In  addition,  neither  the  Software  nor  the  Documentation  and  underlying  information  or
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technology may be downloaded or otherwise exported or re-exported (i) into (or to  a  national
or resident of) any country to which the United States has embargoed goods; or (ii) to  anyone
on  the  United  States  Treasury  Department's  list  of  Specially  Designated  Nations  or  the
United  States  Commerce  Department's  Table  of Denial Orders. By  using  the  Software  you
are  agreeing  to  the  foregoing  and  you  are  certifying  that  you  are  not  located  in,  under  the
control of, or a national or resident of any such country or on any such list.

This agreement shall be governed by the laws of the state of New York  and  shall inure  to  the
benefit of Peer  Software,  Inc.  and  any  successors,  administrators,  heirs,  and  assigns.  Any
action  arising  under  this  Agreement  shall  be  filed  in  any  state  or  federal  court  located  in
Suffolk county in the State  of New York, and  You hereby agree, acknowledge  and  submit to
the exclusive jurisdiction and venue of such courts for the purposes of such action, waive  any
right You may have to object to such jurisdiction or venue.

This  Agreement sets  forth all rights  for the  user of the  Software  and  is  the  entire  agreement
between You and  Peer Software, Inc. and  supersedes any other prior or contemporaneous
agreements  or  communications  with  respect  to  the  Software  and  Documentation.  This
Agreement may not be modified  except by  a  written addendum issued  by  a  duly  authorized
representative  of Peer Software, Inc.  No  provision  hereof  shall  be  deemed  waived  unless
such  waiver  shall  be  in  writing  and  signed  by  Peer  Software,  Inc.  or  a  duly  authorized
representative  of Peer  Software,  Inc.  If  any  provision  of  this  Agreement  is  held  invalid,  the
remainder of this Agreement shall continue in full force and effect. The parties confirm that it is
their wish that this Agreement has been written in the English language only.
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