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RFduino Quickstart Guide

RFD22102 RFduino DIP

RFD22121 USB Shield

RFD22122 RGB LED / Button Shield
RFD22123 Servo Shield

RFD22124 PCB USB Shield
RFD22125 Proto Shield

RFD22126 Dual AAA Battery Shield
RFD22127 Single AAA Battery Shield
RFD22128 CR2032 Battery Shield
RFD22130 MicroSD Shield
RFD22131 Dual Relay Shield

RFD90101, RFD90102, RFD90103, RFD90104, RFD90105 Eval / Dev Kits
An RFduino "Shield" is a modular accessory that directly plugs into the RFduino.

Shrunk an Arduino to the size of a finger-tip
and made it Wireless!

Based On
RFD22301
RF Digital
RF Module

RFD22102 RFduino DIP

Stackable & plugs directly into breadboards

RFduino is a RF Module
with Built-In BLE Stack and ARM Cortex MO
Microcontroller
for Rapid Development and Prototyping Projects

Simple to use Arduino IDE and sketches

running on professional grade hardware
Manufactured by RF Digital Corp. - Support: support@RFduino.com 1
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RF Digital

RF Module

The RFduino is RF Module with Built-In BLE Stack and ARM Cortex MO Microcontroller for Rapid
Development and Prototyping Projects. It features the RFD22301 SMT Module.

Dimensions:
X: 0.900" (22.86mm)
Y: 1.140" (28.95mm)
Z: 0.725" (18.4mm)
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Description Min Nom Max Notes
VDD - Supply Voltage 19V 3.0V 3.6V

General Purpose I/0 (GPIO) input high 0.7 *VDD VDD

voltage

General Purpose I/0 (GPIO) input low VSS 0.3*VDD

voltage

Output standard drive current 0.5 mA

Output high drive current 5 mA Max 3 pins
ULP Current with RC OSC Running 4uA

Transmit Current 18mA

Receive Current 18mA

ARM CPU Running Current 4mA

Manufactured by RF Digital Corp. - Support: support@RFduino.com
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RFduino IDE Installation on Windows

5. Go to Edit Preferences, and add http://rfduino.com/package_rfduino_index.json to
Additional Board Manager URLs and save.

-

Preferences E'E'@‘

Sketchbook location:

Ci\dsers\U 21\ Documents\Arduing

Editor language: :System Default - (requires restart of Arduino)
Editor font size: |11 {requires restart of Arduino)

Show verbose output during: compilation  [~] upload

Compiler warnings: :None -

Display line numbers

Verify code after upload

[] Use external editor

Check for updates on startup

Update sketch files to new extension on save (.pde - .ino)

Automatically assodate .ino files with Arduino

Save when verifying or uploading
Proxy Settings

Server (HTTP): |rfduino.com Port (HTTP): 8080
Server: (HTTPS) Port (HTTPS): |8443
Username: Password:

Additional Boards Manager LIRLs: htn:::,.’,."rfduinc:.cnm,.’padcage_rfduinn_index.jsnn|

Mare preferences can be edited directly in the file
C:WUsers\U21\AppData\RoamingArduino 15\preferences. tut
(edit only when Arduino is not running)

QK ] [ Cancel

Manufactured by RF Digital Corp. - Support: support@RFduino.com 3
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RFduino IDE Installation on Windows

6. Go to Tools > Board > Board Manager... to open the Board Manager. A list of various
Boards will show in alist. Scroll down until you see RFduino Boards by RFduino. Click
on this Item to select it. Once selected, an option on the right will appear to install the
RFduino library. Clicking this will install the latest RFduino library by default. Once
installed, you can close the Board Manager Menu.

[ ﬁkmh_aprzaa | Arduino 16 [FEEE )

File Edit Sketch [Tools| Help

Aute Format Chrl+T

Archive Sketch

sketch_apra3z Fix Encoding & Reload
Loveld st geral Monitor Ctrl+Shift+M
2 J4opat g
3 Board Boards Manager...
4}
- Port Arduino AVR Boards
£ woid loop Arduing Yin
- /7 put 1 Programmer o | Aot
Burn Bootloader reuine LUne

Arduino Duemilanove or Diecimila

o oo

Arduine Nano

Arduine Mega or Mega 2560
Arduinc Mega ADK
Arduine Leonardo
Arduine Micro
Arduino Esplora
Arduine Mini

Arduino Ethernet

1 Arduine Fio

Arduinc BT

LilyPad Arduino USE
LilyPad Arduino
Arduine Pro or Pro Mini
Arduine NG or older
Arduine Robot Control

Arduine Robot Motor

Manufactured by RF Digital Corp. - Support: support@RFduino.com 4
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RFduino IDE Installation on Windows

Type Al - your search. ..

Arduino AVR Boards Built-In by Arduino version 1.6.3 INSTALLED o~
Boards included in this package:

Arduino Ydn, Arduine Une, Arduine Diecimila, Arduino Nano. Arduine Mega, Arduino MegaADK. Arduine Leonardo, Arduino Micro,
Arduino Esplora, Arduino Mini, Arduino Ethernet, Arduino Fio, Arduino BT, Arduino LilyPadUSB, Arduino Lilypad, Arduino Pro,

Arduino ATMegaNG, Arduino Robot Control, Arduino Robot Motor.

More info

Arduine SAM Boards (32-bits ARM Cortex-M3) by Arduino
Boards included in this package:

Arduinc Due.

Mors info

Intel i586 Boards by Intel
Boards included in this package:
Galileo.

More info

Intel i686 Boards by Intel
Boards included in this package:
Edison.

More info

RFduino Boards by RFduino
Boards included in this packaga:
RFduino.

More info

Arduino AVR Boards Built-In by Arduine version 1.6.3 INSTALLED &
Boards included in this package:

Arduino Yin, Arduino Uno, Arduino Diecimila, Arduine Nano, Arduino Mega, Arduinc MegaADK, Arduino Leonarde, Arduino Micro,
Arduinc Esplora, Arduino Mini, Arduino Ethernet, Arduino Fio, Arduino BT, Arduino LilyPadUSE, Arduino Lilypad, Arduine Pro,
Arduino ATMegaNG, Arduine Robot Control, Arduino Robot Motor.

More info

Arduino SAM Boards (22-bits ARM Cortex-M2) by Arduino
Boards included in this package:

Arduine Due.

More info

Intel i586 Boards by Intel
Boards included in this package:
Galileo.

mn

More info

Intel i686 Boards by Intel
Boards included in this package:
Edison.

More info

RFduino Boards by RFduino version 2.3.0 INSTALLED
Boards included in this package:

RFduino.

More info L4

Manufactured by RF Digital Corp. - Support: support@RFduino.com 5
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RFduino IDE Installation on Windows

7. Goto Tools > Board menu, and select RFduino. With RFduino selected as the Board,
you may now view the RFduino BLE, GZLL, and Non-BLE Examples in the File >
Examples drop down list.

[& sketch_apr23a | Arduino 16 | |

[ @ sketch_apr22a | Arduino 16 |
File Edit Sketch Help ol

m Edit Sketch Teols Help
MNew Ctrl+N

Auto Format

Archive Sketch

Fix Encoding & Reload pe Gl
Serial Monitor Cerl+ Shift+M Aeaitral:
Examples 01.Basics
als Lz Bosa i Manags Tz CirleW 02.Digital
5 Port M e Save Ctrl+5 03.Analog

& wvoid leop Programmer Arduino ¥iin Save As.. Ctrl+Shift+ S 04.Communication

7 £/ put 3 =
8 Burn Bootloader Siunelng Upload Ctrl+U 05.Centrol
ERl Arduino Duemilanove or Diecimila Upload Using Programmer  Ctrl+Shift+U 06.5ensors
Arduino Nano
. 07.Display
Arduino Mega or Mega 2560 Page Setup Ctrl+Shift+P
i 08.5trings
Arduine Mega ADK Print Ctrl+P

09.UsB
10.5tarterkit
ArduinolSP

Arduino Leonardo
Preferences Ctrl+Comma
Arduino Micro

Arduine Esplora Quit Ctrl+Q

Arduino Mini
Arduino Ethernet

Arduino Fio

Arduino BT

LilyPad Arduinc USB
LilyPad Arduino
Arduina Pro or Pro Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor

RFduinc Boards
@ RFduino

8. Congratulations, you are now ready to program the RFduino!

Bridge

Esplora
Ethernet

Firmata

GSM
LiquidCrystal
Robot Contrel

Robot Motor
SD

Stepper

TFT

WiFi
IRremote
RFduinoBLE
RFduinoGZLL
RFduinoMNonBLE
Servo

SPI

Wire

Manufactured by RF Digital Corp. - Support: support@RFduino
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Updating RFduino Library

RFduino page.

' Bosrds Mansger

Type :AJI

RFduino
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- | | Filfer pour seardh...

&
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1. Periodically, the RFduino Team will update the RFduino Library files. To keep current
with the latest library updates, we recommend following the RFduino Forum and

2. To update the library, go to Tools > Boards > Board Manager. Scroll down to RFduino
Boards and click to highlight the option. Click Update to download the latest library.

Arduino Due.
More info

Galileo.
More info

Intel i586 Boards by Intel
Boards included in this package:

Edison.
More info

Intel i686 Boards by Intel
Boards included in this package:

RFduino.
More info

RFduino Boards by RFduine version 2.2.0 INSTALLED
Boards included in this package:

Manufactured by RF Digital Corp. - Support: support@RFduino.com
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RFduino USB Driver Installation on Windows

1. Visit the following link: http://www.ftdichip.com/Drivers/VCP.htm

2. Download and install the drivers for your system

3. On Windows you should have a new com port called “USB Serial Port”

e=

File Achion

View Help

= = E HE 8 RS

Device Manager

_—y

A Monitors

b T 7T 7

LF Network adapters
K Portable Devices
"2 Ports (COM & LPT)
'r? Communications Port (COMZ2)

=7 USE Serial Port (COM3) |

g%g Print queues
= Printers
ﬁ Processors

A v A

| Software devices

£ Snond viden and name contrallere

sketch_mar19a | Arduino 1.5.6-r2 =

File Edit Sketch TuulslHEIp

sketch_mar13

vold setuy
A4opat s

viold loop
A4opat 3

=] M tn s L ) -
—

Auto Format
Archive Sketch
Fix Encoding & Reload

Serial Monitor

Board

Ctrl+T

Ctrl+ Shift+ M

=

Port

I Com2

Programmer

Burn Bootloader

\ v | COM3

Il

oo
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RFduino IDE Installation on Mac OS X

1. Visit the following link: http://arduino.cc/en/Main/Software

2. Download Arduino IDE v1.6.4 or newer for Mac OS X

3. Extract the Arduino app to your Application folder

800 (z2] Applications
e = Jm) (5] (2 ) (] (8]  [©](%:] (@
FAVORITES @ Adobe Photoshop €55 (3

= . - i [
% All My Files |_ﬂ Adobe Premiere Pro C55
. Ell Adobe Soundbooth C55 -
< Airbrop [& Air video server
Desktop @ Aperture

fﬂ‘ rghazarianl &) App Store

9&: Applications

g Automator
) Documents = Caffeine

g Dropbox || Calculator
(i Calendar
DEVICES & CCleaner

4. Open the Arduino Application.
8 06

sketch_apr24a | Arduino 1.6.3

sketch_apr24a

vold setup() {
// put your setup code here, to run once:

}

void loop() {
/4 put your main code here, to run repeatedly:

}

[T-0- - Y ST NN

Arduino Yiin on /dev/cu.uskserial-DNOOD2X0O

Manufactured by RF Digital Corp. - Support: support@RFduino.com 9
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RFduino Installation on Mac OS X

5. Go to Edit Preferences, and add http://rfduino.com/package_rfduino_index.json to
Additional Board Manager URLs and save.

o0 Preferences

Sketchbook location:

[ 1Users /steve/Documents /Arduino | | Browse |

Editor language: | System Default ¢_| (requires restart of Arduino)
Editor font size: ’10—| (requires restart of Arduino)

Show verbose output during: | | compilation [ | upload

Compiler warnings: |_m_|

|| Display line numbers

) Verify code after upload

|| Use external editor

™ Check for updates on startup

[E Update sketch files to new extension on save (.pde -> .ino)

™ save when verifying or uploading

Proxy Settings

Server (HTTP): Port (HTTP): | BOBO
Server: (HTTPS) Port (HTTPS): | 8443
Username: Password:

Additional Boards Manager URLs: http://rfduine.com/package_rfduino_index.json

More preferences can be edited directly in the file
fUsers/steve/Library/Arduinol5/preferences.txt
{edit only when Arduino is not running)

| ok | | Cancel |

Manufactured by RF Digital Corp. - Support: support@RFduino.com 10
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RFduino IDE Installation on Mac OS X

6. Go to Tools > Board > Board Manager... to open the Board Manager. A list of various
Boards will show in alist. Scroll down until you see RFduino Boards by RFduino. Click
on this Item to highlight it. Once selected, an option on the right will appear to install the
RFduino library. Clicking this will install the latest RFduino library by default. Once
installed, you can close the Board Manager Menu.

Arduino File Edit Sketch BEEIEY Help
Auto Format
Archive Sketch

Fix Encoding & Reload
Serial Monitor {H3EmM

®T

> Boards Manager...
Port

Arduino AVR Boards
Programmer »  + Arduino Yin
Burn Bootloader Arduino Uno
Arduino Duemilanove or Diecimila
Arduino Nano
3 Arduino Mega or Mega 2560
‘b Arduino Mega ADK
6 void Loopdd { Arduino Leonardo
/4 put your main code here, to run repeatedly: Arduino Micro
Arduino Esplora
Arduino Mini
Arduino Ethernet
Arduino Fio
Arduino BT
LilyPad Arduino USB
LilyPad Arduino
Arduino Pro or Pro Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor

sketch_apr 4a

1 feoid setup(d {
s put your setup code here, to runm once:

Manufactured by RF Digital Corp. - Support: support@RFduino.com 11
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RFduino IDE Installation on Mac OS X
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800

Eoards M

Type | All 3]

Filter your search...

More infg

Boards included in this package:
Arduing Dee.
More infg

Intel ISB6 Boards by Intel
Boards included in this package:
Galiles.

More infa

Inteli6B6 Boards by Intel
Boards included in this package:
Edison.

More infa

RFduino Boards by RFduino
Boards included in this package:
RFduing.

More infg

‘Cantrol, Arduing Robot Mataor,

Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino

[ 230 3] [ Instal |

8006

Boards Manager

Type | All

Contrel, Arduine Robat Motor.
Mo infg

Boards induded in this package:
Arduing Due,
More infg

Intel iS86 Boards by Intel
Boards indudad in this package:
Galllea.

More infg

Intel 686 Boards by Intal
Boards induded in this package:
Edison,

Hore infg

RFduino Boards by RFduino version 2.3.0 INSTALLED
Boards included in this package:

RFduing.

More infg

Arduine SAM Boards {32-bits ARM Cortex-M3) by Arduino

Manufactured by RF Digital Corp
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RFduino IDE Installation on Mac OS X

7. Go to Tools > Board menu, and select RFduino. With RFduino selected as the Board,
you may now view the RFduino BLE, GZLL, and NonBLE Examples in the File >
Examples drop down list.

Arduino File Edit Sketch BTSN Help
Auto Format
Archive Sketch

Fix Encoding & Reload
Serial Monitor TEM

BT

Boards Manager...

Port
Arduino AVR Boards

» Arduino Yan
Arduino Uno

Programmer
Burn Bootloader

sketch_apr2da

RFduino

www.RFduino.com * sales@RFduino.com
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Tel: 949.610.0008

1 |poid setup() {
2 // put your setup code here, to run once:
3

41

5

6 wvoid loop() {
iV £/ put your main code here, to run repeatedly:
8

9}

Arduino Duemilanove or Diecimila
Arduino Nano

Arduino Mega or Mega 2560
Arduino Mega ADK

Arduino Leonardo

Arduino Micro

Arduino Esplora

Arduino Mini

Arduino Ethernet
Arduino Fio

Arduino BT

LilyPad Arduino USB
LilyPad Arduino
Arduino Pro or Pro Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor

RFduino Boards
RFduino

RFD22301
RF Digital
RF Module

® Arduino G Edit Sketch Tools Help
New EN

Open...
Sketchbook
Examples
Close BwW 02.Digital

Save 3 03.Analog

Save As... RS 04.Communication
Upload ®U 05.Control

Upload Using Programmer (03U 06.Sensors

Page Setup 08P 08 Swings

Print ®e 09.USB
- 10.StarterKit
ArduinolSP

01.Basics

07.Display

) 2 26 2o A8 8 28 A 8 /S

std 10000 {
’ /7 put your rain code here, to ren Bridge

3:) Esplora
Ethernet
Firmata

GSM
LiquidCrystal
Robot Control
Robot Motor
SD

Stepper

o 4 RFAUInOBLE
RFduinoGZLL
RFduinoNonBLE
Servo

Nl

Wire

VoV -V V- VR VYV V- V-V VWV WV

8. Congratulations, you are now ready to program the RFduino!
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RFduino USB Driver Installation on Mac OS X

1. Visit the following link: http://www.ftdichip.com/Drivers/VCP.htm

2. Download and install the drivers for your system

3. On Mac OS X you should have a new com port called “/dev/tty.usbserial-xxxxxxxx”

® Arduino File Edit

Sketch BELIEE Help

Auto Format 8T
Archive Sketch

Fix Encoding & Reload
Serial Monitor - ¥8M

8. 00 sketch_marl

sketch_marlSa

void setup() { Board s =
/¢ put your setup code here, to run _ /deV/tty.BIuetooth-lncomlng-POft
/dev/cu.Bluetooth-Incoming-Port

¥ Programmer » /dev/tty.Bluetooth-Modem

void loop() { Burn Boatloader /dev/cu.Bluetooth-Modem

/¢ put your main code here, to run repeatedly: | v /dev/tty.usbseriaI-DC008L3J
/dev/cu.usbserial-DC0O08L3)

RFduino on /dev/tty.usbserial-DCO08L3)

Manufactured by RF Digital Corp. - Support: support@RFduino.com
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RF Module

RFD22102 RFduino DIP is based on RFD22301 SMT

RFD22301 RFduino SMT Module

RFD22102 RFduino DIP

Plugs directly
into breadboards

The RFD22301
compliance approved
SMT module is placed
onto a DIP board to
create the RFD22102
RFduino DIP form factor.

19

18

17 GPIO1
16 GPIOO
15

14 RESET —
13 +3V ——
12 GND—
1"
10

NGB WN-=

GND
GND
GPIO2
GPIO3
GPI04
GPIOS
GPIO6
GND

CONONHBWN=

CE, ETSI, IC, FCC
Approved & Certified

GND

GND

GPIO1
GPIO0/AREF
FACTORY
RESET

+3V

GND

EXT ANT (RFD22302)
GND

GND

See RFD22301 datasheet at:

http://www.RFDigital.com/
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