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About Producer 

The manufacturer retains the right to make amendments to this manual in connection with improvements made to Sound Cleaner II design 
without special notification. 
Any such amendments will be published in a new edition of the Sound Cleaner II manual and on the company’s website: 
http://www.speechpro.com. 
 
We welcome your feedback, questions and concerns regarding Sound Cleaner II. 
If you have any questions concerning the use of this product, please contact Speech Technology Center’s technical support service or your 
regional dealer. 
 

For technical support: 
St. Petersburg 
Phone: +7 (812) 325-8848  
Fax:       +7 (812) 327-9297 
support@speechpro.com 
http://speechpro.com/support_form  
 

Moscow 
Phone: +7 (495) 623-5505  
Fax:       +7 (495) 623-5505 
kdo@speechpro.com 
 

 

Help us assist you by having the following information ready: 
• Problem description; 
• Product name and model/version number; 
• Software name/version number; 
• Computer configuration; 
• Operating system name/version number. 

 
 
 

http://www.speechpro.com/
mailto:support@speechpro.com
http://speechpro.com/support_form
mailto:kdo@speechpro.com
mailto:kdo@speechpro.com
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INTRODUCTION 
This Guide describes Sound Cleaner II noise cancellation and speech enhancement software. 

The Guide does not substitute any academic or reference books, operating system manuals or other sources of information. 

Typographic conventions 
The manual uses the following typographical conventions: 

Formatting Description 

Italic 
Indicates the first appearance of a term. Meaning of the term is explained here 
or in the appendix. Also it is used to attract attention or to make up notes. 

Bold 
Indicates names of construction and software components, names of controls 
and interface elements (headers, buttons, etc.). 

Bold italics Indicates file names and access paths. 

 

Menu selection is marked in the following way: Menu > Command. It means: select Menu, then Command. 

 

The manual uses the following notification symbols: 

   Note: indicates important information that helps you make better use of the product. 

 

     Caution: informs you about potential problems with hardware or software. 

 

   Warning: warns you about potentially serious problems in certain situations and tells you how to avoid them. 
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Trademarks 

The names Windows®, Windows® 7 and Windows® 8 are trademarks of the Microsoft® Corporation. 
The name Adobe, the logotypes Adobe, Acrobat, Adobe PDF and Reader are trademarks of the Adobe Systems Incorporated. 
All other company and product names mentioned in this document are the property of their corresponding owners. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
No part of this manual may be reproduced or transmitted in any form, stored in a searchable system or translated into any language without the written consent of 
Speech Technology Center. 
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1  GENERAL INFORMATION 
1.1 About the Product 

Name Sound Cleaner II 

Description Comprehensive audio restoration software 

Model STC-S630 

Producer Speech Technology Center, Ltd. 

Address Russia, St. Petersburg, Krasutskogo str. 4a, 196084 

Phone +7 (812) 325-88-48 

Fax +7 (812) 327-92-97 

Email support@speechpro.com 
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2  PROGRAM FUNCTIONS AND CONTEXTS OF USE 
2.1 Program Features 

Sound Cleaner II is the software intended for noise reduction and for improvement of audio signals’ quality and speech intelligibility and 
sounding. 
 

The software performs the following tasks: 
• Opens audio and video files; 
• Improves audio signals’ quality and speech intelligibility; 
• Identifies literal content of low-quality speech recordings; 
• Automatically creates text reports about speech signal processing.  

 
The following noise reduction filters are implemented within the software: 
1. STC Auto Filter; 
2. Broadband Noise Filter; 
3. Tone Suppressor; 
4. Click Suppressor; 
5. Inverse Filter; 
6. DTMF Suppressor; 
7. Cellphone Noise Filter; 
8. Reverb Suppressor; 
9. Clip Restorer; 
10. Dynamic Range Control; 
11. Reference Noise Filter; 
12. Equalizer; 
13. Amplifier. 
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2.2 Program Functions 

Sound Cleaner II performs the following functions: 
1. Opens audio and video files of different formats. 
2. Noise reduction and distortion compensation of various types including: 

• stationary and slowly varying additive multi-component narrowband (polyharmonic) and broadband noise; 
• slowly varying amplitude and frequency distortion (bandpass flatness of audio recording or sound transmission channels); 
• reverb distortion; 
• short-term impulse noise; 
• cellphone noise; 
• dual-tone multi-frequency signaling (DTMF); 
• significant edges in a signal; 
• waveform restoring of signals recorded with amplitude overloading; 
• additive noise in two-channel audio stream. 

3. Organizes noise reduction modules as independent blocks to arrange the filtration sequence. 
4. Saves filters’ settings and its sequence as a file to restore the configuration and to use it again. 
5. Adjusts filters’ settings observing the waveform’s and instantaneous spectrum’s images before and after processing. 
6. Changes playback speed without distortion of the absolute pitch. 
7. Loop playback of the entire signal, signal fragments or from the current cursor position. 
8. Enters text with using the built-in text editor for text transcription of audio signals. 
9. Automatically saves the entire file processing history within the project. 
10. Creates a complete report about performed work. The report is created in HTML format and contains information about the 
organization, file and expert; it also includes images of source and processed signals’ waveforms, its spectrums, information about used 
filters with settings, about changes made in the signals and their text transcriptions. 
11. Saves parameters of signal processing to use them afterwards. 
12. Automatically synchronizes main signal and asynchronous reference channel for further processing with using the reference noise 
filter. 
13. Adds Sound Cleaner II as the VST plug-in (of VST3 format) to apply it within the other sound editors (Adobe Audition, Sound 
Forge, Wave Lab, etc.), with the Pro Tools software and hardware system. 
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   Sound Cleaner II within the Microsoft Windows 8 operating system environment cannot run as the VST plug-in. 
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3  GETTING STARTED 
3.1 System Requirements 

Your computer should meet the following configuration requirements for correct installation and using the software: 
• Intel® Core™ 2 Duo processor with a clock frequency of 2.66 GHz; 
• Free disk space on the hard drive at least 1 GB; 
• Operating system (OS): Microsoft® Windows® 7 / 8 not lower than the Professional version, Mac OS X (32 or 64 bit); 
• RAM volume of at least 1 GB; 
• CD-ROM drive 48× (in case of CD-ROM product delivery); 
• SVGA video adapter and monitor with minimum screen resolution of 1280 × 1024 pixels and 32 bit color quality; 
• Keyboard and mouse; 
• Speakers and/or headphones. 

 

   To activate the software, connect a PC to the Internet. 

 

3.2 Delivery Set 

Sound Cleaner II is available for order as a boxed version and an electronic download. 
Boxed version comes in a software hard box that contains a software CD and a hardware license key, a dongle. The dongle allows user to 
transfer easily the license to other computers. 

    It requires a free USB 2.0 port. 

Electronic download comes as a download link and a registration key to your e-mail. The software can be activated on one computer only. 

    To reactivate the software (when reinstalling the operating system on a PC), please contact our technical support. 
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3.3 Software Installation 
 

    To install the Sound Cleaner II software successfully within the Microsoft Windows 7 / 8, Mac OS X operating system environment 

and to register it, the user must have write access to the system registry (as administrator). 

 

    The Sound Cleaner II software cannot be installed on virtual machines because the licensed system software does not run on virtual 

machines. 
 
To install the software, launch Setup.exe file at the root distribution’s directory. Select the installation language. 
The Setup Wizard will detect the presence of the software prerequisites and, in case of its absence, prompts you to install them as the first 
step (Fig. 1). 
If some prerequisites have been previously installed, they do not need to be reinstalled and will not be displayed in the dialog box. 
To install the prerequisites, click Install and wait until the installation is complete. It may take some time. To exit the prerequisites installation, 
click Exit. 

      At the first installation of the licensed Sound Cleaner II software, a trial version is installed as well. 
The trial license is valid for 28 days from the program launch and has the following functional limitations: it operates on the Preview 
mode only, the user can process a signal (realize filtering) just for 30 seconds, but the result cannot be saved. 
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Figure 1. Installing prerequisites 

If the prerequisites have been installed, you will see the Setup Wizard dialog box. Follow the Wizard’s instructions to proceed the installation. 
After the installation is complete, you will see the message box informing that the Sound Cleaner II has already been installed. Click Exit. 
By default the program is launched from the menu Start > All Programs > Speech Technology Center > Sound Cleaner II. 
 

3.3.1 Installation Troubleshooting 

If the Sentinel SL key has already been installed and initiated before installing the Sound Cleaner II software, an error message may appear. 
Stop the HASP Loader service and restart the installation. 

To stop the HASP Loader service, use one of the following methods: 
1. Launch the command prompt and run: net stop "HASP Loader". 
2. Stop the service using standard tools of operating system: 
– In the Start menu select Control Panel > Administrative Tools > Services. 
– Click the right mouse button on the HASP Loader service and select Stop.  
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3.4 Software Registration 

    To install the Sound Cleaner II software successfully within the Microsoft Windows 7 / 8, Mac OS X operating system environment, 

the user must have administrator rights. 

The product is delivered with the registration key which is a combination of 20 digits. 
After installation the software is available in the demo mode. To activate the operating mode you need to register the software. When you 
start the program, the initial registration screen appears (Fig. 2). If you have the trial version installed on your PC, you might purchase the 
license on the manufacturer web site. Click the Purchase Now button in the initial screen. 

 
Figure 2. Initial registration screen 
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If your PC is connected to the internet, click the Activate button in the initial screen. You will be redirected to the Sentinel online activation 
page on the STC web site. You should enter 20 digits of the registration key and the Login button (Fig. 3). Then click the Online Activation 
button to go to the next registration page (Fig. 4), and your copy of the software will be activated. 

 
Figure 3. Entering the product key 

 
Figure 4. Online and offline product activation 
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If your PC is not connected to the internet, click the Register Offline button in the initial screen. The special utility will be launched to provide 
you creation of a c2v file to activate the product. Then follow the instructions shown in the Collect Status Information  tab of the 
activation utility (Fig. 5). 

 
Figure 5. The Collect Status Information tab of the activation utility 

Performing the activation instructions you will be redirected to the pages where you should generate a v2c file and download it to your PC 
following the instructions. 
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Figure 6. A v2c file generating 
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Figure 7. The v2c file is generated successfully 
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Go to the Apply License File  tab of the activation utility and complete the activation following the instructions shown at the figure 5 or at 
the Collect Status Information  tab. 

 
Figure 8. Uploading the v2c file 

 

 
Figure 9. Applying the v2c file 
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After a complete product registration you will see the software’s main window. 
If you cancel the immediate software registration it will run in the trial mode. The user might register the software later via the initial screen. If 
the trial license has already expired, the initial screen will not be shown. Then go to the folder where the software was installed (it is \Program 
Files (x86)\Speech Technology Center\SoundCleaner II\Activation by default) and launch the utility file SafeNetRUS_SC2.exe manually. Follow 
the instructions in the utility window. 
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4  GENERAL OPERATION PRINCIPLES 
4.1 Scheme Creation Principles 

To filter a signal, the user creates the processing scheme with using the particular filters. 
Each filter on the scheme affects the signal in accordance with a certain algorithm and then passes it to the next filter in the chain. So the 
noise reduction filters operate as independent blocks and realize successive signal processing. 
The number of used filters in the scheme to process one signal is unlimited. 
The user uploads a file with the signal to be processed. This is the source signal. 
Right away after uploading the software generates a working signal from the source signal. This working signal is displayed on the screen as a 
waveform. So, at first, the working signal coincides with the source one. 
 

4.2 Preview Mode 

The software features a preview function. So the signal is displayed with applying the current filtration scheme. 
If the Preview mode is on, the filtered signal is drawn over the source one. Working in this mode you are able to playback the selected 
fragment with the applied filters. The signal will be drawn gradually according to the filtering process implementation. Also, if the Preview 
mode is on, all changes in the scheme are immediately considered in the drawing. 
After the Preview mode is switched off, the waveform of the changed signal will be visible until you apply the selected filters (in this case the 
working signal is changed according to the filtration scheme), or until the Preview mode is switched on again (in this case the changed signal 
will be drawn again). But in this mode the signal will be played without applying the current filtration scheme. 
In the Preview mode you can add or remove filters, change their settings, so that these changes affect the played signal right away. 
In the Preview mode the filtered waveform is displayed over the working signal’s waveform with another color, and the waveforms are 
synchronized in time. 
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4.3 How to Arrange Filters 

The user conjectures the sequence of filters that are suitable to process a signal considering the shape of its waveform, and also by listening 
to this signal. The user puts the filters in the processing chain (processing scheme) according to the selected order. 
There are two ways to display the processing chains in the main window: with showing the filters’ dialog boxes including all their settings 
(complete scheme), or with using the filters’ icons (navigation scheme). 
In the general case the software processes left and right channels of a stereo signal separately. Depending on what channel needs to be 
processed (left or right), please drag the selected filter to the area of left or right channel processing respectively. To apply a filter for both 
channels simultaneously, select All Channels from the filter’s context menu. So the filter intended to process both channels will be collocated 
in the middle among the left and right channels’ chains. 

    The Equalizer filter is not applicable to process both channels at the same time, so it is applied separately for left and right channel. 

 

4.4 Saving File and Scheme 

You may to listen to a signal previously with having applied the selected filters, but without changing the signal. Then, after having selected 
the filters, they are applied to the working signal or to its selected fragment. And the changed signal can be saved to a file. 
The user can save the created filtration scheme to use it later. The filtration sequence and the filters’ settings are saved in the scheme. If saving 
the scheme as a preset, the user can add an audio file to the scheme as an example. 
To ease learning and to help you to use the software’s features with the maximal efficiency, we have added some embedded noise reduction 
schemes as the presets containing the samples of distorted audio files. 
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5  GRAPHICAL USER INTERFACE 
5.1 Main Window 
The Sound Cleaner II main window is shown on the figure 11. 
 

The program’s main window consists of the following parts: 
1  Main menu; 
2  Data window containing waveform of the processed signal; 
3  Status bar; 
4  Playback control panel; 
5  Filtration Scheme panel combining three tabs: Filters, Presets and History; 
6  Navigation processing scheme: the panel holding the filters’ icons; 
7  Complete processing scheme which holds the filters’ dialog boxes. 

 
The information bar to the right shows the message icon the user may see during the signal processing (see section 5.3 Status Bar). 
The sizes of all filters’ dialog boxes, except the Equalizer, are fixed and cannot be changed. 
Also, the user can open the Transcriber module which will occupy an area within the main window (see section 12 TEXT TRANSCRIPTION). 
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Figure 10. Sound Cleaner II main window 

 
 

Message box 

Disabled filter 

Enabled filter 
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5.2 Player Interface 

The playback control panel provides playing and processing of audio files (Fig. 11, pos. 4). 
During the file playing the current time of a played audio file is displayed on the left of the control panel. 

Playback control buttons allow you to perform the following operations with files: 
Button Description 

 
To play the selected file. 

 
To pause playing the file. 

 
To stop playing the file. 

 To turn on/off the Preview mode of playing the audio file with applied filters. 

 
To turn on/off Loop playback. 

 
To change the signal applying a processing scheme. 

 /  
To mute/restore volume in the channel. 

 /  
To turn on/off synchronous volume control in the channels. 

The Filtering and Preview buttons are disabled until the user begins to form a filtering chain to process the audio file. 

Buttons  and  are interchangeable. 
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5.2.1 Playback Control 
Playback and pause control is realized by means of the following ways: 
• with using the playback control panel; 
• with the main menu commands; 
• with pressing the Space key. 

 

      When the Transcriber module’s window is open, the Space key is not applicable regardless of which window is active. In this case use 
Ctrl+Space shortcut. 

 

If the cursor was put or a fragment was selected within the signal, the playback begins from the cursor’s position or into that fragment. 
Press Esc to remove the cursor/selection. 

 

     Sound Cleaner II operates with the default installed sound card. To make the program start working with a new card, you must restart 
Sound Cleaner II. 
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5.3 Status Bar 

 
Figure 11. Status bar of the main window 

The status bar is located below the signal waveform. 
 
The following data of audio files are displayed in the status bar from left to right: 
• bit depth; 
• sampling rate; 
• number of channels: mono or stereo; 
• total recording duration in the “mmm : ss . msmsms” format; 
• beginning of the selection; 
• end of the selection; 
• duration of the selection into the square brackets. 

 
The message icon is shown to the right in the status bar to display the notifications the user may see during the signal processing. 
 

To see previously displayed messages perform one of the following actions: 
1. Left click on the icon. 
2. Select the View > Show Notify List command. 
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6  WORKING WITH AUDIO FILES 
6.1 Opening audio files 

The software opens audio files and audio streams of video files of the most common formats such as: WAV, MP3, WMA, AVI, OGG, AIFF, 
FLAC, etc. 
 

   A complete list of supported formats can be found on the website: http://ffmpeg.org/general.html. 

 

To open a file, follow these steps: 

1. Choose the File > Open... command in the main menu or press the Ctrl+O shortcut. You may previously listen to the signals from the 
files you want to open. 

2. Select a file and click the Open button in the Open File dialog box. 

 

The file content will be shown as the waveform into the data window (Fig. 13). 

The file information will be displayed in the status bar below the waveform. 

 

6.2 Displaying Signal in the Data Window 
6.2.1 Data Window Areas 

 

In general, the data window consists of the following areas (Fig. 13): 

1  tab of the opened file; 

2  waveform scaling pictograms; 

3  navigation waveform; 

4  full-size waveform; 

5  horizontal scroll bar. 

http://ffmpeg.org/general.html
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Figure 12. Data window 

 

6.2.2 Opened File Tab 

This tab shows the name of the opened audio file. Also it contains the  button to close this tab. 
If you choose another file, a new tab appears into the data window and becomes active. 

To activate another file tab, left click its title. 

6.2.3 Navigation Waveform 
The navigation waveform represents the signal’s part visible into the data area of the main window. 

The signal’s part visible into the window is highlighted on the navigation waveform. Also, any changes of its horizontal size or horizontal scale 
shifting are displayed on the navigation waveform. 

You can enlarge or reduce the signal fragment visible into the window with using the navigation waveform (Fig. 14, a). To do this, move the 
cursor to the edge of the highlighted area at the navigation waveform until you see the bidirectional arrow. Keeping pressed the left mouse 
button drag the border to the desired position. The horizontal scroll box will change its size accordingly. 

To move the data visible in the window to another position at the horizontal scale, move the cursor to the highlighted area at the navigation 
waveform until it assumes the form of the open palm. Keeping pressed the left mouse button while the cursor has this shape, move the 
highlighted area to the desired position within the signal (Fig. 14, b). 

The navigation waveform allows you to set quickly the area of data visible in the window anywhere within the signal. To do this, move the 
cursor to the beginning of the data area. Keeping pressed the left mouse button, move the cursor to the end of the data area (Fig. 14, c). The 
horizontal scroll box will change its size accordingly. 
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a)   b)   c)  
Figure 13. Size changing (a), moving the highlighted area (b) and selecting the visible data area (c) on the navigation waveform 

 

   To scroll the signal visible in the window you may also move the cursor to the horizontal or vertical scale and press the Ctrl key (or the 

Cmd key when working on the Mac OS X) and rotate the mouse wheel. 

 

6.2.4 Signal Waveform 
The signal waveform allows you easily observe the entire signal and any part of it as well. 

The horizontal axis shows the current time from the beginning of the signal in seconds, and on the vertical axis you see the signal amplitude 
in samples. 

Move the cursor to the horizontal or vertical scale and rotate the mouse wheel to change the data area. 

 

To display the entire signal horizontally, use one of the methods: 
1. Select the View > Horizontal auto-zoom menu item. 
2. Press the F8 key. 
3. Click the  pictogram above the navigation waveform. 

 

To display the entire signal vertically, use one of the methods: 

1. Select the View > Vertical auto-zoom menu item. 

2. Press the F7 key. 

3. Click the  pictogram above the navigation waveform. 
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To make the amplitude be represented not with the samples but with decibels, use one of the methods: 

1. Select the View > In dB menu item. 

2. Select the In dB item in the context menu of the vertical scale. 

3. Press the F5 key. 

 

6.3 Selecting Signal Fragment 
To select the signal fragment, follow these steps: 

1. Place the mouse cursor to the beginning of the fragment. 

2. Press the left mouse button and holding it move the cursor to the end of the fragment. 

3. Release the left mouse button. 

The selected fragment will be highlighted in a different color and bounded with two vertical dotted borders (Fig. 15, a). 

a)    b)  

Figure 14. Shifting the selected fragment’s borders (a) and the vertical cursor (b) 

To move selected fragment’s border, follow these steps: 

1. Move the mouse cursor to the border until it assumes the form shown in the Figure 15, a. 

2. Keeping pressed the left mouse button drag the border to the desired position. 

The vertical cursor might be moved the same manner (see Fig. 15, b). 
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6.4 Editing Data 
You can perform the following editing operations: 

• Undo allows you to cancel the operation you made to change the signal. 

• Redo allows you to recover the cancelled operation. 

• Delete removes the selected signal fragment. 

• Trim removes all other data except the selected fragment. 

Use the Signal Shift Left menu item or Ctrl+Shift+Left shortcut to shift the entire signal to the left along the horizontal scale by the size of 
the selected fragment. 

Use the Signal Shift Right menu item or Ctrl+Shift+Rgiht shortcut to shift the entire signal to the right along the horizontal scale by the size 
of the selected fragment. 

 

6.4.1 Dividing Stereo Signals 
To divide a stereo signal to two mono signals, open the stereo signal and select Edit > Divide stereo to two mono or press the Ctrl+2 
shortcut. 

The result of this operation (two separate mono signals extracted from the left and right channels of the original stereo file respectively) 
(Fig. 16) will be displayed at the new tabs for each signal. You can choose a tab with the mono signal you need and save it as a file. 

 
Figure 15. Data window. There are tabs of the original stereo signal, of the mono signals extracted from its left and right channels 
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6.4.2 Creating Reference Channel 
One of the distinctive features of the Sound Cleaner II software is the stereo filtering with using the asynchronous reference channel. 

The most laborious procedure of asynchronous filtering is the creation (synchronization) of the reference signal, i.e. the procedure of 
alignment the beginning and end of the main and reference signals. 

The main channel which contains useful signal and noises (for instance, music) is the user’s source recording. 

The reference channel is the “pure” noise (for instance, music) obtained from another source (for instance, a recording from CD). 

The asynchronous filtering may be applied in the case if a single-channel recording made through a microphone contains the speech signal 
distorted with a noise from a musical composition played indoors through acoustic speakers, i.e. when there is a speech mixed with music or 
any track that can be obtained later, but not during recording. In this case, it is impossible to carry out adaptive filtering (as in the 
synchronous case), because the second signal (noise) is absent. However, knowing what music was that noise, you can get it from an external 
source, for example, read from CD, computer disk, the Internet, etc. 

 

The asynchronous filtering consists of two successive procedures: 

1. Synchronization of main and reference signals. 

2. Noise suppression by means of stereo filtering. 

 

The synchronization includes the following operations: 

1. Reduction to the same sampling rate (performed automatically). 

2. Rough definition of the beginning of speech in the main signal and of the corresponding point in the reference signal (carried out by 
the user). 

3. Rough definition of the end of speech in the main signal and of the corresponding point in the reference signal (carried out by the 
user). 

4. Precise alignment of the beginning and end of speech (performed automatically). 
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To perform stereo filtration using the asynchronous reference channel, select the Edit > Create reference channel menu item or press 
the F11 key. 

 

   The software does not support processing of stereo and 32-bit signals when creating the reference channel. The maximal duration of a 

processed signal cannot be more than 30 minutes. 

 

      In the reference channel creation mode the signal editing operations are unavailable (except Shift signal left/right commands). 

 

A new Reference Channel tab containing two empty windows will appear into the data window. The upper window is for the main signal 
(useful signal with noise), and the lower one is for the reference signal (noise) (Fig. 17). 

1. Load the useful signal (speech with noises) into the upper window (for the main channel): 

• Click the Browse... button (Fig. 17). 

• Select a signal you need in the Open File dialog box. 

Thus, the main signal will be displayed into the upper window. On the right you will see the information about the loaded signal: file name, 
sample rate and duration. 

2. Click the Next button to proceed. 

 

   When opening make sure that the files you want to process have sufficient duration, because there are some limits for minimal duration of an 

audio fragment (22 s with sample rate of 4000 Hz, 18 s with sample rate of 8000 Hz, 16 s with sample rate of 11 025 Hz, and 11 s with sample rate of 
22 050 Hz). 
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Figure 16. Creation of the reference channel. Loading the useful signal (speech with noises) 

3. Load the signal (containing noises) to the lower window for the reference channel (Fig. 18). 

 

     After having determined the reference channel, the main channel cannot be changed. 

 

The reference signal will be displayed into the lower window. On the right you will see the information about the loaded signal: file name, 
sample rate and duration. 

4. Click the Next button to proceed. 
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Figure 17. Creation of the reference channel. Loading the noise 

5. Carefully listen to the main signal, observe it using the waveform extension to see details, and shift the signal along the time line to find 
the beginning of speech into the main signal; place there the mark of beginning (Fig. 19). There is no need to indicate the position 
precisely, just determine the position roughly accurate to 0.5 … 1 s. 

6. Carefully listen to the reference signal, observe it using the waveform extension to see details, and shift the signal along the time line to 
find the respective point at the reference signal; place there the mark of beginning (Fig. 19). 

7. Click the Next button to proceed. 
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      Usually it is not too difficult to determine the beginning of speech within the main signal (speech with music). It is much more difficult 
to determine the respective point at the reference signal. Short, similar to each other, signal fragments on the waveform might be 
useful to find it, for example, it could be abrupt amplitude bursts along the time line (visual determination). To find out what fragment 
is appropriate (for instance, a noisy song may include long similar breaks, so it is not easy to understand what time corresponds to the 
speech beginning), that is why you might need to shift the reference signal and listen to the different fragments over and over again. 

 

 
Figure 18. Creation of the reference channel. Placing the marks of the signals’ beginning 
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8. After having listened to the main signal’s end, having observed its waveform along the time line, and having placed the mark of the 
signal’s end, find the respective fragment into the reference signal and place there the signal end mark too (Fig. 20). 

9. Click the Next button to proceed. 

 
Figure 19. Creation of the reference channel. Placing the marks of the signals’ end 

 

 

 

 

 

 



41 
WORKING WITH AUDIO FILES Sound Cleaner II 

  User Guide 
 

 

10. Synchronize precisely the beginning and the end of the respective fragments at the main and reference signals. If you are not satisfied 
with the result, go back and reset the marks. If you suppose that the software has realized automatic adjustment not very well, uncheck 
the Automatically tune border marks box. In this case the manually placed marks will be used. 

11. Click the Next button to process the data. 

 
Figure 20. Creation of the reference channel. Performing the precise signal synchronization 

 

 

 

 

 



42 
WORKING WITH AUDIO FILES Sound Cleaner II 

  User Guide 
 

 

12. After having done the precise synchronization, in case if the respective fragments were aligned correctly, click the Finish button to 
save the result of this operation to a stereo file. 

 
Figure 21. Creation of the reference channel. Saving the result to a stereo file 
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You will see the new tab of the created signal into the data window (Fig. 23). 

  
Figure 22. Creation of the reference channel. Displaying the created signal 

13. Clear the signal with the Reference Noise Filter. 
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6.5 Copying Data to the Clipboard 
The program allows you to copy the selected area of the screen within the main window or a window containing the entire signal (data) to 
the clipboard for making reports. 

 

To copy a screen area, follow these steps: 

1. Select the Service > Copy Screen Area menu item. The cursor assumes the form of +. 

2. Move the cursor to the interesting point on the screen, and holding down the left mouse button select the desired area (the area will 
be highlighted with a different color). 

3. Release the left mouse button. The selected area of the screen will be saved to the clipboard. 

4. In a text editor place the cursor to the position where you want the copied screen area to be inserted. 

5. In the text editor select the Insert command, and the copied screen area will be inserted as a figure to the position you indicated. 

 

To copy a signal window, follow these steps: 

1. Select the Service > Copy Window Image menu item. 

2. In a text editor place the cursor to the position where you want the copied window image to be inserted. 

3. In the text editor select the Insert command, and the entire copied window image containing the signals (data) will be inserted as a 
figure to the position you indicated. 
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6.6 Drawing and Erasing a Signal 
The software allows you to edit the shape of signal oscillograms in the “Drawing/Erasing” mode. To enable this mode, click the right mouse 
button in the data window and select the Draw/Erase item in the context menu. The cursor assumes the shape of a “pencil”. 

Press and hold the left mouse button, and move the cursor in the “Drawing” mode to draw a continuous line, which will replace the previous 
signal representation. 

Press and hold the right mouse button. The cursor assumes the shape of a red square, of an “eraser”. Move the cursor within the data window 
in the “Erasing” mode to erase a part of the signal. Thus, the part of the signal within the square’s frames will be erased, i.e. the line 
representing the signal amplitude will be shifted to zero within this fragment. 

Press Esc to disable the “Drawing/Erasing” mode. 
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6.7 Getting Signal Properties 
To obtain the information about the signal from the active tab within the data window, select the File > File info menu item or click the right 
mouse button in the data window and select the File info item in the context menu. 

The Signal Properties dialog box will appear (Fig. 24) displaying the detailed information of the file properties. 

You may copy this information to the clipboard and paste it to a text report. To do it, click the Copy button in the Signal Properties dialog 
box. 

Click OK to close the dialog box. 

 
Figure 23. Signal Properties window 
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6.8 Saving Audio Files 
To save the audio file, select the File > Save As... menu item or press the Ctrl+Shift+S shortcut. 

The saving dialog box will appear. You should specify there the folder and file name and then click the Save button. 

 

6.9 Closing Audio Files 
To close all the audio files loaded into the data window, select the menu item File > Close All. 

 

 

 

 



48 
CREATING THE PROJECT Sound Cleaner II 

  User Guide 
 

 

7  CREATING THE PROJECT 
All the operations you performed can be saved to a project which contains the entire information about changes made to the audio file. 
You may save to the project all the filters applied to the file, the equalizer adjustments, comments, etc. 
The project is created automatically when the first signal change (editing, processing or filtering) is done. 
Each signal loaded to a project can be saved to a separate file (see section 6.7 Saving Audio Files). 
 
If some data obtained during the processing were not saved previously, when you close the data window and/or shut down the program the 
dialog box appears warning about the unsaved data and offering to save them. 
Thus, the project will be created; it will include a file with .scpj extension and a folder with .scpjd extension which contains the project 
information. 
 
To save the project during the working with the software, select the File > Save Project menu item or press the Ctrl+S shortcut. 
Specify the path and file name to save the project into the saving dialog box and click the Save button. 
 
To open the project, select the File > Open Project... menu item. 
Select a previously saved project file and click the Open button. 
The saved project data will be loaded (with audio file, processing scheme and other user settings). So the user may continue working with the 
saved file from the last operation. 
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8  WORKING WITH A SCHEME 
8.1 Complete Scheme of Signal Processing 
A complete scheme of signal processing is the sequence of different adjusted filters. You can apply it to any signal fragment or to the whole 
signal. 

The chains of signal processing are displayed in the main window with two ways: with showing the filters’ dialog boxes including all their 
settings (complete scheme) (Fig. 25, pos. 2), and with using the filters’ icons (navigation scheme) (Fig. 25, pos. 1). 

Each filter has its own dialog box. 

Initially the filters are enabled with the default settings. 

In the general case the software processes left and right channels of a stereo signal separately. 

To process a signal, it is necessary to arrange the filters into the successive processing chains (schemes) depending on what channel is to be 
processed (left, right or both). 

 

To process left or right channel of a signal: 

1. Choose the needed filter in the list. 

2. Drag the chosen filter with the mouse and drop it into the processing area for left or right channel. 

 

To use a common filter for two separate chains to process two channels at once, follow these steps: 

1. Select the needed filter in the list. 

2. Drag the selected filter with the mouse and drop it in the middle between upper and lower chains of the complete processing scheme. 

Or 

1. Double-click on the selected filter in the list. 

2. The filter’s dialog box will appear into the processing area of the complete scheme. Click the right mouse button to open the filter’s 
context menu and select there the All Channels item. 

   The All Channels contextual menu command is not available for the Equalizer filter. 
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To enable/disable a filter, use one of these ways: 

1. Click the switch in the filter’s dialog box. 

2. Left click on the filter’s icon into the navigation scheme. 

 

To enable/disable all the filters at the same time, select Scheme > Turn On All Filters/Turn Off All Filters. 

 

To remove the filter’s dialog box, use one of these ways: 

1. Drag the selected filer back to the list (on the left of the main window) from the complete or navigation processing scheme. 

2. Open the dialog box’s context menu with the right mouse button click and select the Remove Filter command. 
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Figure 24. Complete and navigation schemes of signal processing 
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8.2 Navigation Scheme 
Navigation scheme of filtering is a visual representation of the complete scheme of filtering with filter icons. 

The navigation scheme provides the same features on the formation of the filtration chain as the complete scheme, except changing filter 
settings. 

You may hide or unfold this scheme. To do it, check Navigation Scheme in the View menu. 

The both schemes (complete and navigation) as well as the processing history panel might be hidden. To do it, click the  Close button 

(above the navigation scheme). Then only a waveform will be shown in the main window as well as the playback control panel for better 
viewing and working with the waveform. 

To unfold the schemes and the history panel, check Navigation Scheme and/or Scheme in the View menu again. 

If a long processing chain (complete scheme) was built, not all the filters are displayed in the working area of the main window. To show any 
hidden filter into the scheme, right click on the filter icon and select Show Filter in the context menu. 

You also can close a filter’s dialog box and remove it from the navigation scheme. To do it, right click on the filter’s icon into the navigation 
scheme and select the Remove Filter command. 
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8.2.1 Saving the Scheme 

The program allows you to save the created filtration scheme as a file. The scheme includes sequence and settings of the filters. 
To save the scheme, select the Scheme > Save as... command. 
 

8.2.2 Opening the Scheme 

To open a previously saved processing scheme, follow these steps: 
1. Select the Scheme > Open... command in the main menu. 
2. Choose the needed scheme file with .schm extension in the appeared dialog box and click the Open button. 

The previously saved complete processing scheme will appear on the screen, also with the navigation scheme (see Fig. 25). 
 

8.2.3 Removing the Scheme 
To remove the scheme from the working area, select the Scheme > Clear command in the main menu. 

If that scheme was previously saved to a .schm file, this file will not be deleted. 

 

8.2.4 Saving the Preset 

The user can save (also rename and remove) the created filtration scheme (a preset) via the Preset tab into the processing scheme 
for later use. 

To save the preset, follow these steps: 

1. Select the Scheme > Save as Preset command in the main menu, or click the Save as Preset button at the Presets tab on the 
Filtration Scheme panel. 

2. In the Add Preset dialog box (Fig. 26) select the preset name and click the Apply button. 

Also, you can add a sound file as a sample to the preset. The sound file should be uploaded to the program. To add the sound file to the 
preset, in the Add Preset dialog box check the Save preset with sound file box. As a result, the sequence of filters, their configuration and 
the sound file will be saved into the preset. And the saved preset will appear on the Presets tab of the filtration scheme. 

      If the audio file was not uploaded to the program, the Save preset with sound file check box will be disabled. 
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The Presets tab also contains the embedded noise reduction schemes, the presets with the samples of distorted audio signals. These 
embedded schemes cannot be saved, renamed or removed. 

 
Figure 25. Adding the preset 

 

8.2.5 Renaming the Preset 
To rename the preset, follow these steps: 

1.  Select the Scheme > Rename Preset command in the main menu. 

2. In the dialog box (Fig. 27) select the preset you need to rename from the drop-down list, enter a new name and click the Apply button. 

 
Figure 26. Renaming the preset 

 

 

 

 

 

 

 



55 
WORKING WITH A SCHEME Sound Cleaner II 

  User Guide 
 

 

8.2.6 Removing the Preset 
To remove the preset from the Presets tab of the filtration scheme, follow these steps: 

1. Select the Scheme > Remove Preset command in the main menu, or select the Remove command in the preset’s context menu. 

2. In the dialog box (Fig. 28) select the preset you need to remove from the drop-down list, enter a new name and click the Apply button. 

 
Figure 27. Removing the preset 
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9  FILTERING 
The noise reduction filter is a tool to process the entire signal or signal fragments. In the working area of the program it looks like one of the 
blocks. The sequence of filters makes filter scheme.  

To filter the signal, perform the following: 

• Select a suitable set of filters; 

• Stop playback; 

• Click Filtering on the playback control panel or in the Process menu or press Ctrl+F4 on the keyboard. Certain filters will be applied 
to the signal.  

      Select the data processing area. The entire signal will be processed, but in case signal fragment is selected, filtering changes will be 
applied only to the fragment.  

 

9.1 Filters and their Functions 

Table 1 –Available filters. Short description 

Filter name Icon Description 

Cellphone Noise Filter  
 

Suppresses GSM interferences 

STC Auto Filter 
  

Improves recording quality by using only on slider 

Clip Restorer 
 

Restores clipped signal 

Reverb Suppressor 
 

Decreases reverberations 

Dynamic Range Control 
 

Equalizes signal in amplitude area  
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Filter name Icon Description 

Click Suppressor 
  

Filters adaptively pulse interferences  

Inverse Filter 
 

Filters adaptively strong stationary periodic noises 

DTMF Suppressor 
 

Suppress two-frequency phone numerical signals – DTMF 
signals 

Reference Noise Filter 
 

Suppress nonstationary broadband and periodical noises 

Tone Suppressor 
 

Filters adaptively stationary tonal interferences and 
individual tonal pulses 

Amplifier 
 

Increases/decreases signal level 

Broadband Noise Filter 
 

Filters adaptively broadband and narrowband tonal 
interferences 

Equalizer 
 

Represents graphically spectrum and corrects its amplitude 
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9.2 STC Auto Filter 

STC Auto Filter is a combined filter mostly based on Broadband Noise Filter. 
STC Auto Filter is used to extract speech signals from stationary interference background – broadband and narrowband tonal interferences.  
Automatic noise filtering works well to get reliable results in a short time period. It does not demand from the user any special noise-filtering 
skills and experience. 
This algorithm is designed to suppress broadband and periodic noises caused by electric pick-ups or mechanic vibrations, room and street 
noise, communication channel or record equipment interferences. 
You may hear these noises as hum, sizzle, buzz, rumbling, hisses or roars. 
It is nearly impossible to remove such noises with other methods, such as one-channel adaptive filtration, spectrum smoothing or with 
equalizer, as noises are spread across the entire spectrum and intersect with the speech signal. 
Auto Filter enables to unmask speech signal at SNR values (-5 –   -10 dB). At the same time filter suppresses noise narrowband components. 

This filter has the following advantages: 
• It works within continuous speech with a large amount of interlocutors. 
• There is no need in speech pauses. 

9.2.1 Processing Principles 

Auto Filter processes signal frame by frame. Data frame is transformed into spectrum. Then power spectral density (PSD) is estimated. If the 
frame is a useful signal pause (noise signal fragment), then current PSD is used to accumulate averaged PSD of noise. Current PSD is 
compared with accumulated noise PSD at each frequency. Signal spectrum weakens at the frequencies where current frame PSD is 
commensurable with noise PSD (as at these frequencies useful signal has no components or they are too small for an ear to unmask them). 
Signal spectral components are saved at those frequencies, where current PSD is larger than noise PSD. This procedure is called spectrum 
subtraction. 
After that a filtered frame spectrum is transformed back to the time zone. As a result we get a filtered signal. 
This processing algorithm can be compared with dynamic equalizer work, which changes its characteristics at each frame several tens of 
times per second. 
In case of using a big size frame such equalizer operation result may be interpreted as echo. Processing parameters are used to control 
equalizer operation mode (quantity of spectral bands, noise statistics acquisition interval, etc.). 
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9.2.2 STC Auto Filter Controls 

 
Figure 28. STC Auto Filter processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Depth (0–40). 
3  Suppression Depth indicator. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 
Main parameter of Auto Filter is Suppression Depth. 
This parameter can be configured within 0–40 dB. It adjusts the largest possible suppression of spectral components of noise. 
As for comfort perception, optimum suppression depth should be 12–18 dB. 
“Musical noise” may appear at large values; it has uneven sounding according to time that makes uncomfortable signal perception. 
Large values of suppression depth can be used to suppress strong stationary tone interferences. 
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9.3 Clip Restorer 

Clip Restorer is used to limit signal amplitude, thus removing strong bursts, “metalic” signal sounding and excessive rising of high frequency 
components (sizzle), and thus smoothing signal level. 
Clippping is a waveform distortion that occurs when the amplifier is overloaded and when dynamic range is exceeded by amplifier output 
voltage. 
On the waveform clipping usually looks like signal amplitude limitation. 

 
Figure 29. Clipped signal 

 

9.3.1 Processing Principles 

Clip Restorer algorithm is controlled cutoff of high frequency signal components that create “metallic” sounding. 
To remove loud high frequency sizzle sounds, use LP Filter additionally. It suppresses high frequency signal components with frequencies 
above 3 kHz. 
Figure 30 shows the same signal as in Figure 31, restored by Clip Restorer. 
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Figure 30. Restored signal 

Clip Restorer reduces signal amplitude; it is expressed brightly at large suppression depth. 
In such cases you are recommended to strengthen additionally the signal. 
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9.3.2 Clip Restorer Controls 

 
Figure 31. Clip Restorer processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Depth (0–100). 
3  Suppression Depth indicator. 
4  LP Filter ON/OFF button. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 

9.3.3 Working with Filter 

To restore clipped signal, perform the following: 
1. Enable filter. 
2. Move the slider to achieve the desired sound quality. 
3. If the sound is too weak, enable Amplifier filter after Clip Restorer filter when creating the scheme and gain the signal. 
4. If necessary, enable LP Filter. 

 
 
 
 
 
 



63 
FILTERING Sound Cleaner II 

  User Guide 
 

 

9.4 Reverb Suppressor 
9.4.1 Processing Principles 

Reverb Suppressor is used to decrease reverberations, i.e. non-stationary noise, generated by speech signal. This filter is similar to the 
Broadband Noise Filter. The difference is the estimation method of noise spectrum. 

9.4.2 Reverb Suppressor Controls 

 
Figure 32. Reverb Suppressor processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Depth (1–40). 
3  Suppression Depth indicator. 
4  Slider to adjust Adaptation Time (0.2–2). 
5  Adaptation Time indicator. 
6  Whitening mode ON/OFF button. 
7  Subtracted Signal mode ON/OFF button. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 
Main and most important parameters of filter are Suppression Depth and Adaptation Time. 
Suppression Depth can be configured within 1–40 dB. It adjusts the largest possible suppression of spectral components of noise. 
As for comfort perception, optimum suppression depth should be 12–18 dB. 
“Musical noise” may appear at large values; it has uneven sounding according to time that makes uncomfortable signal perception. 
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Large values of suppression depth can be used to suppress strong stationary tonal interferences. 
Adaptation Time specifies adjustment time, i.e. time the filter needs to tune itself to the variations of interference spectrum. For common 
cases values around 0.5 s are recommended. Adjust time constant within 1.0–2.0 s or 0.2–0.5 s intervals according to type (soft/deep) of 
reverberation suppression. 
Remember, that increasing suppression depth and decreasing adaptation time causes noise suppression greatly but at the same time it can 
impair speech signal quality by decreasing the level of useful signal. 
Control speech suppression level in listening mode of subtracted signal. To perform this, press the Subtracted Signal button. 
Whitening is an additional filtration mode. It suppresses noise at frequencies where its level is very high. Thus, this mode whitens spectrum of 
remained noise on filter output that makes sounding of filtered signal more comfortable. 
 

9.5 Dynamic Range Control 
9.5.1 Processing Principles 
Dynamic processing of signals is used to improve intelligibility of signals in case of signal level difference, in the presence of booming noise 
(long pulses) and room noises. 

Dynamic processing algorithms improve the audio signal quality; suppress strong impulses, clicks, and thus unmasking the signal. It equalizes 
signal level in different areas that decreases user fatigue at playback. 

 
Dynamic processing algorithms perform the following functions: 
• Speech level equalization; 
• Reduction signal level to specified level; 
• Pulse and bump and suppression (hearing protection); 
• Gain control of recording device; 
• Expanding the dynamic range of a signal; 
• Signal suppression in pauses. 
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9.5.2 Filter Controls 

 
Figure 33. Dynamic Range Control processing window  

Filter controls: 
1  Filter ON/OFF switch. 
2  Output Level window. 
3  Strong signal control buttons. 
4  Weak signal control buttons. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 
Specify straight average of signal amplitude in the Output Level window. 
It is used to distinguish strong and weak signals, and it reduces the volume of strong sounds or amplifies weak sounds by narrowing or 
“compressing” an audio signal's dynamic range.  
When reducing the volume of strong sounds, dynamic filter weakens the signals which straight average is greater than specified level. In this 
case instantaneous amplitudes of the signal can be higher or lower than specified level.  
When amplifying the volume of weak sounds, dynamic filter amplifies the signals which straight average is less than specified level. In this 
case instantaneous amplitudes of the signal can be higher or lower than specified level. Ultimate amplification of weak sounds is 26 dB (20 
times). 
When reducing the volume of weak sounds, dynamic filter weakens the signals which straight average is less than specified level. In this case 
instantaneous amplitudes of the signal can be higher or lower than specified level. 
Radio-buttons in the middle of the window adjust separate dynamic processing modes for strong and weak signals. Strong signals may 
remain at their initial level or can be weakened, that is usually done to bring loud speech down to threshold value or eliminate strong and 
long (more than 20 ms) impulses (knocks). 
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You may also amplify weak signals to balance the level of speech for two speakers; leave them unchanged (remain); or weaken them, which 
may be useful for suppressing the noise in pauses between loud speech fragments. 

 

9.6 Click Suppressor 
Click Suppressor is used to restore automatically speech or musical signals, distorted and masked by various pulse interferences, such as 
clicks, radio interferences, knocks, etc. 

Click Suppressor algorithms improve quality of audio signals, suppress strong signal impulses, clicks, and thus unmasking useful audio signal 
and increasing its intelligibility and sound quality. 

9.6.1 Processing Principles 
During impulse filtration Sound Cleaner II substitutes impulses with smoothened and weakened interpolated signals. If the program does 
not detect an impulse, it leaves the fragment unchanged. It also does not suppress tonal interferences and broadband noises. Impulse 
detection is based upon the information, which the program has about differences between useful signal and interference. Thus, setting 
filtration parameters correctly is critical for effective processing. 

9.6.2 Click Suppressor Controls 

 
Figure 34. Clip Suppressor processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Level (1–10). 
3  Suppression Level indicator. 
4  Slider to adjust Pulse length (1–10). 
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5  Pulse length indicator. 
The RESET button in the lower left corner of the window is used to return to filter default settings. 
 

To adjust impulse filtration, use the following parameters: 

1.  Suppression Level is used to detect and locate the impulses basing upon their energy. Default value is 6. Increasing suppression level 
will make the program locate weaker impulses. Setting small suppression level values will leave the weak impulses intact; if the value you 
have set is too high, then sudden changes of useful signal level will be considered impulse interferences and removed. 

2.  Pulse length slider controls detection and localization of impulses with respect to their duration. Decreasing this coefficient will 
enable the program to detect short and weak impulses, impairing, however, localization of longer impulses. 

 

9.7 Inverse Filter 
9.7.1 Processing Principles 
Inverse Filter effectively suppresses strong stationary periodic noises caused by electrical pick-ups or mechanical vibrations, thus recovering 
speech signal and equalizing signal AFC. 

The basis of inverse spectral filter is an algorithm of spectral equalizing (reduction medium spectrum of signal to flat spectrum of white noise). 
Formant and tonal speech structure of individual sounds, however, is preserved. 

It amplifies weaker signal components and suppresses the stronger ones at the same time. The average spectrum therefore tends to 
approach the flat spectrum, thus unmasking speech signal and improving its intelligibility. 

Broadband noises, however, usually become stronger, making signal perception less comfortable. Try to reach a compromise between noise 
reduction and speech perception. 
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9.7.2 Inverse Filter Controls 

 
Figure 35. Inverse Filter processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppress Spectrum Components (1–24). 
3  Suppress Spectrum Components indicator. 
4  Slider to adjust Amplify Spectrum Components (0–50). 
5  Amplify Spectrum Components indicator. 
6  Speech Equalizer mode ON/OFF button. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 

 

To adjust inverse filtration, use the following parameters: 

1. The Suppress Spectrum Components parameter adjusts ultimate suppression of strong spectrum components for any frequency. 
Suppression is used to reduce uneven noise spectrum to flat one, thus weakening its peaks. 12–24 dB values are recommended. 

2. The Amplify Spectrum Components parameter adjusts ultimate amplification of weak spectrum components for any given 
frequency. This parameter is used to control equalization level of spectrum by amplification of weak components (usually in high 
frequencies). Limitation of ultimate amplification is necessary in order not to amplify the broadband noise in high frequencies. 12–24 dB 
values are recommended. 

The Speech Equalizer button is used to turn on/off the mode of reducing medium signal spectrum to model medium spectrum of speech 
signal. In some cases the signal with such spectrum sounds more comfortable than whitened signal (with flat spectrum). 
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9.8 DTMF Suppressor 

DTMF Suppressor is used to suppress two-frequency phone numerical signals that mask useful signal. 
DTMF signals – the signals used for voice-frequency dialing. They are a sequence of short (approx. 0.2 s) rectangular pulses with two-
frequency filling. The signals are heard as a sequence of tonal pulses whose frequency varies from pulse to pulse. Frequency values are of 2 
types: low-frequency (LF) and high-frequency (HF). There are 4 fixed frequencies in each group: 
–  LF: 697 Hz, 770 Hz, 852 Hz, 941  
–  HF: 1209 Hz, 1336 Hz, 1477 Hz, 1633 Hz. 
DTMF signal is generated by combination of two frequencies: one frequency from the lower group, the other from the upper group. 
Typical view of DTMF signal and speech signal, distorted by DTMF interference, is shown on Figure Ошибка! Источник ссылки не найден.. 

 
Figure 36. Waveform (above) and spectrogram (below) of DTMF signal and speech signal, distorted by DTMF interference 



70 
FILTERING Sound Cleaner II 

  User Guide 
 

 

9.8.1 Processing Principles 

DTMF Suppressor algorithm automatically detects DTMF interference, defines, which frequencies are used in the moment, and turns on 
corresponding filters to suppress the frequencies. 
When suppressor works, short pulses may occur at the beginning and at the end of the pulse of DTMF interference. They are caused by 
transition processes in suppressor. 
On the waveform the pulses appear as bursts of signal that correspond to the begging and end of interference pulse, and they are heard as 
periodically recurring clicks. Use Click Suppressor, to remove such pulses. 

9.8.2 DTMF Suppressor Controls 

 
Figure 37. DTMF Suppressor processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Depth (1–10). 
3  Suppression Depth indicator. 
4  Click Suppressor ON/OFF button. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 

9.8.3 Working with Filter 

To suppress DTMF signals, perform the following: 
1. Enable filter. 
2. Move the slider to achieve the desired suppression level. 
3. If necessary, enable Click Suppressor. 
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9.9 Cellphone Noise Filter 

Cellphone Noise Filter is used to suppress interferences from cellphone, occurred during recording process. 
GSM interference is interference that occurs in GSM networks. It is a series of short consecutive pulses usually of high amplitude with 
frequency about F0 = 217 Hz. The frequency can vary slightly. GSM interference is heard as sharp rough pulsating buzzing. 

 
Figure 38. Typical waveform view of GSM interference 

 

9.9.1 Processing Principles 

GSM interference suppression algorithm automatically detects GSM interference and turns on corresponding filters to suppress the frequency 
center F0 (approximately 217 Hz) and its harmonics. Usually there are a lot of harmonics. There can be not only multiple harmonics (i.e. F0 × 2; 
F0 × 3, etc.), but the harmonics located between the main ones (i.e. the step between harmonics can be not only F0, but also F0/2). This step 
requires manual adjustment. To remove short clicks, use Click Suppressor. 
If AutoDetect is on, automatic detection of GSM interference in processed signal is carried out. Once AutoDetect signals about the presence 
of GSM interference in the signal, filter-suppressor turns on. 
If AutoDetect is off, filter-suppressor is on constantly. 
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In case AutoDetect is on there is a risk not to suppress any interference fragment, if AutoDetect has not reacted on it, for example, if 
interference is masked by strong speech signal. 
On the other hand, in case AutoDetect is off, frequencies that correspond to interference will be removed constantly from the useful signal as 
well; it will lead to low distortions in useful signal. 

For successful work with AutoDetect, perform the following: 

• If there is strong interference and weak useful signal, turn on AutoDetect. 
• If there is weak interference and strong useful signal, work in two modes. 

When suppressor works, short pulses may occur at the beginning and at the end of the pulse of GSM interference. They are caused by 
transition processes in suppressor. 
On the waveform the pulses appear as bursts of signal that correspond to the begging and end of interference pulse, and they are heard as 
periodically recurring clicks. Use Click Suppressor, to remove such pulses. 

9.9.2 Cellphone Noise Filter Controls 

  
Figure 39. GSM Suppressor processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Window to adjust primary (reference) cutoff frequency. 
3  Window to adjust ultimate frequency with harmonics. 
4  Window to adjust step by frequency. 
5  Slider to adjust Suppression Depth (1–10). 
6  Suppression Depth indicator. 
7  AutoDetect ON/OFF button. 
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8  Click Suppressor ON/OFF button. 
The RESET button in the lower left corner of the window is used to return to filter default settings. 

9.9.3 Working with Filter 

To suppress GSM interferences, perform the following: 
1. Enable filter. 
2. Specify primary (reference) cutoff frequency. In most cases, its value will be 217 Hz. 
To analyze the correctness of specified primary frequency, use the Spectrum Analyzer of Equalizer before applying Cellphone Noise 
Filter. 
3. Specify ultimate cutoff frequency. If its value is unknown, use the Spectrum Analyzer or specify the value as a half of sampling 

frequency. 
4. Specify step. In most cases, step will be 217 Hz. 
To analyze the correctness of specified step, use the Spectrum Analyzer of Equalizer before applying Cellphone Noise Filter. 
5. Adjust ultimate suppression depth. 
6. Enable AutoDetect and Click Suppressor. 
7. Filter signal and listen to it. 
8. Try to reduce the step in 2 times – if it’s getting better, leave this value. 
9. Slightly varying ultimate frequency, achieve the best suppression. 
10. Reducing suppression level and ultimate frequency cutoff, improve speech sounding without suppression losses. 
11. Try to operate the filter without AutoDetect and Click Suppressor. 

 

9.10 Reference Noise Filter 
9.10.1 Processing Principles 

Two-channel adaptive filtration algorithm (Reference Noise Filter) is designed to suppress both nonstationary broadband noises 
(background speech, radio, room noise) and periodical noises (vibrations, power-line pick-ups, etc.). When extracting useful signal (in the 
main channel), additional information about interference properties provided in reference channel is used. 

Stereo filtering has, however, serious limitations: it may be effectively applied only if the following conditions were met during recording: 
• Stereoscopic base (i.e. distance between the microphones) should not be less, than 10 cm; 
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• Left and right channel microphones should be located at different distances from the useful signal source. The same thing is for the 
interference source; 

• Left channel microphone should be located in the area of direct signal, and right channel microphone should be located in the area of 
useful signal. 

9.10.2 Reference Noise Filter Controls 

 
Figure 40. Reference Noise Filter processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Depth (1–40). 
3  Suppression Depth indicator. 
4  Slider to adjust Delay (-10–20). 
5  Delay indicator. 
6  Main Channel Left/Right ON/OFF radio buttons. 
7  Subtracted Signal ON/OFF button. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
The Suppression Depth parameter limits ultimate suppression of spectral interference components (usually less than the limit). 
Delay is a parameter critical for effective stereo processing. 
The Main Channel (Left/Right) field is used to process desired channel, as signals can be recorded randomly. 
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The Subtracted Siganl button is used to select the main channel correctly: there is useful signal in subtracted signal; if useful speech signal is 
heard in subtracted signal, the main channel is selected incorrectly. 

 

9.11 Tone Suppressor 

Tone Suppressor is used to suppress stationary tonal interferences and individual tonal pulses. This filter is the most effective to suppress 
narrow-band interference and coherent noise; its advantage is the optimum preservation of useful signal (speech) when adaptation is 
adjusted correctly. 
Tone suppressor is based upon the search of strong peaks in signal spectrum and their suppression. 

9.11.1 Processing Principles 

Tone Suppressor is used to remove narrow-band stationary and nonstationary interferences (vibrations, network interferences, noises from 
consumer devices, slow music, traffic sounds, sirens, etc.) and tonal pulses (phone pulses, tonal music, etc.) from signal. Suppression of tonal 
noise in spectral area enables to unmask speech signal, suppressing tonal interference by 20–40 dB. 
Main advantage of this method is that under the action of specific interferences speech signal is preserved much better, than when using 
other methods of noise cancellation. 
This is achieved by the fact that filter suppresses only certain noise narrow-band components, leaving the rest signal spectrum without 
changes, not affecting the useful signal. 
Main parameters of adaptive compensation that determine the level of noise suppression are Frame size and filter Adaptation Time. 
Increasing the number of coefficients leads to opportunity to suppress a large number of noise spectral peaks and at the same time decreases 
filter performance, its ability to adjust to rapidly changing interference. 
Delay time is used to adjust filter to suppress rapidly and slowly changing interferences. 
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9.11.2 Tone Suppressor Controls 

 
Figure 41. Tone Suppressor processing window 

 
Filter controls: 
1  Filter ON/OFF switch. 
2, 3  Drop-down lists to choose the algorithm parameters for different types of tonal interference. 
4  Slider to adjust Adaptation Time (0.2–2). 
5  Adaptation Time indicator. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 
Main parameter of Tone Suppressor is Frame size. It determines the number of spectral bands and the size of processed data block. The 
higher the value, the larger number of spectral peaks can be suppressed. Therefore, it is recommended to increase the frame size for 
interference of transformer noise type (Hum, Buzz). Note that too large frame size results in echo initiation. In case of a small number of 
frequencies of tonal interference, adjust the frame size within 256–512 points. 
Adaptation Time specifies adjustment time, i.e. time the filter needs to tune itself to the variations of interference spectrum. For common 
cases values around 1 sec are recommended. 
Decrease the adaptation time for interferences, which characteristics are changed rapidly, and increase the adaptation time for interferences, 
which characteristics are changed slowly. 
Remember, that at small adaptation time quality of processed speech signal may become worse, as speech signals contain rapidly changing 
tonal components. 
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9.12 Amplifier 
The Amplifier filter is used to increase or decrease the signal level within 20 dB. 

9.12.1 Amplifier Controls 

 
Figure 42. Amplifier processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Scale of a display gain control. 
3  Slider to adjust gain (-20–20). 
4  Gain indicator. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 

The Gain coefficient is adjusted by the slider with 1 dB step; current value is displayed to the right of the scale. 0 dB value means, that the 
signal is not amplified. 

During signal processing, signal level may go down due to corrections of frequency characteristic and noise reduction. It weakens some 
components of a signal, which may be lost during further processing. That’s why it is reasonable to amplify a signal during audio processing. 

If the gain value, you adjust, is too high, the overflow indicator (red button), located on the scale of a display gain control, will signal about it. 
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9.13 Broadband Noise Filter 

Broadband Noise Filter is used to extract speech signals from stationary interference background – broadband and narrowband tonal 
interferences. 
This algorithm is designed to suppress broadband and periodic noises caused by electric pick-ups or mechanic vibrations, room and street 
noise, communication channel or record equipment interferences. 
You may hear these noises as hum, sizzle, buzz, rumbling, hisses or roars. 
It is nearly impossible to remove such noises with other methods, such as one-channel adaptive filtration, spectrum smoothing or with 
equalizer, as they are spread across the whole spectrum and intersect with the speech signal. 
Broadband Noise Filter enables to unmask speech signal at SNR values (-5 – -10 dB). At the same time filter suppresses noise narrowband 
components. 

This filter has the following advantages: 
• It works within continuous speech with a large amount of interlocutors. 
• There is no need in speech pauses. 

 

9.13.1 Processing Principles 

Broadband Noise Filter processes signal frame by frame. Data frame is transformed into spectrum. Then power spectral density (PSD) is 
estimated. If the frame is a useful signal pause (noise signal fragment), then current PSD is used to accumulate averaged PSD of noise. Current 
PSD is compared with accumulated noise PSD at each frequency. Signal spectrum weakens at the frequencies where current frame PSD is 
commensurable with noise PSD (because at these frequencies useful signal has no components or they are too small for an ear to unmask 
them). Signal spectral components are saved at those frequencies, where current PSD is larger than noise PSD. This procedure is called 
spectrum subtraction. 
After that a filtered frame spectrum is transformed back to the time zone. As a result we get a filtered signal. 
This processing algorithm can be compared with operation of dynamic equalizer, which changes its characteristics at each frame several tens 
of times per second. 
In case of using a large size frame such equalizer operation result may be interpreted as echo. Processing parameters are used to control 
equalizer operation mode (quantity of spectral bands, noise statistics acquisition interval, etc.). 
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9.13.2 Broadband Noise Filter Controls 

 
Figure 1. Broadband Noise Filter processing window 

Filter controls: 
1  Filter ON/OFF switch. 
2  Slider to adjust Suppression Depth (1–40). 
3  Suppression Depth indicator. 
4  Slider to adjust Adaptation Time (0.2–2). 
5  Adaptation Time indicator. 
6  Whitening ON/OFF button. 
7  Subtracted Signal ON/OFF button. 

The RESET button in the lower left corner of the window is used to return to filter default settings. 
 
Main and most important parameters of filter are Suppression Depth and Adaptation Time. 
Suppression Depth can be configured within 1–40 dB. It adjusts the largest possible suppression of spectral components of noise. 
As for comfort perception, optimum suppression depth should be 12–18 dB. 
“Musical noise” may appear at large values; it has uneven sounding according to time that makes uncomfortable signal perception. 
Large values of suppression depth can be used to suppress strong stationary tone interferences. 
Adaptation Time specifies adjustment time, i.e. time the filter needs to tune itself to the variations of interference spectrum. For common 
cases values around 0.5 s are recommended. Adjust time constant within 1.0–2.0 or 0.2–0.5 s intervals according to type (soft/deep) of 
reverberation suppression. 
Adaptation time specifies the constant of adaptation time to the uneven changes of noise level. Real time of complete filter adjustment can 
be either more or less than a specified value. 



80 
FILTERING Sound Cleaner II 

  User Guide 
 

 

Remember, that increasing suppression depth and decreasing adaptation time causes noise suppression greatly but at the same time it can 
impair speech signal quality by decreasing the level of useful signal. 
Control speech suppression level in listening mode of subtracted signal. To perform this, press the Subtracted Signal button. 
Whitening is an additional filtration mode. It suppresses noise at frequencies where its level is very high. Thus, this mode whitens spectrum of 
remained noise on filter output that makes sounding of filtered signal more comfortable. 
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9.14 Equalizer 

Equalizer displays signal spectrum and allows user to correct signal amplitude. Equalizer works in automatic or semi-automatic mode. It is 
used to suppress any stationary components of a signal regardless of their frequency and location, and to weaken or strengthen the 
amplitude in a chosen spectral band. This filter processes well audio recordings containing considerable stationary noises such as power-line 
noise, mechanical and engine noises and so on. 
Equalizer is represented in the program as two windows: the Spectrum Analyzer window (Fig. 44) and the Multiband Equalizer window 
(Fig. 45). 

 
Figure 43. Spectrum Analyzer 

In Filtration Scheme equalizer is displayed without sliders, i.e. as Spectrum Analyzer. Spectrum Analyzer is used to analyze signal 
spectrum. 
To work with spectrum, open the Multiband Equalizer window by double clicking with the left mouse button in the Spectrum Analyzer 
window. 

9.14.1 Multiband Graphic Equalizer Controls 
The Multiband Equalizer window consists of the following (Fig. 45): 
1  Header and a toolbar; 
2  Spectrum analyzer settings panel; 
3  Spectrum analyzer window; 
4  Horizontal scroll bar; 
5  Graphic equalizer; 
6  Sling indicator and Additional FC Adjustment sliders. 
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Specify the type of spectrum on the spectrum analyzer settings panel. 
Instantaneous – displaying current signal spectrum. Instantaneous spectrum is a spectrum of short signal fragment. Duration of this 
fragment is given by the length of the FFT window. Current spectrum displays changes of amplitude-frequency characteristic of signal during 
its playback. 
Accumulated – averaging of input signal spectrum. 

   Accumulated spectrum is applied only to input signal. 

Also you may select the amplitude displaying scale. 
Logarithmic – logarithmic (decibel) displaying of amplitude scale. 
Linear – linear displaying of amplitude scale. 
Select the equalizer’s bands number in the Bands drop-down list. It determines the spectrum accuracy. The more the better. The fast Fourier 
transformation (FFT) window size is 4 times more than the bands number, so 1 band corresponds to 4 FFT points. 
Spectrum analyzer window displays current signal (spectrum) (blue color) and filter (green color) with horizontal belt indicator. 
Vertical marks (two white lines in spectrum analyzer window) determine the borders to apply filters. You can change their location during 
signal processing. 
The RESET button in the lower left corner of the window is used to return to filter default settings. 

There are buttons to control equalizer window in the upper-right corner of the toolbar: 

–  To minimize/close equalizer window, click . 

–  To move equalizer window from one place to another, point the mouse cursor over the Equalizer window name (in the upper-left 
corner of the window), click the left mouse button and move the window to the desired location. 

To control spectrum, use vertical sliders of equalizer window (sliders to adjust filter bands). By clicking above or below the slider, the value of 
the slider is changed to 18; it allows you to move slider from 0 to -72 (by clicking 4 times). 
You can link the sliders in equalizer. To perform this, use the Sling mode (see section 9.14.5 Sling Mode). 



83 
FILTERING Sound Cleaner II 

  User Guide 
 

 

 
Figure 44. Multiband Equalizer 
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9.14.2 Equalizer Toolbar 

Table 2. Equalizer toolbar buttons 

Button Name Action 

 
Horizontal auto zoom Displays the entire signal on horizontal axis 

 
Vertical auto zoom Displays the entire signal on vertical axis 

 
Input signal spectrum Displays input signal spectrum 

 
Output signal spectrum Displays output signal spectrum 

 
Contrasting Deepens filter negative peaks 

 
Sling Combines several sliders to control simultaneously 

 
High-pass filter 

Automatically adjusts the sliders to pass frequencies below the 
right vertical slider in the Spectrum Analyzer window 

 
Low-pass filter 

Automatically adjusts the sliders to pass frequencies above the 
left vertical slider in the Spectrum Analyzer window 

 
Inverse filter 

Automatically performs inversion of signal spectrum within the 
vertical sliders 

 
Harmonic filter 

Automatically detects and suppresses stationary harmonics 
within the vertical sliders 
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Button Name Action 

 
Spectrum saving filter 

Automatically builds filter with amplitude-frequency 
characteristic of input signal 

 

Accumulate average 
spectrum  

Accumulates spectrum, displaying average spectrum of entire 
signal 

 
Sound Cleaner II allows the user to save and use previously saved equalizer settings, generated while creating report 
(see section 11 CREATING REPORT). Equalizer settings are not displayed in text format in the report; they are saved in the file. The name of this 
file is contained in the report to be downloaded further in the multiband equalizer window. 

To save the current profile, click  Save settings as a preset (on the right side of equalizer toolbar). 
In saving window enter preset name and click OK. 
Current profile will be displayed in the Preset field (on the right side of equalizer toolbar) (Fig. 45). 
 
To download previously saved profile: 
1. From the Preset drop-down list select From file…. 
2. In opening window select file with extension .eqp and click Open. 

To delete the profile, click  Delete preset. 
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9.14.3 Zooming and Scrolling 

The program allows the user to change the borders of spectrum visible in the window. 
Place the cursor to the vertical (Fig. 46, pos. 1) or horizontal (Fig. 46, pos. 2) scale and rotate the mouse wheel, to increase or decrease the 
scale spacing, displayed in the window; thus changing the data range visible in the window. The data range will be expanded or narrowed 
around the current cursor position. 
 
To display the data visible in the window entirely, use a scroll box on the horizontal scroll bar under the horizontal scale (Fig. 46, pos. 4). 
In this mode the  and  buttons (Fig. 46, pos. 3 and 5) will be activated on the both edges of the horizontal scroll bar. 

 
Figure 45. Spectrum window 
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9.14.4 Adjusting Filter FC 

There are 32 spectrum adjustment sliders in the equalizer window. 
To adjust filter FC, use the sliders or specify the exact degree of amplification/attenuation of the signal in indicators over sliders. 
Bands per slider is the field to display actual number of bands for one slider. Graphic equalizer has 2048 bands. The number of bands per 
slider depends on the selected FFT window size and on the scope of data visible in the spectrum analyzer window. 
There is digital indicator (in dB) above each slider, used to display amplification and attenuation degree of the signal in the adjustable band. 
The highest and lowest possible values (+20/-72 dB), which correspond to extreme slider positions, are given to the left of the sliders. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



88 
FILTERING Sound Cleaner II 

  User Guide 
 

 

9.14.5 Sling Mode 

The Sling mode allows you to adjust simultaneously several sliders as if they were bound together with an elastic thread. In this mode it is 
much easier to change the filter FC smoothly. 
To combine sliders in one group, click the Sling button on the equalizer toolbar. 
Belt indicator, located below the sliders, is active only when the mode is on and it is used to adjust the left and right borders of the group. 
Selected group will be marked with the blue indicator in the bar. 
To control linked sliders, click the left mouse button on one of the sliders and drag the chain down. 
If to drag one slider, approximation of values for bands is performed; averaged value of bands is specified for all other sliders. 
If to drag one slider, holding Shift, all other sliders in the group will have the same value. 
If to drag one slider, holding Ctrl, once the slider is released, the built filter will have stair-step view: equalizer bands, which correspond to the 
slider, will have the value of slider without approximation. 
The value of the slider, being dragged, is the ultimate (minimum or maximum) for the last band. So once the slider is released, it will change 
the value, displaying averaged value of corresponding bands. 
Note, that only sliders (not filter bands!) may be grouped and bound together. If you zoom in or out, those sliders, which you have previously 
included in a group, will control other signal bands. 
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9.14.6 Additional FC Adjustment 

The Q1 and Q2 sliders, located at the very bottom of the screen, provide additional filter FC adjustment, which are added to values, set by FC 
adjustment sliders. This extra adjustment makes speech sound more natural and it is much more comfortable for the listener’s perception. 
Q1 adjusts FC convexity within 100–800 Hz frequency band. Once the marks appeared, Q1 affects the area to the right of the left mark, and 
not to the area of LF (100–800). 
Q2 changes FC increase/decrease for every 1000 Hz starting from 1000 Hz. Both sliders work within -18/+18 dB range with current value 
indicated to the right of it. 
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10  SIGNAL PROCESSING 

To process the signal, use the Processing menu commands. 
To apply the changes of the parameters and start signal processing, click Apply. 
To close the window without saving changes, click Cancel. 

      Select the data processing area. The entire signal will be processed, but in case signal fragment is selected, filtering changes will be 
applied only to the fragment. 

 

10.1 Normalization 

Normalization is used to adjust maximum level of amplitude for entire signal or for signal fragments. Normalizing audio signals to 32767 
counts or 0 dB, reach maximum amplitude level. The program uses peak normalization, at which signal level rises to the maximum level for 
digital audio without distortions. There is no need in clipping with this method. However, if audio file has at least one peak, standing out 
against entire signalogram background, audio signal may remain fairly low when normalizing its level, in spite of the loud sound used when 
normalizing. In this case, you are recommended to normalize necessary fragments of the signal. 

Normalization can be used: 
• Before playback –to increase the volume; 
• After filtering – to compensate signal amplitude decay by filtering, for example inverse filter. 

 
Normalization by Amplitude is used to adjust symmetrical normalization above and below the center of sound wave, used in most cases. 
Normalization In Interval is used to adjust normalization for the area above or below the center of sound wave. 
 
Specify the value in counts or decibels with the slider or enter the value manually (using the keyboard) in the Counts field. 
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Figure 46. Amplitude Normalization 

 

10.2 Clipping 

Clipping is used to limit the signal in amplitude area and to suppress partially impulse noise, when impulses occur by series and each of them 
has long duration and amplitude that greatly exceeds the amplitude of useful signal. 
This signal processing method reduces psychoacoustic effect of temporary masking. 
 
Clipping By Amplitude is used to clip symmetrically above and below the center of sound wave, used in most cases. 
Clipping In Interval is used to adjust clipping for the area above or below the center of sound wave. 
 
Specify the value in counts or decibels with the slider or enter the value manually (using the keyboard) in the Counts  field. 
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Figure 47. Amplitude Clipping 

 

10.3 Resampling 

Resampling is used to change sampling rate of source signal. 
Note that spectral components of speech signal that effect speech intelligibility are approximately in the area up to 5 kHz. 
To increase speech intelligibility, lower sampling rate up to 11 025 Hz. It will partially reduce high-frequency noises and simplify the task of 
spectrum correction using equalizer. 
 
Divide to Integer is used to lower sampling rate to the nearest multiple of the current frequency. 
Set to Arbitrary is used to specify necessary signal sampling rate in the range from 4000 to 192 000 Hz. 
Select random sampling rate from the drop-down list or enter the value manually (using the keyboard) in the New Sample Rate field. 
Band Width is used to display actual frequency band after resampling. 

   The boundaries of the spectral signal range are from 0 Hz to the middle of the sampling rate.  

When dividing frequency, the entire spectrum within the range from the middle of an old frequency to the middle of a new one will be 
suppressed for more than 72 dB. However, the high-frequency part of the rest spectrum (10 %) will get to the transitional area and will 
be distorted a little. Thus the Band Width information field displays maximum undistorted frequency. 
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Figure 48. Resampling 

 

10.4 Tempo Correction 

Tempo correction is used to slow down or accelerate the sound with no changing the timbre. 
Use this method for relatively low-frequency speech in comparison with sampling rate. 
You are not recommended to slow down a high singing woman voice recorded with the sampling rate of 8 kHz. 
Use this method at the very end of the process, just prior to playback. 
 

      The white noise decelerated in 3 times turns to a voice frequency, and a voice becomes “drunken”. 

 
Value is used to adjust speed value from 0.33 (slowdown) to 3 (acceleration) with the slider or to enter the value manually (using the 
keyboard) in the Value field. 
The value will be with relative error 10-14 (if the Tempo Accuracy type is selected). 
Signal Quality is used to preserve high quality of the output signal; some fragments of speech will not be accelerated or slowed. 
Tempo Accuracy is used to preserve the exact value of tempo correction factor even at the expense of quality. 
Pitch Period is the expected length of pitch in seconds. Increasing this parameter, output signal envelope becomes a sawtooth and specific 
overtones occur; decreasing this parameter, clicks appear. 
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Figure 49. Tempo Correction 
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11  CREATING REPORT 
To analyze signal processing results, create a report on the basis of data obtained during program work. 
The report will contain information about an audio file, expert, processing, company details, report creation time, images of source and 
processed signal with spectra, information about used filters and settings, text comments, etc. 
Report on the results of the work is saved in HTML format. To view HTML report, use any browser (Mozilla Firefox, Internet Explorer, etc.). To 
open a report, use any text editor, for example MS Word, OpenOffice. To perform this, right-click the report and click Open with. 
To create a report, click File > Create report or press Ctrl+W on the keyboard. 
In the creating report window specify desired data (company details, report creation time, etc.) and click Create (Fig. 51). 
In the saving window specify name and location path of the report and click Save. 
By default, the report is located in the following directory: C:\Program Files\Speech Technology Center\SoundCleaner II. 

 
Figure 50. Creating report 
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12  TEXT TRANSCRIPTION 

Transcriber is the part of Sound Cleaner II and is used to generate a text transcription of a recording. 
To perform this, click Service > Transcriber. 
Enter the text of simultaneously played recording in the designated field of Transcriber (Fig. 52, pos. 2). The program will start to establish 
consistency between text and sound, creating a transcript of sound file. 
During playback the program highlights the text entered by user. To perform this, make corresponding settings in the program beforehand 
(see section 14 CONFIGURING THE PROGRAM). 
 

Transcriber panel consists of the following: 
1 – Toolbar; 
2 – Text input field. 

  
Figure 51. Transcriber 

To control Transcriber (to minimize and/or close the panel), use control buttons to the right of the toolbar. 

To minimize Transcriber, in the right corner of the toolbar click . 
 

To close Transcriber, perform one of the following: 

1. In the right corner of the toolbar click . 
2. In the Service menu clear the Transcriber check box. 

 
Transcriber toolbar (Fig. 52, pos. 1) is the standard text editor panel. 
Use toolbar to change the font face, font size, text format and alignment. 
Please see the tool tips that appear when hovering the mouse cursor over an item to understand allocation of Transcriber control elements. 



97 
TEXT TRANSCRIPTION Sound Cleaner II 

  User Guide 
 

 

      When Transcriber is opened in the program the Space key is inactive for playback of sound file. To play a sound file in this case, use 
Ctrl+Space shortcut. 

Table 3. Text formatting elements 

Element Designation Allocation 

 Font. Font Size Change the font face. Change the font size 

 Bold Make the selected text bold 

 Italic Italicize the selected text 

 Underlined Underline the selected text 

 Left Align text to the left 

 Center Center text 

 Right Align text to the right 

 Justify Justify 

Toolbar editing commands, Transcriber context menu commands, as well as program shortcuts (Fig. 52, pos. 1, Fig. 53) are used to 
perform standard text editing functions: 
• Undo – undoes the performed action. 
• Redo – redoes the undone action. 
• Cut – cuts selected area of the text. 

• Copy – copies selected area of the text. 
• Paste – pastes to a pointed place area of the text, copied with the Copy command or cut with the Cut command. 
• Delete – deletes selected area of the text. 

• Select All – selects all the text in the string. 
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Figure 52. Transcriber context menu 
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13  EDITING HISTORY 

History tab of Filtration Scheme displays any user action during signal processing. Last applied user action is highlighted in the history list 
(Fig. 54). 
During signal processing user can undo changes sequentially and/or can go back to a certain step. 

For this, do the following: 
1. Click Edit > Undo/Redo. 
2. Double-click the applied signal processing on the History tab. 

 

   During signal processing when returning to previous steps part of the history will be lost. 

 
Remove and return back the tab by selecting/clearing the Scheme check box in the View menu. 
In this case the History tab is hidden together with Filtration Scheme. 
 

 
Figure 53. History tab 
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14  CONFIGURING THE PROGRAM 

Most of program settings are adjusted by default. To change the settings if needed, click Service > Options…. 
The Options window appears. 
The window contains the following groups of settings controls (Fig. 55): 
 
Mouse wheel zoom factor 
Specify the step to change (using mouse wheel) the size of data window in percentage. 
 
Number of undo levels 
Specify the number to undo the action. 
 

      Please take into consideration free disk space when undo the action (as all signal changes are saved on the hard disk). 

 
Signal drawing 
Group of settings controls is used to adjust signal display options. 
Select type of signal drawing in data window: Polyline, Stair-step, Dots. 
Specify line thickness. 
Specify maximum number of dots per pixel. 
 
Transcriber 
Select the Highlight text at playback check box. In this case during playback, text entered by user in the Transcriber field will be 
highlighted. 
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Presets 
Group of settings controls is used to adjust preset load options. 
Select the type of preset load: Filtration scheme and sound file (to load the scheme with sound file as a template), Filtration scheme (to 
load the filter scheme). 
 
To save parameters, click Apply in the Options window. 
To close the window without saving changes, click Cancel. 

 
Figure 54. Configuring the program 
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15  FEEDBACK TO THE DEVELOPERS 
Interactions with our help desk can be simplified by the built-in program mechanism, aimed to automate registration process, problem 
solving, submitting of requests and error messages. 
In case of errors and failures in the program, operator has an opportunity to contact immediately the developers of the program and report 
an error. 
For this purpose click Contact Us  on the Help  menu (Figure 55). 

 
Figure 55. Help menu items 

Click Contact Us > New error…  to open the Bug reporter - New error  dialog box should appear (Figure 56); there is an 
opportunity to describe an error. 
The window appears automatically if there is a failure in the program. 
You may: 
1) Click the Send  button to send bug reports and error messages to the producer (if Internet connection is available). 
2) Click the Create archive  button to prepare a bug report for sending. 
3) Click the Save text  to write and save a a message for our technical support. 
4) Click the Close  button to close the dialog box without making an action. 
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Figure 56. Bug reporter - New error dialog box 

Click Contact Us > New issue…  to open the Bug reporter - New issue  dialog box should appear (Figure 57); there is an 
opportunity to point program operation issues. 

 
Figure 57. Bug reporter - New issue dialog box 
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When you create a new error or issue description the Send bug reports archive  dialog box appears (Figure 58). 

 
Figure 58. Send bug reports archive dialog box 

Click Contact Us > Oprions…  to open the Bug reporter - Options  dialog box should appear (Figure 59); there is an opportunity to 
customize common settings concerning bug report sending. 

 
Figure 59. Common bug report settings 

 

   The New error… and New issue… items set active only after having assigned an email address for answers from our technical support 
at the Bug reporter -  Options  dialog box. 
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16  PROGRAM SHUTDOWN 
To shut down the program, perform one of the following: 
• Click File > Quit; 
• Click Close in the right corner of program header; 

• Press Alt+X on the keyboard. 
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17  PROGRAM UNINSTALL 

To uninstall the Sound Cleaner II software, use OS standard means: 
1. Open Control Panel, click Programs and Features.  
2. In the Uninstall or change a program list, select STC Sound Cleaner II, and then click Uninstall.  
3. When prompted, restart the computer. 
OR 
Uninstall the program by the menu command Start > All Programs > Speech Technology Center > Sound Cleaner II > Uninstall 
Sound Cleaner II. 

 

17.1 Program Update 
To install new version of Sound Cleaner II, run the Setup.exe file from the STC installation disk and select installation language. A notify 
message will appear, indicating that Sound Cleaner II is already installed and will offer to update the program. Click Yes. 
Previous program version will be uninstalled and the installation wizard dialog window will appear. To continue installation, follow the wizard 
instructions. 
 

   Previously saved projects and presets will be available after program update. 
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 APPENDICES 

Appendix A: Shortcuts 

For accessibility and efficiency, most common actions can be performed using program shortcuts. A complete list of keyboard shortcuts is 
available in the Shortcuts window (Figure A.1). Click Shortcuts in the Help menu or press F1. 
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Figure A.1. Program shortcuts 
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Appendix B: Program Main Menu 

Program main menu controls program work and consists of the following: File, Scheme, Edit, View, Playback, Process, Service, Help. 
 
The File menu controls files, projects and reports: 
• Open… 

• Open Project… 
• Save Project 
• Export to Sound File… 
• Create Report 

• Recent Files… 
• Recent Projects… 
• File Info 

• Close All 
• Quit 
 
The Scheme menu controls complete signal processing scheme created by user: 
• Open… 

• Save as… 
• Clear 
• Turn on All Filters 

• Turn off All Filters 
• Save as Preset 
• Remove Preset 

• Rename Preset 
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The Edit menu controls data editing process: 

• Undo 
• Redo 
• Delete 

• Trim 
• Divide Stereo to Two Mono 
• Create Reference Channel 
• Shift Signal Left 
• Shift Signal Right 
 
The View menu controls data display, as well as complete signal processing scheme and navigation scheme: 

• Show Notify List 
• Remove All Notifications 

• Navigation Scheme 
• Scheme 
• In dB 

• Vertical Auto-zoom 
• Horizontal Auto-zoom 
 
The Playback menu controls playback of sound files opened in the program: 
• Play All 
• From Cursor 
• Selected Area 
• Pause 

• Resume 
• Stop 
• Preview 
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The Processing menu controls data processing: 

• Normalize 
• Clip 
• Resample 

• Change Speed 
• Filtering 
 
The Service menu controls program settings and offers service functions: 
• Options… 

• Copy Screen Area 
• Copy Window Image 
• Transcriber 
 
The Help menu contains the following commands: 
• User Guide. Starts Adobe® Reader® to open User Guide in .pdf format. 

• Shortcuts. Opens the list of shortcuts for convenient and fast work with the program. 
• About. Displays information about the program. 
• Contact Us. Allows you to contact with our technical support. 

• Get Expert Advice. Allows you to ask our experts for noise reduction service via the web site. 
• Order Training. Allows you getting to know the training courses and asking our experts for consulting via the web site. 

 

   When working on Mac OS X, find the Quit Sound Cleaner II, Options… and About items in the standard application menu. 
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    Firstly install Adobe® Reader® on a PC and then launch Sound Cleaner II. 

  Adobe® Reader® can be downloaded from the producer website: http://www.adobe.com/. 

 
 

 

http://www.adobe.com/
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