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Preface

Introduction
This chapter contains general information about this manual and contacting 
customer support.

Highlights
Topics covered in this chapter:

• About this Guide

• Warranty Registration

• Recommended Reading

• The Microchip Internet Web Site

• Development Systems Customer Notification Service

• Customer Support

About This Guide

Document Layout
This document describes how to install a PICDEM™ MSC1 (Mixed Signal 
Controller1) on a PC and load the GUI software as a development tool for 
creating the initialization assembly code for your PIC16C781/782 application. 
The PICDEM™ MSC1 is the tradename for the PIC16C781/782 
Microcontroller Evaluation Tool described in this manual. The manual layout is 
as follows:

• Chapter 1: Overview and Installation – What the PICDEM™ MSC1  
is and how to install it.

• Chapter 2: Basic Functions – Describes how to get started using the 
PICDEM™ MSC1 and how to access the basic functions using the GUI 
software.

• Chapter 3: Tutorial/Demo - Provides an example of how you can con-
figure a typical peripheral using the PICDEM™ MSC1 and create the 
initialization assembly code corresponding to your configuration.

• Appendix A: Schematics – Provides the schematics and board layout 
for the PICDEM™ MSC1.

• PICDEM™ MSC1 Worldwide Sales and Service – Lists Microchip 
sales and service locations and telephone numbers worldwide.
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Updates
All documentation becomes dated, and this user’s guide is no exception. 
Since the PICDEM™ MSC1 and other Microchip tools are constantly evolving 
to meet customer needs, please refer to our web site at http://
www.microchip.com to obtain the latest documentation available.

Warranty Registration
Please complete the enclosed Warranty Registration Card and mail it 
promptly. Sending in your Warranty Registration Card entitles you to receive 
new product updates. Interim software releases are available at the Microchip 
web site.

Recommended Reading
This user’s guide describes how to use the PICDEM™ MSC1. The data 
sheets contain current information on programming the specific 
microcontroller devices.

README.TXT

For the latest information on using PICDEM™ MSC1, read the README.txt 
file (ASCII text file) included with the PICDEM™ MSC1 software. The 
README.txt file contains update information that may not be included in this 
document.

MPLAB® IDE User’s Guide (DS51025)

Comprehensive guide that describes installation and features of Microchip’s 
MPLAB Integrated Development Environment (IDE), as well as the editor and 
simulator functions in the MPLAB environment.

MPASM™ User’s Guide with MPLINK™ & MPLIB™ (DS33014)

Describes how to use Microchip Universal PICmicro® Microcontroller 
Assembler (MPASM), Linker (MPLINK), and Librarian (MPLIB).

Technical Library CD-ROM (DS00161)

This CD-ROM contains comprehensive data sheets for Microchip PICmicro® 
MCU devices available at the time of print. To obtain this CD-ROM, contact 
the nearest Microchip Sales and Service location (see back page) or 
download individual data sheet files from the Microchip web site (http://
www.microchip.com).

PICmicro Mid-Range MCU Family Reference Manual (DS33023)

This manual explains the general details and operation of the MCU family 
architecture and peripheral modules. It is designed to complement the device 
data sheets.

https://www.application-datasheet.com/
https://www.application-datasheet.com/
https://www.application-datasheet.com/
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Microsoft® Windows® Manuals

This manual assumes that users are familiar with Microsoft Windows 
operating system. Many excellent references exist for this software program, 
and should be consulted for general operation of Windows.

PIC16C781/782 Data Sheet (DS41171)

This book contains details about the PIC16C781/782 Microcontroller and 
more.

The Microchip Internet Web Site
Microchip provides online support on the Microchip World Wide Web (WWW) 
site.

The web site is used by Microchip as a means to make files and information 
easily available to customers. To view the site, the user must have access to 
the Internet and a web browser, such as Netscape® Communicator or 
Microsoft® Internet Explorer®. Files are also available for FTP download from 
our FTP site.

Connecting to the Microchip Internet Website

The Microchip web site is available by using your favorite Internet browser. 
Visit: 

http://www.microchip.com

The file transfer site is available by using an FTP program/client to connect to:

ftp://ftp.microchip.com

Development Systems Customer Notification Service
Microchip started the customer notification service to help our customers 
keep current on Microchip products with the least amount of effort. Once you 
subscribe to one of our list servers, you will receive e-mail notification 
whenever we change, update, revise or have errata related to that product 
family or development tool. See the Microchip web page at 
http://www.microchip.com for other Microchip list servers.

The Development Systems list names are:

• Compilers

• Emulators

• Programmers

• MPLAB

• Otools (other tools)

https://www.application-datasheet.com/
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Once you have determined the names of the lists that you are interested in, 
you can subscribe by sending a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe <listname> yourname

Here is an example: 

subscribe programmers John Doe 

To UNSUBSCRIBE from these lists, send a message to:

listserv@mail.microchip.com 

with the following as the body:

unsubscribe <listname> yourname

Here is an example: 

unsubscribe programmers John Doe

The following sections provide descriptions of the available Development 
Systems lists.

Customer Support
Users of Microchip products can receive assistance through several 
channels:

• Distributor

• Local Sales Office

• Field Application Engineer (FAE)

• Corporate Applications Engineer (CAE)

• Systems Information Upgrade Hotline

Technical Support can be obtained through your local FAE or CAE. CAEs may 
be contacted at (480) 792-7627. Contact the Sales office for prices and 
literature requests. Sales offices are listed on the back cover of this User 
Guide.

In addition, there is a Systems Information and Upgrade Line. This line 
provides system users a listing of the latest versions of all of Microchip's 
development systems software products. Plus, this line provides information 
on how customers can receive any currently available upgrade kits.

The Hotline Numbers are: 

1-800-755-2345 for U.S. and most of Canada, and 

1-480-792-7302 for the rest of the world.
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Chapter 1.  Overview and Installation

1.1  Introduction
The PICDEM™ MSC1 with its PC-based Graphical User Interface (GUI) soft-
ware serves as a stand-alone development and evaluation tool for the 
PIC16C781/782 Microcontrollers, or as a user interface to the peripherals. 

1.2  Highlights
The topics covered in this chapter are:

• Unpacking your PICDEM™ MSC1 hardware and software

• Installing the hardware

• Installing the GUI software

• What the PICDEM™ MSC1  is

• How the PICDEM™ MSC1 helps the Developer

1.3  Unpacking Your PICDEM™ MSC1
1.3.1 Supplied Items

The items contained in your PICmicro box are:

• PICDEM™ MSC1 Circuit Board with a programmed  PIC16C782 
installed

• PIC16C781/782 Data Sheet (DS41171)

• CD-ROM containing: GUI software, User’s Guide, Board Schematics, 
Monitor Firmware, Example Arbitrary Waveform

• Assorted jumpers

1.3.2 Required Items

The items required are:

• PC running Windows 95 or newer operating system

• 9 VDC Power Supply

• 9-pin RS-232 Cable

https://www.application-datasheet.com/
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1.4  Installing the Hardware
Perform the following procedure to install the PICDEM™ MSC1 hardware:

1. Connect the PICDEM™ MSC1 circuit board to the 9 VDC Power Supply
as shown in the Figure 1.1 and plug in the AC connector for the 9 VDC

Power Supply.

Figure 1.1:  Installing the Hardware

2. Connect one end of the RS-232 cable to the Serial Port of your PC.
3. Connect the other end of the RS-232 cable to the PICDEM™ MSC1 cir-

cuit board as shown in Figure 1.1. This completes the hardware installa-
tion.

To PC Serial Port

RS-232 connector

PICDEM™ MSC1 Circuit Board

9 VDC Power Supply

9 VDC Power Connector

AC Power

RS-232 cable

AVDD LED
VDD LED

Note: The AVDD LED and the VDD LED should be lit, indicating the Ana-
log and Digital Power Supplies are operating.
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1.5  Installing the GUI Software
The GUI software adheres to standard Windows® conventions and should be 
easy to install for anyone familiar with other Windows applications.

Perform the following procedure to install the GUI software:

1. Insert the CD containing the GUI software into your PC. Locate and dou-
ble-click on the setup.exe file in the CD Root Directory. An Installation
Wizard will guide you through the installation process.

2. Follow the instructions in the Installation Wizard. The installation creates
an entry in the Start → Programs group. The Wizard will also create a
PICDEM™ MSC1 icon for your desktop. 

3. You can start the GUI software by using the Start → Programs → 
PICDEM™ MCS1 sequence. 

1.6  What the PICDEM™ MSC1 Is
The Evaluation Tool is comprised of:

• Printed circuit board

• PC based GUI

• UV erasable PIC16C782 with monitor firmware

• 9V power supply (IEC)

• RS-232C cable (9-pin)

• General purpose jumper wires

In stand-alone mode, the GUI is useful for discovering the features of all the 
PIC16C781/782 peripherals and identifying which registers are affected by 
the different configurations. When used in conjunction with the evaluation 
board, the GUI gives instant access to the PIC16C781/782 peripherals allow-
ing on-the-fly configuration changes by means of an RS-232 link between a 
PC and the evaluation board.

The GUI includes a Code Generator that can build the initialization assembly 
code that corresponds to the selected configuration. Developers can use the 
Code Generator to perform an entire configuration using the Evaluation Tool 
and save it as a disk file.

The firmware of the PICDEM™ MSC1 allows you to:

• Configure the inputs and outputs of each peripheral module using your 
application parameters

• Configure the operation of each peripheral module

• Load and view the contents of the Special Purpose Registers needed to 
run your application

• Operate a dynamic conversion loop for scoping the Output of the DAC 
Module

• Save the configuration file that you have created and insert it into your 
application software.
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Chapter 2.  Basic Functions

2.1  Starting Communications with the Evaluation 
Tool

2.1.1 Introduction
Start the GUI software by selecting Start→Programs→ PICDEM MSC1, or 
you can double-click the PICDEM MSC1 program icon on your desktop. The 
GUI Control Panel displays, as shown in Figure 2.1.

2.1.2 Using the GUI Control Panel

Figure 2.1:  PICDEM™ MSC1 Control Panel

Features Global to All Peripherals
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Port Selection

Communications port selection is not automatic, so you need to make the 
communications port selection with the Options→Communications Setup 
pull-down menu option (see Figure 2.2) before attempting to connect to the 
Evaluation Board.

Figure 2.2:  Communications Setup

Select the Communications Port that matches the one you are using for the 
serial communications with the Evaluation Board, as shown in Figure 2.3.

Figure 2.3:  Communications Port Selection Menu
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Starting Communications

Select the Pull-down menu Options→Enable Eval Board to begin communi-
cations between the GUI Control Panel and the PICDEM™ MSC1, as shown 
in Figure 2.4.

Figure 2.4:  Enable Evaluation Board

Select the Input/Output tab and note the Port A and Port B functions to verify 
that the GUI is communicating with the Evaluation Board.

Serial Communications with the PICDEM™ MSC1 Evaluation Board

Since the PIC16C781/782 does not have a UART peripheral, serial communi-
cations are "bit-banged" with software timing loops. Timing calibration is per-
formed automatically each time the board is enabled. The Evaluation Board 
clock is the internal RC oscillator.

One characteristic of this oscillator is that it may drift slightly in frequency with 
changes in temperature. If you expect to use the Evaluation Board over a 
wide temperature variation, you will need to recalibrate the communication 
timing at each new operating temperature. 

You can recalibrate at any time by de-selecting the PICDEM MSC1 board by 
selecting Options→Enable Eval Board, then selecting Options→Enable Eval 
Board a second time to recalibrate and re-establish communications. When 
the connection is made, all registers will be initialized to the values set in the 
GUI. This procedure of disconnecting, then reconnecting, is also useful if you 
accidentally RESET the PIC16C781/782 with a stray probe or ground strap.

PERIPHERAL ORGANIZATION

The PIC16C781/782 peripherals are organized as tabbed pages (see Figure 
2.1), one for each major peripheral function. These include:

• Input/Output

• Analog-to-Digital Converter (ADC)

• Digital-to-Analog Converter (DAC)

• Comparators and Operational Amplifier

• Programmable Switch Mode Controller (PSMC)

Note: The MCLR function in Port A and the Dgtl Out: RB4 and DGtl In:
RB5 functions are shown in gray when the GUI software is initially
communicating with the Evaluation Board.
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• Timers

• Memory Access

When a configuration change is made, the register(s) affected by the change 
will turn red, calling attention to where the changes occurred. Register values 
cannot be entered directly. However, when the Evaluation Board is active, 
register values may be retrieved from the Evaluation Board by double-clicking 
on the register name. The register font color changes to blue in response.

Changing the Default Font

In some cases, the default font will not fit in the Register Display boxes. You 
can change the font selection and size with the Options->Data Font menu 
option, as shown in Figure 2.5.

Figure 2.5:  Data Font Selection

The best results will be obtained by choosing a scalable fixed-spacing font 
such as Courier New.

Some controls of the GUI are interlocked so that a change to one selection 
automatically selects other controls necessary for the proper operation of the 
selected item. For example, selecting PORTA RA0 as the non-inverting Op 
Amp input automatically selects RA1 as the inverting input and RB3 as the 
Op Amp output.

Special Conventions

A special convention pertains to the following edit boxes:

• PORTA

• PORTB

• Timer0

• Timer1

• Memory Address

• Memory Data

When typing in one of these boxes, the font color changes to red, indicating 
that the entry is local only to that box. When the <Enter> key is pressed, the 
entry in the box is sent to the corresponding register and the font color reverts 
to black. If focus (i.e., clicking outside the box) is moved outside of the edit 
box before the <Enter> key is pressed, the box is restored to its original con-
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tents and no action is taken. When the GUI is actively connected to the Eval-
uation Board, entries are instantly and automatically sent to the PIC16C782.

GLOBAL ITEMS

Items that are global to all the peripherals are located in the GUI outside of the 
tabbed pages (see Figure 2.1). Global items include:

• Special Function Registers

• Internal Voltage Reference Control (VR)

• Display Mode Selection (Binary or HEX)

• Pull-Down Menus

• Edit Boxes for the AVDD and VREF1 voltages

File Menu Functions

Click on the File menu to view the options, as shown in Figure 2.6.

Figure 2.6:  File Menu Options

Except for the Generate Code option, the options on the File Menu are stan-
dard Microsoft Windows functions:

• Open... - allows you to open a previously saved version of the PICDEM 
MSC1 GUI configuration with all the parameters and data to use as a 
starting point for a new configuration.

• Save - allows you to capture and save the GUI information and configu-
ration data as a file.

• Save As... - same as Save, but allows you to change the name of the 
file saved.

• Generate Code... - Creates an Initialization assembly code file that cor-
responds to the selected configuration.

• Exit - Closes and terminates the program.

Note: The AVDD and VREF1 entries are used to compute some of the dis-
play values for the ADC and DAC peripherals, and have no other
effects. If these inputs are known to be different than the values
shown, enter the correct values.
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2.1.2.1 Input/Output

Use the Input/Output tab to configure the Port A and B functions, as shown in 
Figure 2.7. Some of the Port pins can be mixed signal (i.e., they can be either 
digital or analog). I/O functions are fully described in Section 3.0 of the 
PIC16C781/782 Data Sheet (DS41171).

Figure 2.7:  Input/Output Functions

Use drop-down menu
to configure Port bit
functions.

Register values are Read Only. Double-click on register name
to read value from PICDEM MSC1 board.

https://www.application-datasheet.com/
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2.1.2.2 Analog-to-Digital Converter (ADC)

Use the ADC tab to configure the 10 inputs (shown in the ADC Input Select 
area) to the Analog to Digital Converter, as shown in Figure 2.8. The ADC 
allows conversion of an analog input signal to a corresponding 8-bit digital 
value. ADC functions are fully described in Section 9.0 of the PIC16C781/782 
Data Sheet (DS41171).

Figure 2.8:  Analog-to-Digital Converter Peripheral (ADC) Functions

Names change to
correspond with
selected pin
function

Read ADC Continuous Mode checkbox(1)

single ADC read button
ADC - Internal RC clock source - Required when performing
ADC conversions during SLEEP Mode

Note 1: When the Read ADC Continuous Mode is checked, ADC readings are
             automatically updated about 10 times per second.

https://www.application-datasheet.com/
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2.1.2.3 Digital-to-Analog Converter (DAC)

Use the DAC tab to configure the Digital to Analog Converter (DAC) module, 
as shown in Figure 2.9. The DAC module generates an output voltage pro-
portional to the value in the 8-bit DAC Register. DAC functions are fully  
described in Section 10.0 of the PIC16C781/782 Data Sheet (DS41171).

Figure 2.9:  Digital-to-Analog (DAC) Peripheral Functions

Change DAC Output by moving slider or by entering desired value in Output text box

https://www.application-datasheet.com/
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ARBITRARY WAVEFORM

The DAC Arbitrary Waveform function is a utility that provides for sending a 
set of user-defined data bytes to the DAC one byte at a time, with a user-
defined dwell time between each byte. The data set must consist of 2 to 80 
bytes. The dwell time is determined by waiting a user-defined number of 
timer0 count intervals. The utility computes dwell time as a function of :

• Timer0 clock

• Timer0 prescale

• Number of points in the waveform

• User-defined waveform period or frequency parameter.

Timer0 counts must be between 2 and 255. Adjust the paramaters to ensure 
the count is within these limits.

The period of the waveform is defined as the time required for all the wave-
form points to be output.

Two types of waveforms can be computed by the utility:

1. A sine wave (see Figure 2.10)
2. A triangle wave (see Figure 2.11)

An unlimited number of other waveforms can be generated external to the util-
ity and saved as a text file, which the utility can retrieve. Each point of the 
waveform is represented as an integer between 0 and 255. The set of points 
is saved as a text file with one integer per line. If the waveform file contains 
more than 80 integers, the Arbitrary Waveform utility accepts only the first 80.

The DAC data is displayed in the preview window when the waveform is gen-
erated or loaded from a file. Two waveform periods are displayed, so that 
unexpected discontinuities between the last and first data bytes can be identi-
fied. The preview window displays the waveform in an unsmoothed format 
that represents the expected DAC output.

Figures 2.10 and 2.11 show examples of utility generated sine and triangle 
waveforms respectively.
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Figure 2.10:  Sine Wave Example

Figure 2.11:  Triangle Waveform Example

Frequency
Divider for
Timer0/WDT

(Up to 80 max)

The more points
sampled, the smoother
the waveform

Timer Counts must be
between 2 and 255

Frequency
Divider for
Timer0/WDT

(Up to 80 max)

Output of DAC
waveform will
resemble this
stepped pattern
on a scope
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2.1.2.4 Comparators/Op Amp

Use the Comparators/Op Amp tab to configure the two separate voltage com-
parators, C1 and C2, as shown in Figure 2.12. Internal voltage reference is 
provided by the VDAC option for both comparators. An external voltage refer-
ence can be supplied to C1 via the AN3/VREF input and the AN2/VREF2 input 
for C2. You can also use the same tab to configure the Operational Amplifier 
(OPA) module.

The Comparator Module functions are fully described in Section 12.0 of the 
PIC16C781/782 Data Sheet.

The Operational Amplifier (OPA) Module is fully described in Section 11.0 of 
the PIC16C781/782 Data Sheet (DS41171). 

Figure 2.12:  Comparators/Op Amp Peripheral Functions

Calibrate function is enabled only when

Enabling the Op Amp automatically configures the GUI I/O pin functions.
PICDEM MSC1 board is active

https://www.application-datasheet.com/
https://www.application-datasheet.com/


PICDEM™ MSC1 User’s Guide 

DS41178A-page 20  2001 Microchip Technology Inc.

2.1.2.5 Programmable Switch Mode Controller (PSMC)

Use the PSMC tab to configure the PSMC module, as shown in Figure 2.13. 
This module provides all the necessary features to implement a pulsed feed-
back control system. The PSMC generates a pulsed output based on its ana-
log feedback. The Programmable Switch Mode Controller (PSMC) is fully 
described in Section 13.0 of the PIC16C781/782 Data Sheet (DS41171).

Figure 2.13:  PSMC Peripheral Functions

Enabling the PSMC automatically configures the GUI I/O pin functions

https://www.application-datasheet.com/
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2.1.2.6 Timers

Use the Timers tab to configure Timer0 and Timer1, as shown in Figure 2.14. 
Timer0 can operate as either a timer or a counter. The Timer0 Module is 
described in Section 5.0 of the PIC16C781/782 Data Sheet (DS41171). The 
Timer1 module is fully described in Section 6.0 of the PIC16C781/782 Data 
Sheet (DS41171). 

Figure 2.14:  Timers / Peripheral Functions

Internal

External

https://www.application-datasheet.com/
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2.1.2.7 Memory

Use the Memory tab to access Data or Program Memory, as shown in Figure 
2.15. The Memory tab also contains the Configuration Word functions which 
may be changed only when communications between the GUI and the PIC-
DEM™ MSCI Board have been turned off.

Memory Organization is fully described in Section 2.0 of the PIC16C781/782 
Data Sheet (DS41171).

Program Memory Read (PMR) is fully described in Section 4.0 of the 
PIC16C781/782 Data Sheet (DS41171).

Oscillator Configuration is fully described in Section 14.2 of the PIC16C781/
782 Data Sheet (DS41171).

The Brown Out Threshold Voltages are fully described in Section 17.7.4 of the 
PIC16C781/782 Data Sheet (DS41171).

The Configuration bits are fully described in Section 14.1 of the PIC16C781/
782 Data Sheet (DS41171).

Figure 2.15:  Memory Functions

Configuration Setup Tool Area

Note: The Configuration Word Setup Tool Area in the GUI is active only
when the communications with the Evaluation Board have been
turned off. The Configuration Word does not affect the PICDEM
MSC1 board configuration. The Configuration Word is used at the
beginning of Code files.

https://www.application-datasheet.com/
https://www.application-datasheet.com/
https://www.application-datasheet.com/
https://www.application-datasheet.com/
https://www.application-datasheet.com/
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Chapter 3.  Tutorial/Demo

3.1  Digital-to-Analog (DAC) Module Configuration

3.1.1 DAC Module Setup
In this project you will configure a digital-to-analog conversion that requires 
stepping through a series of digital values to produce an analog sine wave 
output. You can utilize the Arbitrary Waveform feature of the PICDEM™ 
MSC1 to set up the conversion parameters and exercise them in a  looping 
environment to allow scoping the output of the DAC. 

In this example, you will perform the setup tasks to:

• Configure a single digital input/output line

• Exercise a conversion loop to allow scoping of the DAC output

• Save the configuration file to be used in your application.

3.1.1.1 Enabling the DAC Module

1. Start the GUI software by selecting Start→Programs→PICDEM MSC1,
or you can double-click the PICDEM MSC1 icon on your desktop. 

2. Select the Pull-down menu Options→Enable Eval Board to begin com-
munications between the GUI Control Panel and the PICDEM™ MSC1.

3. Select the Input/Output tab on the GUI Control Panel, as shown in Figure
3.1.
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Figure 3.1:  Selecting the Input/Output Tab

4. Using the drop-down menu of RB1, select the Anlg Out:VDAC option and
press <Enter>, as shown in Figure 3.2. 

Figure 3.2:  Enabling the VDAC Output

5. Select the DAC tab on the Evaluation Tool Control Panel. The Control
Panel displays the DAC controls, as shown in Figure 3.3. Note the DAC
output is shown enabled.
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Figure 3.3:  DAC Setup Initial Display

The DAC module is controlled by means of four Special Function registers:

• DACON0

• DAC

• TRISB

• ANSEL.

The DACON0 register controls three items:

• Enable/disable the DAC

• Enable DAC output on RB1/AN5/VDAC pins (providing ANSEL<5>=1 
and TRISB<1>=1)

• Selection of reference voltage.

The DAC register holds the digital value to be converted to analog output.

The TRISB and the ANSEL registers are the primary controls for the configu-
ration of PORTB pins.

DACON0 

DAC Output
DAC output 

DAC module

Arbitrary 

button

enabled

enable

enable

Waveform

shows

Note: DACON0 register shows all zeros before the DAC is enabled and
configured.
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The Evaluation Board software has built-in safeguards against performing 
certain functions out of sequence, or executing functions with missing param-
eters. For example, if you were to click the Arbitrary Waveform button (shown 
above) at this point in the configuration, you see the following warning mes-
sage, shown in Figure 3.2:

Figure 3.4:  DAC Warning

This message informs you that the Arbitrary Waveform will not display on the 
DAC output pin unless the DAC output has been enabled, the DAC module is 
turned on, and the timer source is defined as either internal or, if external, 
supplied via jumpering to the clock source input pin. You can ignore the warn-
ing and continue with your configuration by clicking OK, but the output wave-
form will not be available if you have not satisfied the conditions mentioned in 
the warning message.

6. Enable the DAC module by clicking the DAC ON radio button.

The Control Panel changes to appear as shown in Figure 3.3.
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Figure 3.5:  Enabling the DAC Module and Output

7. Select the Timer tab on the Evaluation Board Control Panel. The Timer0
and Timer1 controls display as shown in Figure 3.4. For this example, we
will use the internal clock function, FOSC/4 as the clock source for
Timer0.

DACON0 

DAC module
enabled and
DAC output is
enabled

(in red)

DAC module 
enabled

DAC output

is enabled

shows

is

to RB1
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Figure 3.6:  Clock Source Selection

8. Select FOSC/4 as the source for the internal clock. 

See the PIC16C781/782 Data Sheet (DS41171) for Option Register details.

3.1.1.2 Using the Arbitrary Waveform Feature

The PICDEM™ MSC1 GUI contains an Arbitrary Waveform feature that can 
be used for testing the DAC peripheral. This feature allows you to generate 
sinusoid or triangle wave data to upload to the DAC. You can also load a wave 
data file previously generated and saved as a text file. Wave data files consist 
of integers between 0 and 255, one integer per line. Each line corresponds to 
a waveform data point. Up to 80 points can be specified. If more than 80 
points are in the file, only the first 80 will be used. Less than 80 points will 
automatically RESET the point counter to the number of points specified in 
the file. An example waveform file (ArbWave.txt) is included in the installa-
tion directory.  

9. Select the Arbitrary Waveform button on the DAC control section of the
Control Panel. The Arbitrary Waveform dialog box displays, as shown in
Figure 3.5.

Set clock 

FOSC/4
source to Note

Option_Reg
changes
value when
clock 
source
changes

Note: Bit 5 of the OPTION_REG is set to a zero, indicating the Internal
instruction cycle clock (FOSC/4) has been selected.

https://www.application-datasheet.com/
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Figure 3.7:  Arbitrary Waveform Dialog Box

10. Select the Sine waveform button. The following waveform representing
two periods of a sine wave is displayed, as shown in Figure 3.6:

Figure 3.8:  Sine Waveform Selected

11. Select the GO button. The following message appears, as shown in 
Figure 3.7:

Sine waveform
buttonwaveform

sampling
parameters
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Figure 3.9:  Adjust Prescale Message

12. Set the Prescale ratio to 1:4. This will bring the Timer Count down to 250,
as shown in Figure 3.8.

Figure 3.10:  Setting the Prescaler

13.  Click the GO button to start the DAC output loop execution. The GO but-
ton changes to STOP.

Note: When you change the Prescale setting, the Timer Count changes to
a new value. The timer counts parameter is Read Only. Timer
Counts are automatically computed as a function of Timer0 fre-
quency, number of points, period (or frequency), and prescaler
value. You can decrease the Timer Count by increasing the pre-
scale ratio.

Set Prescale to
1:4 to change
Line Count to
250
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At this point the firmware is performing a troubleshooting loop on the digital-
to-analog conversion. You can now scope the output of the DAC module to 
see the actual waveform as it approximates a sine wave analog output. To 
stop the loop, click the STOP button. If you want to make the waveform steps 
smoother, increase the number of points to 80 and press <Enter>. Then 
recompute the 80 point sine wave by selecting the Sine Button. The sinewave 
changes to the one shown in Figure 3.9.

Figure 3.11:  Smoothing the Waveform

3.1.1.3 Generating a Code File

The PICDEM™ MSC1 includes a Code Generator that will write an initializa-
tion assembly code file corresponding to the selected configuration.

If you want a Configuration Word different from the PICDEM MSC1 configura-
tion, you will need to turn off communications between the Evaluation Board 
and the GUI:

Note: The Prescale values are grayed out when the timing loop is active.
While the timing loop is active, you cannot change parameters. To
change any parameters, you must stop the loop by clicking the
STOP button or the EXIT button.

Increasing the Number of
Points to 80 makes the
Sine Waveform smoother
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1. Select the Pull-down menu Options→Enable Eval Board to uncheck this
selection and stop communications between the GUI Control Panel and
the PICDEM™ MSC1.

2. Select the Memory tab of the PICDEM™ MSC1 control panel. The Con-
figuration Word section of the panel is now active, as shown in Figure
3.10.

3. Select the desired Configuration Word parameters for your application.

Figure 3.12:  Configuration Word Functions

4. Select the Generate Code option from the File menu, as shown in Figure
3.11.

Figure 3.13:  Generate Code Option

A File Dialog displays, asking you to choose a folder or location for storing the 
*.inc file that will be generated. The generated file will look similar to the 
one shown in Figure 3.12.
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Figure 3.14:  Sample Generated Code File

     __CONFIG   0x3FFF
     org      0x000
     goto     Initialize

     org      0x004
; Insert interrupt service routine here

Initialize

     BANKSEL   PORTA

     movlw     0x20
     movwf     PORTA
     movlw     0xF0
     movwf     PORTB
     movlw     0x00
     movwf     T1CON
     movlw     0x00
     movwf     ADCON0

     BANKSEL   ANSEL

     movlw     0xFF
     movwf     ANSEL
     movlw     0xFF
     movwf     WPUB
     movlw     0xFF
     movwf     TRISA
     movlw     0xFF
     movwf     TRISB
     movlw     0x00
     movwf     REFCON
       movlw     0x00
     movwf     ADCON1
     movlw     0xFF
     movwf     OPTION_REG

     BANKSEL   DACON0

     movlw     0x00
     movwf     DACON0
     movlw     0x00
     movwf     CM1CON0
     movlw     0x00
     movwf     CM2CON0
     movlw     0x00
     movwf     CM2CON1
          movlw     0x00
     movwf     OPACON
     movlw     0x00
     movwf     CALCON
     movlw     0x00
          movwf     PSMCCON0
     movlw     0x00
          movwf     PSMCCON1
; Insert user code here
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NOTES:
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Appendix A.  PICDEM™ MSC1 Schematics

A.1 Introduction
This appendix contains schematics associated with the PICDEM™ MSC1.

A.2 Highlights
Topics covered in this appendix:

• Evaluation Board Schematic

• Parts Placement

• Evaluation Board Hardware

• Evaluation Board Firmware.
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A.3 Schematics

Figure A.1:  PICDEM™ MSC1 Schematic

A
V

S
S

A
V

D
D

A
V

S
S

A
V

D
D

A
V

D
D A
V

S
S

A
V

S
S

O
S

C
1

R
A

0
R

B
0

O
S

C
1

A
V

S
S

D
IG

S
U

P
A

N
S

U
P

A
V

D
D

+
5V

+
5V

A
V

S
S

33
0

R
4

R
3

A
V

S
S

1
T

PP
1

T
P

-6
0R

38

D
5

R
E

D

D
6

R
E

D

D
4

R
E

D

+
5V

+
5V

2
C

W
R

8
10

K
P

O
T

-3
35

2E

D
7

R
E

D

T
P

P
2

T
P

-6
0R

38

1 3 2

J2

D
J0

05
B

D
3

1N
40

01

Y
1

4M
H

z

R
E

S
O

N
A

T
O

R
-Z

T
T

X
1

F
ID

U
C

IA
L_

P
P

X
2

F
ID

U
C

IA
L_

P
P

33
0

R
1

33
0

R
2

+
5V

R
15

3.
3K

R
16

3.
3K

R
14

3.
3K

21
4 3

S
1

S
W

-B
3F

10
00

+
5V

4
V

C
C

3
O

U
T

2
G

N
D

1 N
C

/O
EY
2

O
S

C
_C

A
N

X
3

F
ID

U
C

IA
L_

P
P

3
O

U
T

1
IN

U
4

LM
29

37
-I

M
P

-5
.0

3
O

U
T

1 IN

U
1

LM
29

37
-I

M
P

-5
.0

+
5V

R
17

3.
3K

J3

S
IP

_4

9
P

IN
9

8
P

IN
8

7
P

IN
7

6
P

IN
6

1
P

IN
1

2
P

IN
2

3
P

IN
3

4
P

IN
4

5
P

IN
5

D
E

9S
-F

R
S

J147
0

R
13

4
M

C
LR

R
A

4/
T

O
C

K
I

5
V

S
S

6
A

V
S

S

15
A

V
D

D
16

V
D

D

1
R

A
0

R
A

1

R
A

2

R
A

3

9
R

B
0/

IN
T

10
R

B
1

11
R

B
4

12
R

B
5

13
R

B
6

14
R

B
7

19
R

B
2

20
R

B
3

17
O

S
C

2/
C

LK
O

U
T

18
O

S
C

1/
C

LK
IN

U
2

P
IC

16
C

78
X

_D
IP

40
39

38
37

36
35

34
33

32
31

30
29

28
27

26
25

24
23

22
21

20
19

18
17

16
151311

10
9

8
7

6
5

4
3

2
1

12 14

H
D

R
2X

20
O

/E

J5

12P
H

D
R

J4

47
0

R
10

1
C

1+

6
V

-

3
C

1-

12
R

1O
U

T
9

R
2O

U
T

11
T

1I
N

10
T

2I
N

2
V

+

14
T

1O
U

T
7

T
2O

U
T

13
R

1I
N

8
R

2I
N

5
C

2-

4
C

2+

U
3

T
C

23
2_

M
A

X
23

2A

2C
W

C
C

W

R
9

10
K

P
O

T
-3

35
2E

47
0

R
12

J6

47K

R
A

6

Red

Red

R7

R5
D23.3K

3.3K D1

A
V

D
D

A
V

S
S

+
5V

R
A

7
R

B
3

R
B

2
R

A
0

R
A

1
R

A
4

R
A

5
R

B
7

R
B

6

R
A

2
R

B
5

R
A

3
R

B
0

R
B

1
R

B
4

33pF

C13

R6

RC mode

33pF

C14
2PHDR R

A
6

12

2
R

A
7R11

0.1µF

C1
R

A
1

2

R
A

2
7

R
A

3
8

R
A

4
3

R
A

5

R
B

1

R
B

2

R
B

3

R
B

4

R
B

5

R
B

6

R
B

7

R
B

5

.1µf

C15

R
B

4

1µf

1µf

C9

C6

1µf

C7

16 VCC GND 15

.1µf

C2

1µf

C8

33
0

3 1

1

1 2 3 4

C
C

W

A
V

S
S

A
V

D
D 3 1

J7

.1µF

C10

C5

D
IG

S
U

P

1µF

C11

A
N

S
U

P

COM 2

A
V

S
S

.1µF

C12
47µF

C4

2COM

.1µf

C3

+
5V

V
B

A
T

4 0 P I N H E A D E R

 10µF

O
P

T
IO

N
A

L
(N

O
T

 IN
S

TA
LL

E
D

)



 2001 Microchip Technology Inc. DS41178A-page 37

PICDEM™ MSC1 Schematics

Figure A.2:  Parts Placement Diagram

PICDEM™ MSC1 HARDWARE

The supplied Evaluation Board consists of:

• A PIC16C782 with the MONITOR firmware

• Dual linear 5 volt DC supplies

• An RS-232 interface

• A generous prototyping area (see Figure A.2).

D7 pin
D6 pin
D5 pin
D4 pin LED D4

LED D5
LED D6

LED D7

AVDD LED 
VDD LED 

VDD Jumper 
AVDD Jumper 

+9VDC Connector 

RS-232 Connector

Master Clear (MCLR) Pushbutton 

General Purpose
Bus Lines

Remove these 2 jumpers when using external oscillator
Optional Plug in crystal or resonator here

Optional Plug in external oscillator here

Prototyping Area

40-pin header 

Note: There are four General Purpose Bus Lines provided in the Proto-
typing Area for distributing signals across the area (see Figure
A.2).
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A 40-pin header between the PIC16C782 and the prototype area is intended 
for jumpering prototype circuitry to the PIC16C782 or expanding the prototype 
area by plugging a pre-made circuit onto the evaluation board. The VDD and 
AVDD jumpers connect the on-board linear regulators to the PIC16C782 cir-
cuit and prototype areas. Removal of these jumpers allows for supply volt-
ages and capacity other than that provided by the on-board five volt 
regulators. The RS-232 interface is two lines, asynchronous without hand-
shaking. Connection to the PC is via a 9-pin subminiature D connector, wired 
for a standard 9-conductor serial port cable.

EVALUATION BOARD FIRMWARE

The Evaluation Board firmware is a simple monitor program that provides 
read access to any of the PIC16C781/782 Special Function and memory data 
registers or program locations. The firmware also provides write access to 
any of the Special Function and data registers. The RS-232 interface is "bit-
banged," since the PIC16C781/782 does not contain a USART peripheral. 
Immediately after a RESET, the firmware enters a Search mode for baud rate 
calibration. The first character must be a ten-bit serial sequence composed of:

• Start bit (zero)

• Seven consecutive data zeros

• A one data bit

• A stop bit (one).

This is equivalent to sending a H’80’ character from a serial port set up for:

• Eight data bits

• One start bit

• One stop bit

• No parity. 

You can communicate with the PICDEM™ MSC1 Evaluation Board directly 
from a PC with a hyperterminal window setup as just described with a baud 
rate of 9600 or less, and local echo turned off. Immediately after the Evalua-
tion Board Reset, send the calibration character from the hyperterminal win-
dow by typing <Alt>(0128). In other words, hold down the <Alt> key down 
while typing the four Key Pad numbers 0, 1, 2, 8 in sequence, then release 
the <Alt> key. The Num Lock function must be enabled and the Key Pad num-
bers must be used instead of the number keys at the top of the keyboard. 
Confirm proper calibration by typing the <Enter> key. The Evaluation Board 
will respond with the ’>’ character. All characters are echoed by the Evaluation 
Board firmware. Only those sequences corresponding to an actual command 
will be processed. See the MONITOR.ASM file for details about the command 
protocol. Baud rate recalibration can be remotely requested by sending a 
break character that is at least three times the character time of the most 
recent calibration. 
A Break can be sent from the Hyperterminal by typing <CTRL><BREAK> 
together.

Note: The AVDD and VDD jumpers must be in place as shown when the
internal supply is the primary power source.
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